<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
			<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="https://gmpg.org/xfn/11">
		<meta name="theme-color" content="#630a1f">
	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Optimized by SG Optimizer plugin version - 5.7.20 -->
	<!-- This site is optimized with the Yoast SEO plugin v16.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>BOYS BASKETBALL: Scots Shock Top Seed ~ Calexico Chronicle</title><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin/><style type="text/css">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://fonts.gstatic.com/s/opensans/v20/mem8YaGs126MiZpBA-UFW50e.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(https://fonts.gstatic.com/s/oswald/v36/TK3_WkUHHAIjg75cFRf3bXL8LICs169vsUhiYA.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(https://fonts.gstatic.com/s/oswald/v36/TK3_WkUHHAIjg75cFRf3bXL8LICs1xZosUhiYA.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: italic;
  font-weight: 400;
  font-display: swap;
  src: url(https://fonts.gstatic.com/s/playfairdisplay/v22/nuFRD-vYSZviVYUb_rj3ij__anPXDTnCjmHKM4nYO7KN_qiTXt_A_A.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKdFvXDZbtY.ttf) format('truetype');
}
@font-face {
  font-family: 'Playfair Display';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(https://fonts.gstatic.com/s/playfairdisplay/v22/nuFvD-vYSZviVYUb_rj3ij__anPXJzDwcbmjWBN2PKeiunDZbtY.ttf) format('truetype');
}
</style><link rel="preload" as="font" href="https://fonts.googleapis.com/css?family=Open+Sans%3A400&ver=5.7.2" crossorigin/><link rel="preload" as="font" href="https://fonts.googleapis.com/css?family=Playfair+Display%3A700%2Citalic%2C400%7COswald%3A300%2C700&subset=latin%2Clatin-ext&display=swap" crossorigin/><link rel="preload" as="font" href="https://calexicochronicle.com/wp-content/themes/zeen/assets/css/tipi/tipi.woff2?9oa0lg" crossorigin/><link rel="preload" as="font" href="https://calexicochronicle.com/wp-content/plugins/awesome-weather/fonts/weathericons-regular-webfont.woff2" crossorigin/><link rel="stylesheet" id="siteground-optimizer-combined-css-39ecccfb59bd4ada14ebe236db5b48e7" href="https://calexicochronicle.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-39ecccfb59bd4ada14ebe236db5b48e7.css" media="all" />
	<meta name="description" content="Vincent beats Liberty Charter, 63-55, in the CIF-SDS Division V playoffs and will next face No. 4 St. Joseph Academy." />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="BOYS BASKETBALL: Scots Shock Top Seed ~ Calexico Chronicle" />
	<meta property="og:description" content="Vincent beats Liberty Charter, 63-55, in the CIF-SDS Division V playoffs and will next face No. 4 St. Joseph Academy." />
	<meta property="og:url" content="https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/" />
	<meta property="og:site_name" content="Calexico Chronicle" />
	<meta property="article:publisher" content="https://www.facebook.com//calexicochronicle.ivweekly/" />
	<meta property="article:published_time" content="2021-06-08T03:25:14+00:00" />
	<meta property="article:modified_time" content="2021-06-08T03:25:19+00:00" />
	<meta property="og:image" content="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg" />
	<meta property="og:image:width" content="1092" />
	<meta property="og:image:height" content="728" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Calexico Chronicle">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://calexicochronicle.com/#organization","name":"Calexico Chronicle","url":"https://calexicochronicle.com/","sameAs":["https://www.facebook.com//calexicochronicle.ivweekly/","https://www.instagram.com/calexicochronicle/"],"logo":{"@type":"ImageObject","@id":"https://calexicochronicle.com/#logo","inLanguage":"en-US","url":"https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png","contentUrl":"https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png","width":190,"height":50,"caption":"Calexico Chronicle"},"image":{"@id":"https://calexicochronicle.com/#logo"}},{"@type":"WebSite","@id":"https://calexicochronicle.com/#website","url":"https://calexicochronicle.com/","name":"Calexico Chronicle","description":"Chronicling our community, border region, and beyond since 1904","publisher":{"@id":"https://calexicochronicle.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://calexicochronicle.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#primaryimage","inLanguage":"en-US","url":"https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg","contentUrl":"https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg","width":1092,"height":728,"caption":"Vincent Memorial Catholic High\u2019s Jose Itturribe lofts a shot over Calexico High junior Julian Beltran (33) during their Imperial Valley League game earlier this season in Calexico. The Scots have advanced to the CIF-San Diego Section Division V semifinals while the Bulldogs were eliminated in the Division III quarterfinals. | CAMILO GARCIA JR. PHOTO"},{"@type":"WebPage","@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#webpage","url":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/","name":"BOYS BASKETBALL: Scots Shock Top Seed ~ Calexico Chronicle","isPartOf":{"@id":"https://calexicochronicle.com/#website"},"primaryImageOfPage":{"@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#primaryimage"},"datePublished":"2021-06-08T03:25:14+00:00","dateModified":"2021-06-08T03:25:19+00:00","description":"Vincent beats Liberty Charter, 63-55, in the CIF-SDS Division V playoffs and will next face No. 4 St. Joseph Academy.","breadcrumb":{"@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/"]}]},{"@type":"BreadcrumbList","@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://calexicochronicle.com/","url":"https://calexicochronicle.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://calexicochronicle.com/category/sports/","url":"https://calexicochronicle.com/category/sports/","name":"Sports"}},{"@type":"ListItem","position":3,"item":{"@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#webpage"}}]},{"@type":["Article","NewsArticle"],"@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#article","isPartOf":{"@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#webpage"},"author":{"@id":"https://calexicochronicle.com/#/schema/person/3c7976341401d41e9ea2f64e0fa43194"},"headline":"BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis","datePublished":"2021-06-08T03:25:14+00:00","dateModified":"2021-06-08T03:25:19+00:00","mainEntityOfPage":{"@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#webpage"},"wordCount":556,"publisher":{"@id":"https://calexicochronicle.com/#organization"},"image":{"@id":"https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/#primaryimage"},"thumbnailUrl":"https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg","keywords":["boys basketball","Calexico Bulldogs","Calexico High","CIF-San Diego Section","high school basketball","high school sports","playoffs","Vincent Memorial High","Vincent Scots"],"articleSection":["Sports"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://calexicochronicle.com/#/schema/person/3c7976341401d41e9ea2f64e0fa43194","name":"Calexico Chronicle","url":"https://calexicochronicle.com/author/calexicochronicle/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//use.typekit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; Feed" href="https://calexicochronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; Comments Feed" href="https://calexicochronicle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis Comments Feed" href="https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/calexicochronicle.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>

<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>






<style id='zeen-style-inline-css' type='text/css'>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</style>




<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='login-with-ajax-js-extra'>
/* <![CDATA[ */
var LWA = {"ajaxurl":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/plugins/login-with-ajax/login-with-ajax.js' id='login-with-ajax-js'></script>
<script type='text/javascript' id='eio-lazy-load-js-extra'>
/* <![CDATA[ */
var eio_lazy_vars = {"exactdn_domain":"","skip_autoscale":"0","threshold":"0"};
/* ]]> */
</script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/ewww-image-optimizer/includes/lazysizes.min.js' id='eio-lazy-load-js'></script>
<script defer type='text/javascript' src='https://use.typekit.net/idb6qbc.js?ver=5.7.2' id='zeen-tk-js'></script>
<script defer type='text/javascript' id='zeen-tk-js-after'>
try{Typekit.load({ async: true });}catch(e){}
</script>
<!--[if IE]>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/ie9.js' id='zeen-ie9-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://calexicochronicle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://calexicochronicle.com/wp-json/wp/v2/posts/161124" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://calexicochronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://calexicochronicle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://calexicochronicle.com/?p=161124' />
<link rel="alternate" type="application/json+oembed" href="https://calexicochronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://calexicochronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.19 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-2 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-3 {  margin: 0 auto; }
	.g-4 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-5 { width:100%; max-width:729px; height:100%; max-height:90px; margin: 0 auto; }
	.g-6 {  margin: 0 auto; }
	.g-8 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-9 {  margin: 0 auto; }
	.g-10 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<!-- Advance Canonical URL (Basic) --><link rel="canonical" content="https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/"><!-- Advance Canonical URL --><!-- HFCM by 99 Robots - Snippet # 2: Facebook Pixel Code -->
<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '502023807663205');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=502023807663205&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
<!-- /end HFCM by 99 Robots -->
<!-- HFCM by 99 Robots - Snippet # 3: Google Analytics Code -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-149073942-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-149073942-1');
</script>

<!-- /end HFCM by 99 Robots -->
<link rel="preload" type="font/woff2" as="font" href="https://calexicochronicle.com/wp-content/themes/zeen/assets/css/tipi/tipi.woff2?9oa0lg" crossorigin="anonymous"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin="anonymous"><noscript><style>.lazyload[data-src]{display:none !important;}</style></noscript><style>.lazyload{background-image:none !important;}.lazyload:before{background-image:none !important;}</style>				<style id="uagb-style-conditional-extension">@media (min-width: 1025px){body .uag-hide-desktop.uagb-google-map__wrap,body .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){body .uag-hide-tab.uagb-google-map__wrap,body .uag-hide-tab{display:none}}@media (max-width: 767px){body .uag-hide-mob.uagb-google-map__wrap,body .uag-hide-mob{display:none}}</style>
			<link rel="icon" href="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-100x100.png" sizes="32x32" />
<link rel="icon" href="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-228x228.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-228x228.png" />
<meta name="msapplication-TileImage" content="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-300x300.png" />
		<style type="text/css" id="wp-custom-css">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</style>
		<link rel="dns-prefetch" href="//holtvilletribune.com" data-set-by="SG Optimizer"/><link rel="dns-prefetch" href="//cdn.holtvilletribune.com" data-set-by="SG Optimizer"/></head>
<body class="post-template-default single single-post postid-161124 single-format-standard headings-f1 body-f2 sub-f1 quotes-f1 by-f3 wh-f2 to-top__fixed block-titles-big block-titles-mid-1 body--mobile--limit menu-no-color-hover mob-fi-tall skin-light zeen-sb-sticky-off mm-ani-3 site-mob-menu-a-2 site-mob-menu-4 mm-submenu-1 main-menu-logo-1 body-header-style-2 body-hero-m byline-font-2">
		<div id="page" class="site">
		<div id="mob-line" class="tipi-m-0"></div><header id="mobhead" class="site-header-block site-mob-header tipi-m-0 site-mob-header-1 site-mob-menu-4 sticky-menu-mob sticky-menu-2 sticky-menu site-skin-3 site-img-1"><div class="bg-area header-padding tipi-row tipi-vertical-c">
	<ul class="menu-left icons-wrap tipi-vertical-c">
		<li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-move" data-title="Search" data-type="search"></a></li>
			
	
			
			
	
		</ul>
	<div class="logo-main-wrap logo-mob-wrap">
		<div class="logo logo-mobile"><a href="https://calexicochronicle.com" data-pin-nopin="true"><img src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-190x50.png" alt=""  data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-Mobile-DarkArtboard-7@0.5x.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7@2x.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-Mobile-DarkArtboard-7.png 2x" width="190" height="50" data-src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7@2x.png 2x" class="lazyload"><noscript><img src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7@2x.png 2x" data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-Mobile-DarkArtboard-7@0.5x.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7@2x.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-Mobile-DarkArtboard-7.png 2x" width="190" height="50" data-eio="l"></noscript></a></div>	</div>
	<ul class="menu-right icons-wrap tipi-vertical-c">
		<li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li>
			
	
			
			
	
			
			
			<li class="menu-icon menu-icon-mobile-slide"><a href="#" class="mob-tr-open" data-target="slide-menu"><i class="tipi-i-menu-mob" aria-hidden="true"></i></a></li>
	
		</ul>
	<div class="background"></div></div>
</header><!-- .site-mob-header -->		<div class="site-inner">
			<div id="secondary-wrap" class="secondary-wrap tipi-xs-0 clearfix font-3 mm-ani-3 secondary-menu-skin-3 secondary-menu-width-1"><div class="menu-bg-area"><div class="menu-content-wrap clearfix tipi-vertical-c tipi-row">	<nav id="secondary-navigation" class="secondary-navigation rotatable tipi-xs-0">
		<ul id="menu-secondary" class="menu-secondary horizontal-menu tipi-flex menu-secondary ul-padding row font-3 main-menu-skin-3 main-menu-bar-color-2 mm-skin-4 mm-submenu-1 mm-ani-3">
			<li class="current-date menu-padding date--secondary">June 7, 2021</li><li class="trending-inline dropper drop-it mm-art mm-wrap"><a href="#" id="trending-secondary" class="main-title-wrap"><i class="tipi-i-trend-2 tipi-trending-icon"></i><span class="trending-text">TRENDING NOW</span></a><div class="trending-inline-drop menu tipi-row"><div class="trending-inline-title clearfix"><div class="trending-op-title">Trending</div></div><div class="trending-inline-wrap"><div class="block-wrap tipi-doc-info clearfix">To display trending posts, please ensure the Jetpack plugin is installed and that the Stats module of Jetpack is active. Refer to the theme documentation for help.</div></div></div></li>		</ul>
	</nav><!-- .secondary-navigation -->
<ul class="horizontal-menu menu-icons ul-padding tipi-vertical-c tipi-flex-r secondary-icons"><li  class="menu-icon menu-icon-style-1 menu-icon-fb"><a href="https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly" data-title="Facebook" class="tipi-i-facebook tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-tw"><a href="https://twitter.com/https://www.twitter.com/holtvilletribu1" data-title="Twitter" class="tipi-i-twitter tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-insta"><a href="https://instagram.com/https://www.instagram.com/calexicochronicle" data-title="Instagram" class="tipi-i-instagram tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-yt"><a href="https://youtube.com/https://www.youtube.com/watch?v=6ReaUBW2Ygk&#038;list=UUJ4rDxLDu1Bk-pnEzWDoP-A" data-title="YouTube" class="tipi-i-youtube-play tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="YouTube" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-rss"><a href="https://calexicochronicle.com/feed/" data-title="RSS" class="tipi-i-rss tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="RSS" target="_blank"></a></li><li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li>
			
	
	</ul></div></div></div><header id="masthead" class="site-header-block site-header clearfix site-header-2 header-width-1 header-skin-3 site-img-1 mm-ani-3 mm-skin-4 main-menu-skin-3 main-menu-width-1 main-menu-bar-color-2 logo-only-when-stuck main-menu-c" data-pt-diff="0" data-pb-diff="0"><div class="bg-area">
	<div class="tipi-flex-lcr logo-main-wrap header-padding tipi-flex-eq-height logo-main-wrap-center tipi-row">
						<div class="logo-main-wrap header-padding tipi-all-c"><div class="logo logo-main"><a href="https://calexicochronicle.com" data-pin-nopin="true"><img src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-595x94.png" alt="Calexico Chronicle Logo: Chronicling Our Community, Border Region, and Beyond Since 1904"  data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-DarkArtboard-4.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1@2x.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-DarkArtboard-4@2x.png 2x" width="595" height="94" data-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1.png" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1@2x.png 2x" class="lazyload"><noscript><img src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1.png" alt="Calexico Chronicle Logo: Chronicling Our Community, Border Region, and Beyond Since 1904" srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1@2x.png 2x" data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-DarkArtboard-4.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1@2x.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-DarkArtboard-4@2x.png 2x" width="595" height="94" data-eio="l"></noscript></a></div></div>							</div>
	<div class="background"></div></div>
</header><!-- .site-header --><div id="header-line"></div><nav id="site-navigation" class="main-navigation main-navigation-1 tipi-xs-0 clearfix logo-only-when-stuck main-menu-skin-3 main-menu-width-1 main-menu-bar-color-2 mm-skin-4 mm-submenu-1 mm-ani-3 main-menu-c sticky-menu-dt sticky-menu sticky-menu-3">	<div class="main-navigation-border menu-bg-area">
		<div class="nav-grid clearfix tipi-row">
			<div class="tipi-flex sticky-part sticky-p1">
				<div class="logo-menu-wrap logo-menu-wrap-placeholder"></div>				<ul id="menu-main-menu" class="menu-main-menu horizontal-menu tipi-flex font-3">
					<li id="menu-item-157700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157700"><a href="https://calexicochronicle.com/">Home</a></li>
<li id="menu-item-157701" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157701"><a href="https://calexicochronicle.com/category/featured-stories/" data-ppp="3" data-tid="9"  data-term="category">Top Stories</a><div class="menu mm-11 tipi-row" data-mm="11"><div class="menu-wrap menu-wrap-more-10 tipi-flex"><div id="block-wrap-157701" class="block-wrap-native block-wrap block-wrap-61 block-css-157701 block-wrap-classic columns__m--1 elements-design-2 block-skin-0 filter-wrap-2 tipi-box tipi-row ppl-m-3 ppl-s-3 clearfix" data-id="157701" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block-title-wrap module-block-title clearfix  block-title-1 with-load-more" style="border-bottom-color:#630a1f;"><div class="block-title-area clearfix"><div class="block-title font-1">Top Stories</div><div class="block-subtitle font-1"><p>Covering stories that matter to the community.</p>
</div></div><div class="filters tipi-flex font-2"><div class="load-more-wrap load-more-size-2 load-more-wrap-2">		<a href="#" data-id="157701" class="tipi-arrow tipi-arrow-s tipi-arrow-l block-loader block-more block-more-1 no-more" data-dir="1"><i class="tipi-i-angle-left" aria-hidden="true"></i></a>
		<a href="#" data-id="157701" class="tipi-arrow tipi-arrow-s tipi-arrow-r block-loader block-more block-more-2" data-dir="2"><i class="tipi-i-angle-right" aria-hidden="true"></i></a>
		</div></div></div><div class="block block-61 tipi-flex preview-review-bot"><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-0 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-161023 post type-post status-publish format-standard has-post-thumbnail hentry category-featured-stories category-public-safety category-regional-news tag-coachella-canal tag-crime tag-east-jesus tag-homicide tag-imperial-county-news tag-imperial-county-sheriffs-office-2 tag-marilyn-monroe-cazares tag-murder-investigation tag-nashville tag-niland tag-oliver tag-poe-delwyn-black tag-slab-city tag-tommi-deane-jackson tag-transgender-male"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/06/06/poes-final-stop-is-last-free-place/" class="mask-img"><img width="449" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/06/Coachella-Canal-library-Siphon-7-6-4-449x299.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/Coachella-Canal-library-Siphon-7-6-4-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/Coachella-Canal-library-Siphon-7-6-4-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/Coachella-Canal-library-Siphon-7-6-4-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/Coachella-Canal-library-Siphon-7-6-4-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/Coachella-Canal-library-Siphon-7-6-4-1234x822.jpg 1234w" data-lazy-sizes="(max-width: 449px) 100vw, 449px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/06/poes-final-stop-is-last-free-place/">Poe’s Final Stop is Last Free Place</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-1 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-161007 post type-post status-publish format-standard has-post-thumbnail hentry category-featured-stories category-regional-news tag-awareness tag-el-centro-news tag-imperial-county-news tag-imperial-valley-lgbt-resource-center tag-lgbtq tag-outreach tag-pride-month tag-rosa-diaz tag-stonewall-uprising"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/06/05/rosa-diaz-leads-local-lgbtq-evolution/" class="mask-img"><img width="449" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/06/Pride-Profile-Rosa-Diaz-Horizontal-crop-6-5-449x299.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/Pride-Profile-Rosa-Diaz-Horizontal-crop-6-5-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/Pride-Profile-Rosa-Diaz-Horizontal-crop-6-5-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/Pride-Profile-Rosa-Diaz-Horizontal-crop-6-5-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/Pride-Profile-Rosa-Diaz-Horizontal-crop-6-5-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/Pride-Profile-Rosa-Diaz-Horizontal-crop-6-5-1234x822.jpg 1234w" data-lazy-sizes="(max-width: 449px) 100vw, 449px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/05/rosa-diaz-leads-local-lgbtq-evolution/">Pioneer in Pride: Rosa Diaz Leads Local LGBTQ ‘Evolution’</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-2 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-160844 post type-post status-publish format-standard has-post-thumbnail hentry category-covid19 category-featured-stories category-regional-news tag-your-actions-save-lives tag-arlene-mejorado tag-awareness-campaign tag-branded-arts tag-california-department-of-public-health tag-center-at-sierra-health-foundation tag-covid tag-covid-19 tag-el-centro-news tag-ernesto-yerena-montejano tag-imperial-county-news tag-josh-valencia tag-officer-efren-coronel tag-public-art tag-shepard-fairey"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/06/02/ernesto-yerenas-covid-mural-a-mass-memorial/" class="mask-img"><img width="449" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/06/Mural-Progress-3747-RICH-5-29-449x299.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/Mural-Progress-3747-RICH-5-29-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/Mural-Progress-3747-RICH-5-29-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/Mural-Progress-3747-RICH-5-29-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/Mural-Progress-3747-RICH-5-29-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/Mural-Progress-3747-RICH-5-29-1234x822.jpg 1234w" data-lazy-sizes="(max-width: 449px) 100vw, 449px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/02/ernesto-yerenas-covid-mural-a-mass-memorial/">COVID Mural A Mass Memorial</a></h3></div></div></div></article></div></div></div></div></div></div></li>
<li id="menu-item-157702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157702"><a href="#">Sections</a><div class="menu mm-2 tipi-row" data-mm="2"><div class="menu-wrap menu-wrap-minus-10">
<ul class="sub-menu">
	<li id="menu-item-157705" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157705"><a href="https://calexicochronicle.com/category/featured-stories/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Featured Stories" data-url="https://calexicochronicle.com/category/featured-stories/" data-subtitle="Covering stories that matter to the community." data-count="283" data-tid="9"  data-term="category">Featured Stories</a></li>
	<li id="menu-item-157703" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157703"><a href="https://calexicochronicle.com/category/local-news/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Local News" data-url="https://calexicochronicle.com/category/local-news/" data-subtitle="The Calexico Chronicle has you covered with all your local news. Stay informed about community, school, sports, and any other news that matters to you." data-count="583" data-tid="11"  data-term="category">Local News</a></li>
	<li id="menu-item-157704" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157704"><a href="https://calexicochronicle.com/category/regional-news/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Regional News" data-url="https://calexicochronicle.com/category/regional-news/" data-subtitle="Get your Imperial Valley news here. We go beyond the &#039;instant news&#039;. We like to dig deeper and get to the root of the story. " data-count="484" data-tid="15"  data-term="category">Regional News</a></li>
	<li id="menu-item-157707" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent dropper drop-it menu-item-157707"><a href="https://calexicochronicle.com/category/sports/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Sports" data-url="https://calexicochronicle.com/category/sports/" data-subtitle="" data-count="105" data-tid="16"  data-term="category">Sports</a></li>
	<li id="menu-item-157706" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157706"><a href="https://calexicochronicle.com/category/public-safety/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Public Safety" data-url="https://calexicochronicle.com/category/public-safety/" data-subtitle="" data-count="125" data-tid="14"  data-term="category">Public Safety</a></li>
	<li id="menu-item-157708" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157708"><a href="https://calexicochronicle.com/category/opinion/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Opinion" data-url="https://calexicochronicle.com/category/opinion/" data-subtitle="" data-count="48" data-tid="13"  data-term="category">Opinion</a></li>
	<li id="menu-item-157712" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157712"><a href="https://calexicochronicle.com/category/education/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Education" data-url="https://calexicochronicle.com/category/education/" data-subtitle="" data-count="36" data-tid="7"  data-term="category">Education</a></li>
	<li id="menu-item-157710" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157710"><a href="https://calexicochronicle.com/category/business/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Business" data-url="https://calexicochronicle.com/category/business/" data-subtitle="" data-count="60" data-tid="4"  data-term="category">Business</a></li>
	<li id="menu-item-157709" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157709"><a href="https://calexicochronicle.com/category/agriculture/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Agriculture" data-url="https://calexicochronicle.com/category/agriculture/" data-subtitle="" data-count="18" data-tid="3"  data-term="category">Agriculture</a></li>
	<li id="menu-item-157711" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157711"><a href="https://calexicochronicle.com/category/community-briefs/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Community Briefs" data-url="https://calexicochronicle.com/category/community-briefs/" data-subtitle="" data-count="76" data-tid="5"  data-term="category">Community Briefs</a></li>
	<li id="menu-item-157713" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157713"><a href="https://calexicochronicle.com/category/obituaries/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Obituaries" data-url="https://calexicochronicle.com/category/obituaries/" data-subtitle="" data-count="1" data-tid="12"  data-term="category">Obituaries</a></li>
	<li id="menu-item-157714" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157714"><a href="https://calexicochronicle.com/category/covid19/" class="block-more block-mm-changer block-mm-init block-changer" data-title="COVID-19" data-url="https://calexicochronicle.com/category/covid19/" data-subtitle="Stay up-to-date with the latest local developments on the COVID-19 Pandemic.
Follow us on Facebook &lt;a href=&quot;https://www.facebook.com/calexicochronicle.ivweekly/&quot;&gt;@calexicochronicle.ivweekly&lt;/a&gt; to receive immediate updates." data-count="251" data-tid="6"  data-term="category">COVID-19</a></li>
</ul></div></div>
</li>
<li id="menu-item-157715" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157715"><a href="https://calexicochronicle.com/category/legal-notices/" data-ppp="3" data-tid="10"  data-term="category">Legal Notices</a><div class="menu mm-11 tipi-row" data-mm="11"><div class="menu-wrap menu-wrap-more-10 tipi-flex"><div id="block-wrap-157715" class="block-wrap-native block-wrap block-wrap-61 block-css-157715 block-wrap-classic columns__m--1 elements-design-2 block-skin-0 filter-wrap-2 tipi-box tipi-row ppl-m-3 ppl-s-3 clearfix" data-id="157715" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block-title-wrap module-block-title clearfix  block-title-1 with-load-more" style="border-bottom-color:#630a1f;"><div class="block-title-area clearfix"><div class="block-title font-1">Legal Notices</div></div><div class="filters tipi-flex font-2"><div class="load-more-wrap load-more-size-2 load-more-wrap-2">		<a href="#" data-id="157715" class="tipi-arrow tipi-arrow-s tipi-arrow-l block-loader block-more block-more-1 no-more" data-dir="1"><i class="tipi-i-angle-left" aria-hidden="true"></i></a>
		<a href="#" data-id="157715" class="tipi-arrow tipi-arrow-s tipi-arrow-r block-loader block-more block-more-2" data-dir="2"><i class="tipi-i-angle-right" aria-hidden="true"></i></a>
		</div></div></div><div class="block block-61 tipi-flex preview-review-bot"><article class="tipi-xs-12 elements-location-3 clearfix no-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-0 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-160950 post type-post status-publish format-standard hentry category-legal-notices"><div class="preview-mini-wrap clearfix"><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/04/legal-notices-june-3-2021/">LEGAL NOTICES: June 3, 2021</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix no-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-1 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-160643 post type-post status-publish format-standard hentry category-legal-notices"><div class="preview-mini-wrap clearfix"><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/05/27/legal-notices-may-27-2021/">LEGAL NOTICES: May 27, 2021</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix no-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-2 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-160384 post type-post status-publish format-standard hentry category-legal-notices"><div class="preview-mini-wrap clearfix"><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/05/21/legal-notices-may-20-2021/">LEGAL NOTICES: May 20, 2021</a></h3></div></div></div></article></div></div></div></div></div></div></li>
<li id="menu-item-157716" class="menu-item menu-item-type-post_type menu-item-object-page dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157716"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li id="menu-item-157717" class="menu-item menu-item-type-post_type menu-item-object-page dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157717"><a href="https://calexicochronicle.com/about/">About Us</a></li>
				</ul>
				<ul class="horizontal-menu font-3 menu-icons tipi-flex-eq-height">
										<li class="menu-icon drop-search-wrap menu-icon-search"><a href="#" class="tipi-i-search modal-tr" data-type="search-drop"></a>
				<div class="drop-search search-form-wrap widget_search clearfix"><form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
<div class="content-found-wrap"><div class="content-found"></div><div class="button-wrap"><a class="search-all-results button-arrow-r button-arrow tipi-button" href="#"><span class="button-title">See all results</span><i class="tipi-i-arrow-right"></i></a></div></div></div></li>
			
	
										</ul>
			</div>
			<div id="sticky-p2" class="sticky-part sticky-p2"><div class="sticky-p2-inner tipi-vertical-c"><div class="title-wrap"><span class="pre-title reading">Reading</span><div class="title" id="sticky-title">BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis</div></div><div id="sticky-p2-share" class="share-it tipi-vertical-c"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="https://twitter.com/intent/tweet?via=https://www.twitter.com/holtvilletribu1&#038;text=BOYS%20BASKETBALL%3A%20Scots%20Shock%20Top%20Seed%2C%20Move%20to%20Semis%20-%20https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i><span class="social-tip font-base font-1">Tweet</span></span></a></div></div></div>		</div>
		<span id="progress" class=" no-ipl"></span>	</div>
</nav><!-- .main-navigation -->
			<div id="content" class="site-content clearfix">
			<div id="primary" class="content-area">

	<div class="post-wrap clearfix article-layout-skin-1 title-beneath hero-m sidebar-on sidebar-right post-161124 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-boys-basketball tag-calexico-bulldogs tag-calexico-high tag-cif-san-diego-section tag-high-school-basketball tag-high-school-sports tag-playoffs tag-vincent-memorial-high tag-vincent-scots">
		<div class="hero-wrap clearfix hero-11 tipi-row content-bg medium-uncrop no-par"><div class="hero"><a href="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg" class="mask-img tipi-lightbox"><img width="1092" height="728" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-1092x728.png" class="flipboard-image wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg 1092w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-300x200.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-1024x683.jpg 1024w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-849x566.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-500x333.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-372x248.jpg 372w" data-sizes="auto" /><noscript><img width="1092" height="728" src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg" class="flipboard-image wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg 1092w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-300x200.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-1024x683.jpg 1024w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-849x566.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-500x333.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-372x248.jpg 372w" sizes="(max-width: 1092px) 100vw, 1092px" data-eio="l" /></noscript></a></div><div class="caption">Vincent Memorial Catholic High’s Jose Itturribe lofts a shot over Calexico High junior Julian Beltran (33) during their Imperial Valley League game earlier this season in Calexico. The Scots have advanced to the CIF-San Diego Section Division V semifinals while the Bulldogs were eliminated in the Division III quarterfinals. | CAMILO GARCIA JR. PHOTO</div></div>		<div class="single-content contents-wrap tipi-row content-bg clearfix article-layout-1">
						<div class="tipi-cols clearfix sticky--wrap">
				<main class="site-main tipi-xs-12 main-block-wrap block-wrap tipi-l-8 tipi-col clearfix">
		<article>
				<div class="breadcrumbs-wrap breadcrumbs-sz-
	m	">
		<div class="breadcrumbs">
											<div class="crumb">
									<a href="https://calexicochronicle.com">
									<span>Home</span>
									</a>
								</div>
											<i class="tipi-i-chevron-right"></i>				<div class="crumb">
									<a href="https://calexicochronicle.com/category/sports/">
									<span>Sports</span>
									</a>
								</div>
									</div>
	</div>
	<div class="meta-wrap hero-meta tipi-m-typo elements-design-2 clearfix"><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/sports/" class="cat">Sports</a></div></div><div class="title-wrap title-with-sub"><h1 class="entry-title title flipboard-title">BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis</h1>	<p class="subtitle flipboard-subtitle font-1">Vincent Beats Liberty Charter, 63-55, in Division V Playoffs, Will Next Face No. 4 St. Joseph Academy.</p>
	</div><div class="byline byline-3"><span class="byline-part author-avatar flipboard-author with-name"><a href="https://calexicochronicle.com/author/calexicochronicle/" class="author-avatar"></a></span><span class="byline-part author"><a href="https://calexicochronicle.com/author/calexicochronicle/" title="Posts by Calexico Chronicle" class="author url fn" rel="author">Calexico Chronicle</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-06-07T20:25:14-07:00">June 7, 2021</time></span></div></div></div><!-- .meta-wrap -->			<div class="entry-content-wrap clearfix">
									<div class="share-it share-it-11 share-it-icons share-it-count-0 share-it-before"><div class="title">Share</div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class="tipi-tip tipi-tip-move share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i></span></a><a href="https://twitter.com/intent/tweet?via=https://www.twitter.com/holtvilletribu1&#038;text=BOYS%20BASKETBALL%3A%20Scots%20Shock%20Top%20Seed%2C%20Move%20to%20Semis%20-%20https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class="tipi-tip tipi-tip-move share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i></span></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F&media=https%3A%2F%2Fcalexicochronicle.com%2Fwp-content%2Fuploads%2F2021%2F06%2FCLXVMBoysBasketballMAIN-6-10-849x566.jpg&description=BOYS%20BASKETBALL%3A%20Scots%20Shock%20Top%20Seed%2C%20Move%20to%20Semis" class="tipi-tip tipi-tip-move share-button share-button-pin" rel="noopener nofollow" aria-label="Pin" data-title="Pin" target="_blank" data-pin-custom="true"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-pinterest"></i></span></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class="tipi-tip tipi-tip-move share-button share-button-li" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-linkedin"></i></span></a><a href="https://reddit.com/submit?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class="tipi-tip tipi-tip-move share-button share-button-re" rel="noopener nofollow" aria-label="Submit" data-title="Submit" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-reddit-alien"></i></span></a><a href="mailto:?body=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class="tipi-tip tipi-tip-move share-button share-button-em" rel="noopener nofollow" aria-label="Email" data-title="Email" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-mail"></i></span></a><a href="whatsapp://send?text=BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis – https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class="tipi-tip tipi-tip-move tipi-xl-0 share-button share-button-wa" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-whatsapp"></i></span></a><a href="fb-messenger://share/?link=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class="tipi-tip tipi-tip-move tipi-xl-0 share-button share-button-msg" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-messenger"></i></span></a></div>												<div class="entry-content body-color clearfix link-color-wrap">
																										
<p>LEMON GROVE — Vincent Memorial Catholic High School’s boys’ basketball team put on Cinderella’s slippers, went to the party and shook things up in the CIF-San Diego Section Division V playoffs with a stunning 63-55 upset of top-seeded Liberty Charter here on Friday, June 4.</p>



<p>The eighth-seeded Scots got 29 points from Landon Blaisdell, who hit seven three-point shots in the quarterfinal upset.</p>



<p>“You could see throughout the game the team developing that trust that we hadn’t seen all season,” said Hector Vildosola, Vincent Memorial’s first-year head coach. “It was a really quick season and we had a tough schedule all year, but we thought we had the talent to stun some teams if everything fell into place.”</p>



<p>Benjamin Garza had 12 points for the Scots, including eight in the decisive fourth quarter. Blaisdell hit four three-pointers in the fourth quarter and went 6-for-6 from the free-throw line as well. Pancho Perez Tejada chipped in with nine points for Vincent Memorial.</p>



<p>“That camaraderie and team chemistry just continued to grow as the game went on and they all started trusting each other,” Vildosola said. “So now the stage is set for us to continue our Cinderella story.”</p>



<p>Early in the game, Liberty Charter built an eight-point lead and led 17-12 at the end of the first quarter. Vincent Memorial cut the lead to 26-22 at halftime and then pulled into a 36-36 tie at the end of the third quarter. A huge 27-point fourth quarter sealed the deal for the Scots and pushed them into the semifinals.</p>



<p>Vincent Memorial will be back on the road for the semifinals, facing fourth-seeded St. Joseph Academy of San Marcos at 7 p.m. on Tuesday, June 8.</p>



<p>In the other Division V semifinal, Palo Verde Valley High of Blythe is traveling to face Crawford High of San Diego at 7 p.m. June 8, with the winners of those two games set to meet in the championship game at 7:30 p.m. Thursday, June 10, at Serra High School in San Diego.</p>



<p><strong>Bulldogs Fall in Quarterfinals</strong></p>



<p>SAN DIEGO — After a dominating effort in the first round, the Calexico High School boys’ basketball team couldn’t get a repeat performance and lost to Hoover High, 81-52, in the CIF-San Diego Section Division III quarterfinals here on Friday, June 4.</p>



<p>The 12<sup>th</sup>-seeded Bulldogs, who didn’t play a game between May 10 and June 1, delivered a 70-43 win over Granite Hills in El Cajon on Tuesday, June 1. But three days later the rust caught up with them in the loss at Hoover.</p><p><div class="inline-post clearfix"><div class="see-also byline">See also</div><div id="block-wrap-60168" class="block-wrap-native block-wrap block-wrap-23 block-css-60168 block-wrap-classic columns__m--1 elements-design-2 block-ani block-skin-0 tipi-box block-wrap-thumbnail ppl-m-1 clearfix" data-id="60168" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block block-23 clearfix"><article class="tipi-xs-12 clearfix with-fi ani-base tipi-xs-typo split-1 split-design-1 loop-0 preview-thumbnail preview-23 elements-design-2 post-159286 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-bell-game tag-brawley-union-high tag-brawley-wildcats tag-central-spartans tag-central-union-high tag-high-school-football tag-high-school-sports tag-imperial-valley-league tag-ivl tag-rivalry-game"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/04/17/football-big-plays-lead-spartans-to-bell-win/" class="mask-img"><img width="100" height="100" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-100x100.png" class="attachment-thumbnail size-thumbnail wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-100x100.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-979x979.jpg 979w" data-sizes="auto" /><noscript><img width="100" height="100" src="https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-100x100.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/04/Bell-Game-Brawley-vs-Central-03-979x979.jpg 979w" sizes="(max-width: 100px) 100vw, 100px" data-eio="l" /></noscript></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/sports/" class="cat">Sports</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/17/football-big-plays-lead-spartans-to-bell-win/">FOOTBALL: Big Plays Lead Spartans to Bell Game Win</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/murrayanderson/" title="Posts by Murray Anderson" class="author url fn" rel="author">Murray Anderson</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-04-17T11:50:32-07:00">April 17, 2021</time></span></div></div></div></article></div></div></div></div></div></p>



<p>The fourth-seeded Cardinals jumped out to a massive 27-6 lead at the end of the first quarter against the Bulldogs and cruised home for the victory.</p>



<p>The loss means it won’t be back-to-back CIF-SDS championships for Calexico after winning the Division IV championship in 2020.</p>



<p>“Give all the credit to Hoover. That is a really good team. They are big, athletic and aggressive,” said Hugo Estrada, Calexico’s third-year head coach. “We hadn’t seen a team play that type of defense with that pressure in more than a year.”</p>



<p>Sophomore Aidan Carrasco and junior Julian Beltran led the Bulldogs with 14 points each.</p>



<p>“We’ve got nine kids coming back next season and this was good experience to get a game against this level of team,” Estrada said.</p>
									</div><!-- .entry-content -->
							</div><!-- .entry-content -->

			<footer class="entry-footer">
				<div class="mobile--limiter--wrap tipi-m-0"><a href="#" class="mobile--limiter tipi-button"><span class="mobile--limiter--on">Show More <i class="tipi-i-angle-down"></i></span></a></div><div class="post-tags footer-block-links clearfix"><div class="title">Tags</div><div class="block-elements"><a href="https://calexicochronicle.com/tag/boys-basketball/" rel="tag">boys basketball</a><a href="https://calexicochronicle.com/tag/calexico-bulldogs/" rel="tag">Calexico Bulldogs</a><a href="https://calexicochronicle.com/tag/calexico-high/" rel="tag">Calexico High</a><a href="https://calexicochronicle.com/tag/cif-san-diego-section/" rel="tag">CIF-San Diego Section</a><a href="https://calexicochronicle.com/tag/high-school-basketball/" rel="tag">high school basketball</a><a href="https://calexicochronicle.com/tag/high-school-sports/" rel="tag">high school sports</a><a href="https://calexicochronicle.com/tag/playoffs/" rel="tag">playoffs</a><a href="https://calexicochronicle.com/tag/vincent-memorial-high/" rel="tag">Vincent Memorial High</a><a href="https://calexicochronicle.com/tag/vincent-scots/" rel="tag">Vincent Scots</a></div></div><div class="share-it share-it-2 share-it-bold share-it-count-0 share-it-after tipi-flex"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="https://twitter.com/intent/tweet?via=https://www.twitter.com/holtvilletribu1&#038;text=BOYS%20BASKETBALL%3A%20Scots%20Shock%20Top%20Seed%2C%20Move%20to%20Semis%20-%20https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i><span class="social-tip font-base font-1">Tweet</span></span></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F&media=https%3A%2F%2Fcalexicochronicle.com%2Fwp-content%2Fuploads%2F2021%2F06%2FCLXVMBoysBasketballMAIN-6-10-849x566.jpg&description=BOYS%20BASKETBALL%3A%20Scots%20Shock%20Top%20Seed%2C%20Move%20to%20Semis" class=" share-button share-button-pin" rel="noopener nofollow" aria-label="Pin" data-title="Pin" target="_blank" data-pin-custom="true"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-pinterest"></i><span class="social-tip font-base font-1">Pin</span></span></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" share-button share-button-li" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-linkedin"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="https://reddit.com/submit?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" share-button share-button-re" rel="noopener nofollow" aria-label="Submit" data-title="Submit" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-reddit-alien"></i><span class="social-tip font-base font-1">Submit</span></span></a><a href="mailto:?body=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" share-button share-button-em" rel="noopener nofollow" aria-label="Email" data-title="Email" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-mail"></i><span class="social-tip font-base font-1">Email</span></span></a><a href="whatsapp://send?text=BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis – https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" tipi-xl-0 share-button share-button-wa" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-whatsapp"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="fb-messenger://share/?link=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F06%2F07%2Fboys-basketball-scots-shock-top-seed%2F" class=" tipi-xl-0 share-button share-button-msg" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-messenger"></i><span class="social-tip font-base font-1">Share</span></span></a></div><div class="user-page-box-1 user-box-skin-1 user-box-type-1 tipi-xs-12 user-page-box clearfix">		<div class="mask">
			<a href="https://calexicochronicle.com/author/calexicochronicle/">
								<span class="overlay-arrow-r overlay-arrow"><i class="tipi-i-long-right"></i></span>
			</a>
		</div>
		<div class="meta">
			<div class="author-info-wrap">
				<div class="author-name font-1"><a href="https://calexicochronicle.com/author/calexicochronicle/">Calexico Chronicle</a></div>
							</div>
			<div class="author-right-meta">
												<div class="icons">
														</div>
			</div>
		</div>
	</div>
	<div class="related-posts-wrap clearfix"><div id="block-wrap-40936" class="block-wrap-native block-wrap block-wrap-27 block-css-40936 block-wrap-classic columns__m--1 elements-design-2 block-skin-0 filter-wrap-2 tipi-box ppl-m-3 ppl-s-3 clearfix" data-id="40936" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block-title-wrap module-block-title clearfix  block-title-wrap-style block-title-1 with-load-more" style="border-bottom-color:#630a1f;"><div class="block-title-area clearfix"><div class="block-title font-1">Related</div></div><div class="filters tipi-flex font-2"><div class="load-more-wrap load-more-size-2 load-more-wrap-2">		<a href="#" data-id="40936" class="tipi-arrow tipi-arrow-s tipi-arrow-l block-loader block-more block-more-1 no-more" data-dir="1"><i class="tipi-i-angle-left" aria-hidden="true"></i></a>
		<a href="#" data-id="40936" class="tipi-arrow tipi-arrow-s tipi-arrow-r block-loader block-more block-more-2" data-dir="2"><i class="tipi-i-angle-right" aria-hidden="true"></i></a>
		</div></div></div><div class="block block-27 tipi-flex"><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base article-ani article-ani-1 tipi-s-typo stack-1 stack-design-1 separation-border loop-0 preview-classic preview__img-shape-s preview-27 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-161127 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-calexico-bulldogs tag-calexico-high tag-calexico-news tag-cif-san-diego-section tag-high-school-sports tag-high-school-track-and-field tag-madison-longton tag-track-and-field tag-track-and-field-finals"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/track-field-bulldogs-longton-in-cif-finals/" class="mask-img"><img width="469" height="469" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-469x469.png" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-469x469.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-979x979.jpg 979w" data-sizes="auto" /><noscript><img width="469" height="469" src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-469x469.jpg" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-979x979.jpg 979w" sizes="(max-width: 469px) 100vw, 469px" data-eio="l" /></noscript></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/sports/" class="cat">Sports</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/07/track-field-bulldogs-longton-in-cif-finals/">TRACK &#038; FIELD: Bulldogs’ Longton Running in CIF Finals</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/murrayanderson/" title="Posts by Murray Anderson" class="author url fn" rel="author">Murray Anderson</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-06-07T20:35:32-07:00">June 7, 2021</time></span></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base article-ani article-ani-1 tipi-s-typo stack-1 stack-design-1 separation-border loop-1 preview-classic preview__img-shape-s preview-27 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-161075 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-calexico-bulldogs tag-calexico-high-school tag-cif-san-diego-section tag-high-school-basketball tag-high-school-sports tag-vincent-memorial-high-school"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/girls-basketball-bulldogs-scots-ousted-from-playoffs/" class="mask-img"><img width="469" height="384" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-469x384.png" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image lazyload" alt="" data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMGirlsBasketball2-PREVIEW-and-ONLINE-MAIN-469x384.jpg" /><noscript><img width="469" height="384" src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMGirlsBasketball2-PREVIEW-and-ONLINE-MAIN-469x384.jpg" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" data-eio="l" /></noscript></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/sports/" class="cat">Sports</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/07/girls-basketball-bulldogs-scots-ousted-from-playoffs/">GIRLS BASKETBALL: Bulldogs, Scots Ousted from Playoffs</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/staff-report/" title="Posts by STAFF REPORT" class="author url fn" rel="author">STAFF REPORT</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-06-07T10:43:17-07:00">June 7, 2021</time></span></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base article-ani article-ani-1 tipi-s-typo stack-1 stack-design-1 separation-border loop-2 preview-classic preview__img-shape-s preview-27 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-160798 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-calexico-bulldogs tag-calexico-high-school tag-cif-san-diego-section-division-iii tag-high-school-softball tag-high-school-sports"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/06/01/softball-bulldogs-wait-and-hope-for-playoff-berth/" class="mask-img"><img width="469" height="469" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-469x469.png" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-469x469.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-979x979.jpg 979w" data-sizes="auto" /><noscript><img width="469" height="469" src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-469x469.jpg" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXSoftballMAIN-6-3-979x979.jpg 979w" sizes="(max-width: 469px) 100vw, 469px" data-eio="l" /></noscript></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/sports/" class="cat">Sports</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/01/softball-bulldogs-wait-and-hope-for-playoff-berth/">SOFTBALL: Bulldogs Wait and Hope for Playoff Berth</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/murray-anderson/" title="Posts by Murray Anderson" class="author url fn" rel="author">Murray Anderson</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-06-01T11:13:46-07:00">June 1, 2021</time></span></div></div></div></article></div></div></div></div></div>			</footer><!-- .entry-footer -->
		</article><!-- #post-x -->
	</main><!-- .site-main -->
	
<div class="block clearfix sidebar-wrap sb-wrap-skin-1 tipi-xs-12 tipi-l-4 tipi-col">
		<aside class="sidebar widget-area bg-area site-img-1 sb-skin-1 widgets-title-skin-4 widgets-skin-4">
		<div class="background"></div>
		<div id="adrotate_widgets-6" class="sidebar-widget zeen-widget clearfix adrotate_widgets"><div class="g g-8"><div class="g-single a-35"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MzUsOCwxLDYw" href="https://calexicochronicle.com/wp-content/uploads/2021/05/20210511100354092-WO.pdf" target="_blank"><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://calexicochronicle.com/wp-content/uploads/2021/05/20210511100354092-WO.png" class="lazyload" /><noscript><img src="https://calexicochronicle.com/wp-content/uploads/2021/05/20210511100354092-WO.png" data-eio="l" /></noscript></a></div></div></div></div><div id="search-3" class="sidebar-widget zeen-widget clearfix widget_search"><h3 class="widget-title title">Search Our Site:</h3><form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
</div><div id="zeen_facebook_like_box-6" class="sidebar-widget zeen-widget clearfix zeen_facebook_like_box">		<div class="fb-page"
			  data-href="https://www.facebook.com/https://www.facebook.com/calexicochronicle.ivweekly"
			  data-width="600"
			  data-hide-cover="false"
			  data-show-facepile="true"
			  data-small-header="false"
			  data-tabs="timeline"
			  data-show-posts="false"></div>

	<div id="fb-root"></div>
	<script>(function(d, s, id) {
		var js, fjs = d.getElementsByTagName(s)[0];
		if (d.getElementById(id)) return;
		js = d.createElement(s); js.id = id;
		js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2';
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script>

		</div><div id="lets_social_count-4" class="sidebar-widget zeen-widget clearfix lets_social_count"><h3 class="widget-title title">We&#8217;re Social! Let&#8217;s Connect:</h3>		<ul class="lets-social-count-wrap lets-social-count-3 clearfix">
											<li class="network-option network-fb">
								<a href="https://facebook.com/calexicochronicle.ivweekly" target="_blank" rel="noopener nofollow"><span class="icon-wrap"><i class="tipi-i-facebook lsc-facebook"></i></span><span class="icon-content"><span class="icon-action">Like</span><span class="icon-count">7,500</span><span class="icon-title">Fans</span>				</span>
			</a>
			</li>
											<li class="network-option network-in">
								<a href="https://www.instagram.com/calexicochronicle" target="_blank" rel="noopener nofollow"><span class="icon-wrap"><i class="tipi-i-instagram lsc-instagram"></i></span><span class="icon-content"><span class="icon-action">Follow</span><span class="icon-count">656</span><span class="icon-title">Followers</span>				</span>
			</a>
			</li>
											<li class="network-option network-yt">
								<a href="https://www.youtube.com/channel/UCJ4rDxLDu1Bk-pnEzWDoP-A/featured" target="_blank" rel="noopener nofollow"><span class="icon-wrap"><i class="tipi-i-youtube-play lsc-youtube-play"></i></span><span class="icon-content"><span class="icon-action">Subscribe</span><span class="icon-count">13</span><span class="icon-title">Subscribers</span>				</span>
			</a>
			</li>
				</ul>

		</div><div id="adrotate_widgets-7" class="sidebar-widget zeen-widget clearfix adrotate_widgets"><div class="g g-9"><div class="g-single a-12"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MTIsOSwxLDYw" href="http://www.goldenacorncasino.com/players-club-intro.php"><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://calexicochronicle.com/wp-content/banners/golden_acorn_ad_12-19_300x250.jpg" class="lazyload" /><noscript><img src="https://calexicochronicle.com/wp-content/banners/golden_acorn_ad_12-19_300x250.jpg" data-eio="l" /></noscript></a></div></div></div></div><div id="media_video-2" class="sidebar-widget zeen-widget clearfix widget_media_video"><h3 class="widget-title title">Recent News Videos</h3><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-161124-1" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=lc86LBS4G4s&#038;list=UL&#038;_=1" /><a href="https://www.youtube.com/watch?v=lc86LBS4G4s&#038;list=UL">https://www.youtube.com/watch?v=lc86LBS4G4s&#038;list=UL</a></video></div></div><div id="adrotate_widgets-8" class="sidebar-widget zeen-widget clearfix adrotate_widgets"><div class="g g-10"><div class="g-single a-37"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MzcsMTAsMSw2MA==" href="https://www.cetys.mx/yourlocaluniversity"><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://calexicochronicle.com/wp-content/uploads/2021/05/SurCa_Holtville_News_periodico-01-scaled.jpeg" class="lazyload" /><noscript><img src="https://calexicochronicle.com/wp-content/uploads/2021/05/SurCa_Holtville_News_periodico-01-scaled.jpeg" data-eio="l" /></noscript></a></div></div></div></div><div id="zeen_stylish_posts-4" class="sidebar-widget zeen-widget clearfix zeen_stylish_posts"><h3 class="widget-title title">Trending News</h3><div class="zeen-stylish-posts-wrap"><div id="block-wrap-88281" class="block-wrap-native block-wrap block-wrap-55 block-css-88281 block-wrap-slider block-wrap-tiles columns__m--1 elements-design-3 block-skin-0 tipi-box tile-design-wrap-1 rounded-corners clearfix" data-id="88281" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="slider slider-art tipi-spin clearfix" data-ppp="1" data-dir="0" data-s="55" data-effect="0"><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-1 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-161127 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-calexico-bulldogs tag-calexico-high tag-calexico-news tag-cif-san-diego-section tag-high-school-sports tag-high-school-track-and-field tag-madison-longton tag-track-and-field tag-track-and-field-finals"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/track-field-bulldogs-longton-in-cif-finals/" class="mask-img"><img width="449" height="299" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-449x299.png" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-449x299.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-300x200.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1024x683.jpg 1024w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-849x566.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1536x1024.jpg 1536w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-500x333.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1234x822.jpg 1234w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-372x248.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1479x986.jpg 1479w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10.jpg 1920w" data-sizes="auto" /><noscript><img width="449" height="299" src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-449x299.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-300x200.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1024x683.jpg 1024w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-849x566.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1536x1024.jpg 1536w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-500x333.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1234x822.jpg 1234w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-372x248.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-1479x986.jpg 1479w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10.jpg 1920w" sizes="(max-width: 449px) 100vw, 449px" data-eio="l" /></noscript></a><a href="https://calexicochronicle.com/2021/06/07/track-field-bulldogs-longton-in-cif-finals/" class="mask-overlay" aria-label="TRACK &#038; FIELD: Bulldogs’ Longton Running in CIF Finals"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/murrayanderson/" title="Posts by Murray Anderson" class="author url fn" rel="author">Murray Anderson</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/sports/" style="background-color:#630a1f" class="cat cat-with-bg">Sports</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/07/track-field-bulldogs-longton-in-cif-finals/">TRACK &#038; FIELD: Bulldogs’ Longton Running in CIF Finals</a></h3></div></div></article><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-2 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-161124 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-boys-basketball tag-calexico-bulldogs tag-calexico-high tag-cif-san-diego-section tag-high-school-basketball tag-high-school-sports tag-playoffs tag-vincent-memorial-high tag-vincent-scots"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/" class="mask-img"><img width="449" height="299" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-449x299.png" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-449x299.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-300x200.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-1024x683.jpg 1024w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-849x566.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-500x333.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-372x248.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg 1092w" data-sizes="auto" /><noscript><img width="449" height="299" src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-449x299.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-300x200.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-1024x683.jpg 1024w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-849x566.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-500x333.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10-372x248.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXVMBoysBasketballMAIN-6-10.jpg 1092w" sizes="(max-width: 449px) 100vw, 449px" data-eio="l" /></noscript></a><a href="https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/" class="mask-overlay" aria-label="BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/calexicochronicle/" title="Posts by Calexico Chronicle" class="author url fn" rel="author">Calexico Chronicle</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/sports/" style="background-color:#630a1f" class="cat cat-with-bg">Sports</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/07/boys-basketball-scots-shock-top-seed/">BOYS BASKETBALL: Scots Shock Top Seed, Move to Semis</a></h3></div></div></article><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-3 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-161099 post type-post status-publish format-standard has-post-thumbnail hentry category-regional-news tag-covid tag-covid-19 tag-el-centro-news tag-entertainment tag-imperial-county-news tag-lil-cholo tag-lucha-libre tag-luchadors tag-professional-wrestling tag-venue-wrestling-entertainment tag-vwe"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/luchadors-get-love-from-imperial-valley-crowd/" class="mask-img"><img width="449" height="299" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-449x299.png" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-449x299.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-1234x822.jpg 1234w" data-sizes="auto" /><noscript><img width="449" height="299" src="https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-449x299.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-1234x822.jpg 1234w" sizes="(max-width: 449px) 100vw, 449px" data-eio="l" /></noscript></a><a href="https://calexicochronicle.com/2021/06/07/luchadors-get-love-from-imperial-valley-crowd/" class="mask-overlay" aria-label="Luchadors Get Love from Imperial Valley"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/marcie-landeros/" title="Posts by Marcie Landeros" class="author url fn" rel="author">Marcie Landeros</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/regional-news/" style="background-color:#630a1f" class="cat cat-with-bg">Regional News</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/07/luchadors-get-love-from-imperial-valley-crowd/">Luchadors Get Love from Imperial Valley</a></h3></div></div></article><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-4 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-161095 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety tag-bolo tag-crime tag-crown-motel tag-el-centro-news tag-el-centro-police tag-public-safety tag-shooting"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/shooting-at-el-centro-motel-leaves-man-critical/" class="mask-img"><img width="449" height="299" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-449x299.png" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-449x299.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-1234x822.jpg 1234w" data-sizes="auto" /><noscript><img width="449" height="299" src="https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-449x299.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/06/CROWN-Motel-6-7-1234x822.jpg 1234w" sizes="(max-width: 449px) 100vw, 449px" data-eio="l" /></noscript></a><a href="https://calexicochronicle.com/2021/06/07/shooting-at-el-centro-motel-leaves-man-critical/" class="mask-overlay" aria-label="Shooting at El Centro Motel Leaves Man Critical"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/richardmontenegro/" title="Posts by Richard Montenegro Brown" class="author url fn" rel="author">Richard Montenegro Brown</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/public-safety/" style="background-color:#630a1f" class="cat cat-with-bg">Public Safety</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/06/07/shooting-at-el-centro-motel-leaves-man-critical/">Shooting at El Centro Motel Leaves Man Critical</a></h3></div></div></article><span class="slider-arrow slider-arrow-prev slider-arrow-2"><i class="tipi-i-angle-left"></i></span><span class="slider-arrow slider-arrow-next slider-arrow-2"><i class="tipi-i-angle-right"></i></span></div></div></div></div></div></div>	</aside><!-- .sidebar -->
</div>
			</div><!-- .tipi-cols -->
					</div><!-- .tipi-row -->
			</div><!-- .post-wrap -->
		
</div><!-- .content-area -->
		</div><!-- .site-content -->
				<footer id="colophon" class="site-footer site-footer-2 site-img-1 widget-area-borders-1 footer-fs  widget-title-default footer__mob__cols-2 clearfix">
			<div class="bg-area">
								<div class="bg-area-inner">
										<div class="footer-widget-area footer-widget-bg-area footer-widgets tipi-xs-12 clearfix footer-widget-area-5 footer-widgets-skin-3 site-img-1">
	<div class="footer-widget-bg-area-inner tipi-flex tipi-row footer-widget-mob-area tipi-xs-12 tipi-m-0 clearfix">
	<div class="tipi-xs-12 footer-widget-wrap footer-widget-wrap-1 clearfix">
		<aside class="sidebar widget-area">
			<div id="search-4" class="footer-widget footer-widget-mob zeen-widget clearfix widget_search"><h3 class="widget-title title">Search</h3><form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
</div><div id="categories-3" class="footer-widget footer-widget-mob zeen-widget clearfix widget_categories"><h3 class="widget-title title">Sections</h3>
			<ul>
					<li class="cat-item cat-item-3"><a href="https://calexicochronicle.com/category/agriculture/">Agriculture</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://calexicochronicle.com/category/business/">Business</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://calexicochronicle.com/category/community-briefs/">Community Briefs</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://calexicochronicle.com/category/covid19/" title="Stay up-to-date with the latest local developments on the COVID-19 Pandemic.
Follow us on Facebook @calexicochronicle.ivweekly to receive immediate updates.">COVID-19</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://calexicochronicle.com/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://calexicochronicle.com/category/election-coverage/">Election Coverage</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://calexicochronicle.com/category/featured-stories/" title="Covering stories that matter to the community.">Featured Stories</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a>
</li>
	<li class="cat-item cat-item-11"><a href="https://calexicochronicle.com/category/local-news/" title="The Calexico Chronicle has you covered with all your local news. Stay informed about community, school, sports, and any other news that matters to you.">Local News</a>
</li>
	<li class="cat-item cat-item-12"><a href="https://calexicochronicle.com/category/obituaries/">Obituaries</a>
</li>
	<li class="cat-item cat-item-13"><a href="https://calexicochronicle.com/category/opinion/">Opinion</a>
</li>
	<li class="cat-item cat-item-14"><a href="https://calexicochronicle.com/category/public-safety/">Public Safety</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://calexicochronicle.com/category/regional-news/" title="Get your Imperial Valley news here. We go beyond the &#039;instant news&#039;. We like to dig deeper and get to the root of the story. ">Regional News</a>
</li>
	<li class="cat-item cat-item-16"><a href="https://calexicochronicle.com/category/sports/">Sports</a>
</li>
			</ul>

			</div><div id="pages-3" class="footer-widget footer-widget-mob zeen-widget clearfix widget_pages"><h3 class="widget-title title">Services</h3>
			<ul>
				<li class="page_item page-item-144531"><a href="https://calexicochronicle.com/about/">About Us</a></li>
<li class="page_item page-item-155865"><a href="https://calexicochronicle.com/advertising/">Advertising</a></li>
<li class="page_item page-item-144857"><a href="https://calexicochronicle.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-155882"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li class="page_item page-item-155880"><a href="https://calexicochronicle.com/archived-eeditions/">Older E-Editions</a></li>
<li class="page_item page-item-144866"><a href="https://calexicochronicle.com/subscribe/">Subscribe</a></li>
			</ul>

			</div>		</aside><!-- .sidebar .widget-area -->
	</div>
</div><!-- .footer-widget-area -->
	<div class="footer-widget-bg-area-inner tipi-flex tipi-row tipi-xs-0">
					<div class="tipi-xs-6 footer-widget-wrap footer-widget-wrap-1 clearfix">
				<aside class="sidebar widget-area">
					<div id="categories-2" class="footer-widget zeen-widget clearfix widget_categories"><h3 class="widget-title title">Sections</h3>
			<ul>
					<li class="cat-item cat-item-3"><a href="https://calexicochronicle.com/category/agriculture/">Agriculture</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://calexicochronicle.com/category/business/">Business</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://calexicochronicle.com/category/community-briefs/">Community Briefs</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://calexicochronicle.com/category/covid19/" title="Stay up-to-date with the latest local developments on the COVID-19 Pandemic.
Follow us on Facebook @calexicochronicle.ivweekly to receive immediate updates.">COVID-19</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://calexicochronicle.com/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://calexicochronicle.com/category/election-coverage/">Election Coverage</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://calexicochronicle.com/category/featured-stories/" title="Covering stories that matter to the community.">Featured Stories</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a>
</li>
	<li class="cat-item cat-item-11"><a href="https://calexicochronicle.com/category/local-news/" title="The Calexico Chronicle has you covered with all your local news. Stay informed about community, school, sports, and any other news that matters to you.">Local News</a>
</li>
	<li class="cat-item cat-item-12"><a href="https://calexicochronicle.com/category/obituaries/">Obituaries</a>
</li>
	<li class="cat-item cat-item-13"><a href="https://calexicochronicle.com/category/opinion/">Opinion</a>
</li>
	<li class="cat-item cat-item-14"><a href="https://calexicochronicle.com/category/public-safety/">Public Safety</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://calexicochronicle.com/category/regional-news/" title="Get your Imperial Valley news here. We go beyond the &#039;instant news&#039;. We like to dig deeper and get to the root of the story. ">Regional News</a>
</li>
	<li class="cat-item cat-item-16"><a href="https://calexicochronicle.com/category/sports/">Sports</a>
</li>
			</ul>

			</div>				</aside><!-- .sidebar .widget-area -->
			</div>
							<div class="tipi-xs-6 footer-widget-wrap footer-widget-wrap-2 clearfix">
				<aside class="sidebar widget-area">
					<div id="pages-2" class="footer-widget zeen-widget clearfix widget_pages"><h3 class="widget-title title">Services</h3>
			<ul>
				<li class="page_item page-item-144531"><a href="https://calexicochronicle.com/about/">About Us</a></li>
<li class="page_item page-item-155865"><a href="https://calexicochronicle.com/advertising/">Advertising</a></li>
<li class="page_item page-item-144857"><a href="https://calexicochronicle.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-155882"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li class="page_item page-item-155880"><a href="https://calexicochronicle.com/archived-eeditions/">Older E-Editions</a></li>
<li class="page_item page-item-144866"><a href="https://calexicochronicle.com/subscribe/">Subscribe</a></li>
			</ul>

			</div>				</aside><!-- .sidebar .widget-area -->
			</div>
							<div class="tipi-xs-6 footer-widget-wrap footer-widget-wrap-3 clearfix footer-widget-wrap-last">
				<aside class="sidebar widget-area">
					<div id="custom_html-2" class="widget_text footer-widget zeen-widget clearfix widget_custom_html"><h3 class="widget-title title">Contact Information</h3><div class="textwidget custom-html-widget"><a href="https://calexicochronicle.com"><img class="alignnone size-medium wp-image-148863 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="" width="300" style="padding-bottom: 5px;" data-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleBlack400x52.png" /><noscript><img class="alignnone size-medium wp-image-148863" src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleBlack400x52.png" alt="" width="300" style="padding-bottom: 5px;" data-eio="l" /></noscript></a>

<div>
<strong>Address:</strong> 1239 W. Main Street, El Centro CA 92243<br />
<strong>Phone:</strong> (760) 339-4899, (760) 356-2995<br />
	<strong>Email:</strong> <a href="mailto:info@calexicochronicle.com">info@calexicochronicle.com</a><br /></div></div></div><div id="zeen_social_icons-2" class="footer-widget zeen-widget clearfix zeen_social_icons"><h3 class="widget-title title">Follow Us</h3><div class="social-widget-icons social-align-1">			<ul>
							<li>
					<a href="https://www.facebook.com/calexicochronicle.ivweekly" class="tipi-i-facebook tipi-i-sz-2 zeen-social-icons-light tipi-tip tipi-tip-move" data-title="Facebook" rel="noopener nofollow" target="_blank"></a>
				</li>
							<li>
					<a href="https://www.instagram.com/calexicochronicle/" class="tipi-i-instagram tipi-i-sz-2 zeen-social-icons-light tipi-tip tipi-tip-move" data-title="Instagram" rel="noopener nofollow" target="_blank"></a>
				</li>
							<li>
					<a href="https://www.youtube.com/channel/UCJ4rDxLDu1Bk-pnEzWDoP-A?feature=emb_ch_name_ex" class="tipi-i-youtube-play tipi-i-sz-2 zeen-social-icons-light tipi-tip tipi-tip-move" data-title="YouTube" rel="noopener nofollow" target="_blank"></a>
				</li>
							<li>
					<a href="https://calexicochronicle.com/feed/" class="tipi-i-rss tipi-i-sz-2 zeen-social-icons-light tipi-tip tipi-tip-move" data-title="RSS" rel="noopener nofollow" target="_blank"></a>
				</li>
						</ul>
		</div>

		</div>				</aside><!-- .sidebar .widget-area -->
			</div>
					</div><!-- .footer-widget-area -->
	<div class="background"></div></div><!-- .footer-widget-area -->
<div class="footer-lower-area footer-area clearfix site-skin-3">
	<div class="tipi-row tipi-flex tipi-xs-flex-full">
		<div class="logo-copyright-block">
			<div class="logo logo-footer"><a href="https://calexicochronicle.com" data-pin-nopin="true"><img src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-416x55.png" alt=""  data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-416x55-1.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-White-Footer-416x55-1.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-832x110-1.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-White-Footer-832x110-1.png 2x" width="416" height="55" data-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-416x55-1.png" data-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-832x110-1.png 2x" class="lazyload"><noscript><img src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-416x55-1.png" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-832x110-1.png 2x" data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-416x55-1.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-White-Footer-416x55-1.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-832x110-1.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-White-Footer-832x110-1.png 2x" width="416" height="55" data-eio="l"></noscript><span class="logo-subtitle font-3">Chronicling Our Community, Border Region, and Beyond Since 1904</span></a></div>				<div class="copyright font-2 copyright-l">© 2021 Calexico Chronicle, 1239 W. Main Street, El Centro CA 92243</div>
			</div>
		<div class="tipi-flex-right">
				<ul class="horizontal-menu font-3 menu-icons">
		<li  class="menu-icon menu-icon-style-1 menu-icon-fb"><a href="https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly" data-title="Facebook" class="tipi-i-facebook tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-tw"><a href="https://twitter.com/https://www.twitter.com/holtvilletribu1" data-title="Twitter" class="tipi-i-twitter tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-insta"><a href="https://instagram.com/https://www.instagram.com/calexicochronicle" data-title="Instagram" class="tipi-i-instagram tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-yt"><a href="https://youtube.com/https://www.youtube.com/watch?v=6ReaUBW2Ygk&#038;list=UUJ4rDxLDu1Bk-pnEzWDoP-A" data-title="YouTube" class="tipi-i-youtube-play tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="YouTube" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-rss"><a href="https://calexicochronicle.com/feed/" data-title="RSS" class="tipi-i-rss tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="RSS" target="_blank"></a></li><li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li><li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-move" data-title="Search" data-type="search"></a></li>
			
	
		</ul>
						<nav id="footer-navigation" class="footer-navigation clearfix font-3">
		<ul id="menu-footer-menu" class="footer-menu horizontal-menu"><li id="menu-item-157695" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157695"><a href="https://calexicochronicle.com/subscribe/">Subscribe</a></li>
<li id="menu-item-157696" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157696"><a href="https://calexicochronicle.com/contact-us/">Contact</a></li>
<li id="menu-item-157697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157697"><a href="https://calexicochronicle.com/privacy-policy-2/">Privacy Policy</a></li>
<li id="menu-item-157698" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157698"><a href="https://calexicochronicle.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-157699" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157699"><a href="https://calexicochronicle.com/credits/">Site Credits</a></li>
</ul>	</nav><!-- .footer-navigation -->
					</div>
	</div>
</div>
					<div class="background"></div>				</div>
			</div>
		</footer><!-- .site-footer -->
		<div id="prev-block__wrap" class="next-prev__design-2 tipi-vertical-c next-prev__prev"><div class="next-prev__trigger tipi-all-c"><i class="tipi-i-arrow-left"></i></div><div class="next-prev__contents"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/track-field-bulldogs-longton-in-cif-finals/" class="mask-img"><img width="100" height="100" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20100%20100&#039;%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail zeen-lazy-load-base zeen-lazy-load  wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-100x100.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/06/CLXTrackMAIN-6-10-979x979.jpg 979w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="meta"><div class="pre-title">Previous</div><a href="https://calexicochronicle.com/2021/06/07/track-field-bulldogs-longton-in-cif-finals/" class="title">TRACK &#038; FIELD: Bulldogs’ Longton Running in CIF Finals</a></div></div></div><div id="next-block__wrap" class="next-prev__design-2 tipi-vertical-c next-prev__next"><div class="next-prev__trigger tipi-all-c"><i class="tipi-i-arrow-right"></i></div><div class="next-prev__contents"><div class="mask"><a href="https://calexicochronicle.com/2021/06/07/luchadors-get-love-from-imperial-valley-crowd/" class="mask-img"><img width="100" height="100" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20100%20100&#039;%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail zeen-lazy-load-base zeen-lazy-load  wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-100x100.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/06/Lil-Cholo-and-Mariachi-Loco-VWE-6-10-979x979.jpg 979w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="meta"><div class="pre-title">Next</div><a href="https://calexicochronicle.com/2021/06/07/luchadors-get-love-from-imperial-valley-crowd/" class="title">Luchadors Get Love from Imperial Valley</a></div></div></div>		
	</div><!-- .site-inner -->

</div><!-- .site -->
<div id="mob-menu-wrap" class="mob-menu-wrap mobile-navigation-dd tipi-m-0 site-skin-3 site-img-1">
	<div class="bg-area">
		<a href="#" class="mob-tr-close tipi-close-icon"><i class="tipi-i-close" aria-hidden="true"></i></a>
		<div class="content-wrap">
			<div class="content">
												<nav class="mobile-navigation mobile-navigation-1"><ul id="menu-mobile" class="menu-mobile vertical-menu font-2"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157700"><a href="https://calexicochronicle.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157701"><a href="https://calexicochronicle.com/category/featured-stories/">Top Stories</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157702"><a href="#">Sections</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157705"><a href="https://calexicochronicle.com/category/featured-stories/">Featured Stories</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157703"><a href="https://calexicochronicle.com/category/local-news/">Local News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157704"><a href="https://calexicochronicle.com/category/regional-news/">Regional News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent dropper standard-drop menu-item-157707"><a href="https://calexicochronicle.com/category/sports/">Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157706"><a href="https://calexicochronicle.com/category/public-safety/">Public Safety</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157708"><a href="https://calexicochronicle.com/category/opinion/">Opinion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157712"><a href="https://calexicochronicle.com/category/education/">Education</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157710"><a href="https://calexicochronicle.com/category/business/">Business</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157709"><a href="https://calexicochronicle.com/category/agriculture/">Agriculture</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157711"><a href="https://calexicochronicle.com/category/community-briefs/">Community Briefs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157713"><a href="https://calexicochronicle.com/category/obituaries/">Obituaries</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157714"><a href="https://calexicochronicle.com/category/covid19/">COVID-19</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157715"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157716"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157717"><a href="https://calexicochronicle.com/about/">About Us</a></li>
</ul></nav><!-- .mobile-navigation -->				<ul class="menu-icons horizontal-menu">
							<li class="menu-icon menu-icon-subscribe"><a href="#" class="modal-tr" data-type="subscribe"><i class="tipi-i-mail"></i><span class="font-3">Subscribe</span></a></li>
	<li  class="menu-icon menu-icon-style-1 menu-icon-fb"><a href="https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly" data-title="Facebook" class="tipi-i-facebook tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-tw"><a href="https://twitter.com/https://www.twitter.com/holtvilletribu1" data-title="Twitter" class="tipi-i-twitter tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-insta"><a href="https://instagram.com/https://www.instagram.com/calexicochronicle" data-title="Instagram" class="tipi-i-instagram tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-yt"><a href="https://youtube.com/https://www.youtube.com/watch?v=6ReaUBW2Ygk&#038;list=UUJ4rDxLDu1Bk-pnEzWDoP-A" data-title="YouTube" class="tipi-i-youtube-play tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="YouTube" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-rss"><a href="https://calexicochronicle.com/feed/" data-title="RSS" class="tipi-i-rss tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="RSS" target="_blank"></a></li><li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li><li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-move" data-title="Search" data-type="search"></a></li>
			
	
					</ul>
			</div>
		</div>
		<div class="background"></div>	</div>
</div>
<div id="modal" class="modal-wrap inactive" data-fid="">
	<span class="tipi-overlay tipi-overlay-modal"></span>
	<div class="content tipi-vertical-c tipi-row">
		<div class="content-search search-form-wrap content-block">
			<form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
			<div class="search-hints">
				<span class="search-hint">
					Start typing to see results or hit ESC to close				</span>
				<div class="suggestions-wrap font-2"><a href="https://calexicochronicle.com/tag/calexico-chronicle/" class="tag-cloud-link tag-link-177 tag-link-position-1" style="font-size: 12px;">Calexico Chronicle</a>
<a href="https://calexicochronicle.com/tag/imperial-county-news/" class="tag-cloud-link tag-link-758 tag-link-position-2" style="font-size: 12px;">Imperial County news</a>
<a href="https://calexicochronicle.com/tag/calexico-news/" class="tag-cloud-link tag-link-195 tag-link-position-3" style="font-size: 12px;">Calexico News</a>
<a href="https://calexicochronicle.com/tag/covid-19/" class="tag-cloud-link tag-link-359 tag-link-position-4" style="font-size: 12px;">Covid-19</a>
<a href="https://calexicochronicle.com/tag/calexico/" class="tag-cloud-link tag-link-166 tag-link-position-5" style="font-size: 12px;">Calexico</a></div>			</div>
			<div class="content-found-wrap"><div class="content-found"></div><div class="button-wrap"><a class="search-all-results button-arrow-r button-arrow tipi-button" href="#"><span class="button-title">See all results</span><i class="tipi-i-arrow-right"></i></a></div></div>		</div>

				<div class="content-lwa content-block site-img-1 site-skin-2">
					<div class="tipi-modal-bg bg-area">
							</div>
				</div>

		<div class="content-custom content-block">
		</div>
	</div>
	<a href="#" class="close tipi-x-wrap tipi-x-outer"><i class="tipi-i-close"></i></a>

</div>
<span id="tipi-overlay" class="tipi-overlay tipi-overlay-base tipi-overlay-dark"><a href="#" class="close tipi-x-wrap"><i class="tipi-i-close"></i></a></span>
<div id="slide-in-box" class="slide-in-box tipi-tile tipi-xs-0 slide-in-2"><i class="tipi-i-close tipi-closer"></i><div class="content"><div class="title">More Stories</div>			<div class="mask"><a href="https://calexicochronicle.com/2020/12/22/mexicali-man-dies-after-being-struck-by-a-minivan/" class="mask-img"><img width="469" height="469" src="https://calexicochronicle.com/wp-content/ewww/lazy/placeholder-469x469.png" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image lazyload" alt=""   data-src="https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-469x469.jpg" data-srcset="https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-372x372.jpg 372w" data-sizes="auto" /><noscript><img width="469" height="469" src="https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-469x469.jpg" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2020/12/Calexico-vehicle-of-interest-12-24-372x372.jpg 372w" sizes="(max-width: 469px) 100vw, 469px" data-eio="l" /></noscript></a><div class="go-next"><a href="https://calexicochronicle.com/2020/12/22/mexicali-man-dies-after-being-struck-by-a-minivan/"><i class="tipi-i-long-right"></i></a></div></div>

			<div class="entry font-1"><a href="https://calexicochronicle.com/2020/12/22/mexicali-man-dies-after-being-struck-by-a-minivan/">Mexicali Man, 53, Dies After Being Struck by a Minivan</a></div>
			</div></div>		<div id="to-top-wrap" class="to-top to-top-2 font-2"><a href="#" id="to-top-a" class="
								tipi-arrow tipi-arrow-m tipi-arrow-t
								">
		<i class="tipi-i-angle-up"></i>					</a></div>
		<span id="lr-check"></span><script type="application/ld+json">{"@context": "http://schema.org",
	"@type": "WebPage",
	"name": "Calexico Chronicle",
	"description": "Chronicling our community, border region, and beyond since 1904","url": "https://calexicochronicle.com/","datePublished": "2021-06-07T20:25:14-07:00","dateCreated": "2021-06-07T20:25:14-07:00","dateModified": "2021-06-07T20:25:19-07:00","sameAs": ["https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly","https://twitter.com/https://www.twitter.com/holtvilletribu1"],"potentialAction": {
	"@type": "SearchAction",
	"target": "https://calexicochronicle.com/?s=&#123;search_term&#125;",
	"query-input": "required name=search_term"},"breadcrumb":{ "@type": "BreadcrumbList","itemListElement": [{"@type": "ListItem",	"position": 1, "item": {
				"@id": "https://calexicochronicle.com",
				"name": "Home"
				}
				},{"@type": "ListItem",	"position": 2, "item": {
				"@id": "https://calexicochronicle.com/category/sports/",
				"name": "Sports"
				}
				}]}}</script><style id='zeen-mm-style-inline-css' type='text/css'>
.main-menu-bar-color-2 .menu-main-menu .menu-item-157700.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157700 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157701.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157701 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157702.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157702 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157715.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157715 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157716.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157716 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157717.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157717 .sub-menu { background: #111;}
</style>


<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/zeen-engine/admin/js/flickity.pkgd.min.js' id='flickity-js'></script>
<script type='text/javascript' id='jshowoff-adrotate-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js' id='jshowoff-adrotate-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js' id='awesome_weather-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js' id='siteground-optimizer-lazy-sizes-js-js'></script>
<script type='text/javascript' id='lets-live-blog-js-js-extra'>
/* <![CDATA[ */
var letsLiveBlogJs = {"root":"https:\/\/calexicochronicle.com\/wp-json\/","nonce":"be855630dc","root_point":"codetipi-lets-live-blog\/v1","root_full":"https:\/\/calexicochronicle.com\/wp-json\/codetipi-lets-live-blog\/v1\/","pagiRoot":"\/2021\/06\/07\/boys-basketball-scots-shock-top-seed\/?fbclid=IwAR00zSH_jNnQLKLZs3LvNFeybvJWCR1U1rl3J0ZCPkuUUKNHhx4zNk8Rxio","data":{"pid":161124,"timeInterval":10000,"i18n":{"ok":"OK","warning":"Warning","delete":"Delete","jumphl":"Jump to highlight","edit":"Edit","live":"Live","ended":"Finished","starting":"Not started","disabled":"Broadcasting Off","publish":"Publish","cancel":"Cancel","success":"Success","successD":"Entry was deleted.","confirmD":"This will permanently delete this entry. Continue?","update":"Update","start":"Start broadcast","stop":"Stop broadcast","highlight":"Highlight","highlightinput":"Summary of highlight"}}};
/* ]]> */
</script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/lets-live-blog/frontend/js/functions.min.js' id='lets-live-blog-js-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/gsap/gsap.min.js' id='gsap-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/gsap/ScrollTrigger.min.js' id='scroll-trigger-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/js.cookie.min.js' id='js-cookie-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/imagesloaded.pkgd.min.js' id='images-loaded-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/menu-aim.min.js' id='menu-aim-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/intersection-observer.min.js' id='intersection-observer-js'></script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/swipebox.min.js' id='swipebox-js'></script>
<script type='text/javascript' id='zeen-functions-js-extra'>
/* <![CDATA[ */
var zeenJS = {"root":"https:\/\/calexicochronicle.com\/wp-json\/codetipi-zeen\/v1\/","nonce":"be855630dc","qry":{"page":0,"year":2021,"monthnum":6,"day":7,"name":"boys-basketball-scots-shock-top-seed","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":10,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"},"args":{"siteUrl":"https:\/\/calexicochronicle.com","sDelay":7000,"subL":false,"lazy":true,"lazyNative":false,"iconSorter":"<i class=\"tipi-i-chevron-down\"><\/i>","iplComs":false,"heroFade":0.07499999999999999722444243843710864894092082977294921875,"iplMob":true,"infUrlChange":true,"fbComs":false,"lightbox":true,"lightboxChoice":1,"archiveUrlChange":false,"stickyHeaderCustomize":false,"cookieDuration":90,"searchPpp":3,"iplCached":true,"path":"\/","disqus":false,"subCookie":true,"pluginsUrl":"https:\/\/calexicochronicle.com\/wp-content\/plugins","frontpage":false,"ipl":["lets-review\/assets\/js\/functions.min.js"]},"i18n":{"embedError":"There was a problem with your embed code. Please refer to the documentation for help.","loadMore":"Load More","noMore":"No More Content"}};
/* ]]> */
</script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/functions.min.js' id='zeen-functions-js'></script>
<script defer type='text/javascript' id='zeen-functions-js-after'>
	var zeen_157701 = {
		id: 157701,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 61,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "off",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 1,
		fi_off: 0,
		ppp: 3,
		args: {"cat":"9","post_type":{"post":"post","e_editions":"e_editions","bookshelf_v1":"bookshelf_v1"},"posts_per_page":"3","ignore_sticky_posts":1}	};
	
	var zeen_157715 = {
		id: 157715,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 61,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "off",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 1,
		fi_off: 0,
		ppp: 3,
		args: {"cat":"10","post_type":{"post":"post","e_editions":"e_editions","bookshelf_v1":"bookshelf_v1"},"posts_per_page":"3","ignore_sticky_posts":1}	};
	
	var zeen_60168 = {
		id: 60168,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 23,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 0,
		fi_off: 0,
		ppp: 1,
		args: {"cat":"16,","post__not_in":[161124],"posts_per_page":1,"orderby":"rand","date_query":[{"inclusive":true,"after":"3 months ago"}]}	};
	
	var zeen_40936 = {
		id: 40936,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 27,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 0,
		fi_off: 0,
		ppp: 3,
		args: {"post__not_in":[161124],"posts_per_page":3,"post_type":"post","tag":"","cat":"16,"}	};
	
	var zeen_88281 = {
		id: 88281,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 55,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 0,
		fi_off: 0,
		ppp: 4,
		args: {"posts_per_page":4,"tag__in":[],"cat":"","orderby":"trending","trending":{"name":"styling-posts-all-time488281","max":4,"num":-1}}	};
	
</script>
<script defer type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/page-links-to/dist/new-tab.js' id='page-links-to-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/wp-mediaelement.min.js' id='wp-mediaelement-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/renderers/vimeo.min.js' id='mediaelement-vimeo-js'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-2').gslider({ groupid: 2, speed: 12000 });
	jQuery('.g-4').gslider({ groupid: 4, speed: 10000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 12000 });
	jQuery('.g-8').gslider({ groupid: 8, speed: 35000 });
	jQuery('.g-10').gslider({ groupid: 10, speed: 10000 });
}
});
</script>
<!-- /AdRotate JS -->

</body>
</html>