<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
			<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="https://gmpg.org/xfn/11">
		<meta name="theme-color" content="#630a1f">
	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Optimized by SG Optimizer plugin version - 5.7.19 -->
	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>State Houses Migrants in Holtville Hotel - Calexico Chronicle</title>
	<meta name="description" content="An undetermined number of asylum seekers that have been released from the custody are being housed at the Barbara Worth Country Club." />
	<link rel="canonical" href="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="State Houses Migrants in Holtville Hotel - Calexico Chronicle" />
	<meta property="og:description" content="An undetermined number of asylum seekers that have been released from the custody are being housed at the Barbara Worth Country Club." />
	<meta property="og:url" content="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/" />
	<meta property="og:site_name" content="Calexico Chronicle" />
	<meta property="article:publisher" content="https://www.facebook.com//calexicochronicle.ivweekly/" />
	<meta property="article:published_time" content="2021-04-02T03:17:55+00:00" />
	<meta property="article:modified_time" content="2021-04-02T03:17:57+00:00" />
	<meta property="og:image" content="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1.jpg" />
	<meta property="og:image:width" content="976" />
	<meta property="og:image:height" content="593" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Julio Morales">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="6 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://calexicochronicle.com/#organization","name":"Calexico Chronicle","url":"https://calexicochronicle.com/","sameAs":["https://www.facebook.com//calexicochronicle.ivweekly/","https://www.instagram.com/calexicochronicle/"],"logo":{"@type":"ImageObject","@id":"https://calexicochronicle.com/#logo","inLanguage":"en-US","url":"https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png","width":190,"height":50,"caption":"Calexico Chronicle"},"image":{"@id":"https://calexicochronicle.com/#logo"}},{"@type":"WebSite","@id":"https://calexicochronicle.com/#website","url":"https://calexicochronicle.com/","name":"Calexico Chronicle","description":"Chronicling our community, border region, and beyond since 1904","publisher":{"@id":"https://calexicochronicle.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://calexicochronicle.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#primaryimage","inLanguage":"en-US","url":"https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1.jpg","width":976,"height":593,"caption":"An aerial overview of the Barbara Worth Country Club is shown in this image found on a real estate website. The California Department of Social Services has contracted with the owner of the hotel to house an undetermined amount of asylum seekers in its rooms, it was revealed on Thursday, April 1. | COURTESY PHOTO"},{"@type":"WebPage","@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#webpage","url":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/","name":"State Houses Migrants in Holtville Hotel - Calexico Chronicle","isPartOf":{"@id":"https://calexicochronicle.com/#website"},"primaryImageOfPage":{"@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#primaryimage"},"datePublished":"2021-04-02T03:17:55+00:00","dateModified":"2021-04-02T03:17:57+00:00","description":"An undetermined number of asylum seekers that have been released from the custody are being housed at the Barbara Worth Country Club.","breadcrumb":{"@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/"]}]},{"@type":"BreadcrumbList","@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://calexicochronicle.com/","url":"https://calexicochronicle.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/","url":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/","name":"State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club"}}]},{"@type":"Article","@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#article","isPartOf":{"@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#webpage"},"author":{"@id":"https://calexicochronicle.com/#/schema/person/f44dbdc84f843709a2f5f44490647968"},"headline":"State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club","datePublished":"2021-04-02T03:17:55+00:00","dateModified":"2021-04-02T03:17:57+00:00","mainEntityOfPage":{"@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#webpage"},"publisher":{"@id":"https://calexicochronicle.com/#organization"},"image":{"@id":"https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/#primaryimage"},"keywords":"asylum seekers,Barbara Worth Country Club,border crisis,Galilee Center in Mecca,Holtville News,Imperial County news,migrants,Public Safety,U.S. Border Patrol,u.s. immigrations and customs enforcement","articleSection":"Public Safety,Regional News","inLanguage":"en-US"},{"@type":"Person","@id":"https://calexicochronicle.com/#/schema/person/f44dbdc84f843709a2f5f44490647968","name":"Julio Morales"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//use.typekit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; Feed" href="https://calexicochronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; Comments Feed" href="https://calexicochronicle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club Comments Feed" href="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v6.7.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
		<!-- Note: ExactMetrics is not currently configured on this site. The site owner needs to authenticate with Google Analytics in the ExactMetrics settings panel. -->
					<!-- No UA code set -->
				<!-- / Google Analytics by ExactMetrics -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/calexicochronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://calexicochronicle.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='awesome-weather-css'  href='https://calexicochronicle.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=5.7' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='lets-review-api-css'  href='https://calexicochronicle.com/wp-content/plugins/lets-review/assets/css/style-api.min.css?ver=3.2.8' type='text/css' media='all' />
<link rel='stylesheet' id='lets-social-count-css'  href='https://calexicochronicle.com/wp-content/plugins/lets-social-count/assets/css/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='lets-live-blog-css'  href='https://calexicochronicle.com/wp-content/plugins/lets-live-blog/frontend/css/style.min.css?ver=1.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='lets-live-blog-icons-css'  href='https://calexicochronicle.com/wp-content/plugins/lets-live-blog/frontend/css/fonts/style.css?ver=1.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='zeen-style-css'  href='https://calexicochronicle.com/wp-content/themes/zeen/assets/css/style.min.css?ver=3.9.8.4' type='text/css' media='all' />
<style id='zeen-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='zeen-child-style-css'  href='https://calexicochronicle.com/wp-content/themes/zeen-child/style.css?ver=3.9.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='zeen-fonts-css'  href='https://fonts.googleapis.com/css?family=Playfair+Display%3A700%2Citalic%2C400%7COswald%3A300%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='swipebox-css'  href='https://calexicochronicle.com/wp-content/themes/zeen/assets/css/swipebox.min.css?ver=1.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://calexicochronicle.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='login-with-ajax-js-extra'>
/* <![CDATA[ */
var LWA = {"ajaxurl":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/plugins/login-with-ajax/login-with-ajax.js?ver=3.1.11' id='login-with-ajax-js'></script>
<script type='text/javascript' src='https://use.typekit.net/idb6qbc.js?ver=5.7' id='zeen-tk-js'></script>
<script type='text/javascript' id='zeen-tk-js-after'>
try{Typekit.load({ async: true });}catch(e){}
</script>
<!--[if IE]>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/ie9.js?ver=3.9.8.4' id='zeen-ie9-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://calexicochronicle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://calexicochronicle.com/wp-json/wp/v2/posts/157978" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://calexicochronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://calexicochronicle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://calexicochronicle.com/?p=157978' />
<link rel="alternate" type="application/json+oembed" href="https://calexicochronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://calexicochronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.17 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-2 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-3 {  margin: 0 auto; }
	.g-4 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-5 { width:100%; max-width:729px; height:100%; max-height:90px; margin: 0 auto; }
	.g-6 {  margin: 0 auto; }
	.g-8 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-9 {  margin: 0 auto; }
	.g-10 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style type='text/css'>img#wpstats{display:none}</style><link rel="preload" type="font/woff2" as="font" href="https://calexicochronicle.com/wp-content/themes/zeen/assets/css/tipi/tipi.woff2?9oa0lg" crossorigin="anonymous"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin="anonymous">				<style id="uagb-style-conditional-extension">@media (min-width: 1025px){.entry-content .uag-hide-desktop.uagb-google-map__wrap,.entry-content .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){.entry-content .uag-hide-tab.uagb-google-map__wrap,.entry-content .uag-hide-tab{display:none}}@media (max-width: 767px){.entry-content .uag-hide-mob.uagb-google-map__wrap,.entry-content .uag-hide-mob{display:none}}</style>
			<link rel="icon" href="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-100x100.png" sizes="32x32" />
<link rel="icon" href="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-293x293.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-293x293.png" />
<meta name="msapplication-TileImage" content="https://calexicochronicle.com/wp-content/uploads/2021/02/cropped-CC-Logo-Header-Artboard-5-293x293.png" />
		<style type="text/css" id="wp-custom-css">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</style>
		</head>
<body class="post-template-default single single-post postid-157978 single-format-standard headings-f1 body-f2 sub-f1 quotes-f1 by-f3 wh-f2 to-top__fixed block-titles-big block-titles-mid-1 body--mobile--limit menu-no-color-hover mob-fi-tall skin-light zeen-sb-sticky-off mm-ani-3 site-mob-menu-a-2 site-mob-menu-4 mm-submenu-1 main-menu-logo-1 body-header-style-2 body-hero-m byline-font-2">
		<div id="page" class="site">
		<div id="mob-line" class="tipi-m-0"></div><header id="mobhead" class="site-header-block site-mob-header tipi-m-0 site-mob-header-1 site-mob-menu-4 sticky-menu-mob sticky-menu-2 sticky-menu site-skin-3 site-img-1"><div class="bg-area header-padding tipi-row tipi-vertical-c">
	<ul class="menu-left icons-wrap tipi-vertical-c">
		<li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-move" data-title="Search" data-type="search"></a></li>
			
	
			
			
	
		</ul>
	<div class="logo-main-wrap logo-mob-wrap">
		<div class="logo logo-mobile"><a href="https://calexicochronicle.com" data-pin-nopin="true"><img src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7@2x.png 2x" data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-Mobile-DarkArtboard-7@0.5x.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-MobileArtboard-7@2x.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CC-Logo-Mobile-DarkArtboard-7.png 2x" width="190" height="50"></a></div>	</div>
	<ul class="menu-right icons-wrap tipi-vertical-c">
		<li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li>
			
	
			
			
	
			
			
			<li class="menu-icon menu-icon-mobile-slide"><a href="#" class="mob-tr-open" data-target="slide-menu"><i class="tipi-i-menu-mob" aria-hidden="true"></i></a></li>
	
		</ul>
	<div class="background"></div></div>
</header><!-- .site-mob-header -->		<div class="site-inner">
			<div id="secondary-wrap" class="secondary-wrap tipi-xs-0 clearfix font-3 mm-ani-3 secondary-menu-skin-3 secondary-menu-width-1"><div class="menu-bg-area"><div class="menu-content-wrap clearfix tipi-vertical-c tipi-row">	<nav id="secondary-navigation" class="secondary-navigation rotatable tipi-xs-0">
		<ul id="menu-secondary" class="menu-secondary horizontal-menu tipi-flex menu-secondary ul-padding row font-3 main-menu-skin-3 main-menu-bar-color-2 mm-skin-4 mm-submenu-1 mm-ani-3">
			<li class="current-date menu-padding date--secondary">April 2, 2021</li><li class="trending-inline dropper drop-it mm-art mm-wrap"><a href="#" id="trending-secondary" class="main-title-wrap"><i class="tipi-i-trend-2 tipi-trending-icon"></i><span class="trending-text">TRENDING NOW</span></a><div class="trending-inline-drop menu tipi-row"><div class="trending-inline-title clearfix"><div class="trending-op-title">Trending</div><div class="trending-ops" data-uid="65221"><span data-r="1" class="trending-op trending-op-1 trending-selected">Now</span><span data-r="2" class="trending-op trending-op-2">Week</span><span data-r="3" class="trending-op trending-op-3">Month</span></div></div><div class="trending-inline-wrap"><div id="block-wrap-65221" class="block-wrap-native block-wrap block-wrap-61 block-css-65221 block-wrap-classic columns__m--1 elements-design-2 block-skin-0 tipi-box tipi-row ppl-m-3 ppl-s-3 clearfix" data-id="65221" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block block-61 tipi-flex preview-review-bot"><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-m-typo stack-1 stack-design-1 separation-border-style loop-0 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157919 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety tag-crime tag-el-centro-sector tag-public-safety tag-stash-house tag-u-s-border-patrol tag-undocumented-immigrants"><div class="preview-mini-wrap clearfix"><div class="mask"><div class="counter counter-1 font-3 trending-accent-border"></div><a href="https://calexicochronicle.com/2021/04/01/border-patrol-takes-down-stash-house-in-imperial/" class="mask-img"><img width="449" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/04/IID-clone-stash-house-449x299.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/IID-clone-stash-house-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/04/IID-clone-stash-house-360x240.jpg 360w" data-lazy-sizes="(max-width: 449px) 100vw, 449px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/border-patrol-takes-down-stash-house-in-imperial/">Border Patrol Takes Down Stash House in Imperial</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-m-typo stack-1 stack-design-1 separation-border-style loop-1 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157978 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety category-regional-news tag-asylum-seekers tag-barbara-worth-country-club tag-border-crisis tag-galilee-center-in-mecca tag-holtville-news tag-imperial-county-news tag-migrants tag-public-safety tag-u-s-border-patrol tag-u-s-immigrations-and-customs-enforcement"><div class="preview-mini-wrap clearfix"><div class="mask"><div class="counter counter-2 font-3 trending-accent-border"></div><a href="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/" class="mask-img"><img width="449" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-449x299.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-849x565.jpg 849w" data-lazy-sizes="(max-width: 449px) 100vw, 449px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/">State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-m-typo stack-1 stack-design-1 separation-border-style loop-2 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157895 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion tag-calexico-city-council tag-calexico-mayor tag-city-of-calexico tag-imperial-county-news tag-raul-urena tag-rosie-arreola-fernandez"><div class="preview-mini-wrap clearfix"><div class="mask"><div class="counter counter-3 font-3 trending-accent-border"></div><a href="https://calexicochronicle.com/2021/04/01/letter-calexico-mayor-takes-on-attacks/" class="mask-img"><img width="238" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/04/New-Rosie-Fernandez-mug-238x299.jpg" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/letter-calexico-mayor-takes-on-attacks/">LETTER: Calexico Mayor Takes On Personal Attacks</a></h3></div></div></div></article></div></div></div></div></div></div></li>		</ul>
	</nav><!-- .secondary-navigation -->
<ul class="horizontal-menu menu-icons ul-padding tipi-vertical-c tipi-flex-r secondary-icons"><li  class="menu-icon menu-icon-style-1 menu-icon-fb"><a href="https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly" data-title="Facebook" class="tipi-i-facebook tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-tw"><a href="https://twitter.com/https://www.twitter.com/holtvilletribu1" data-title="Twitter" class="tipi-i-twitter tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-insta"><a href="https://instagram.com/https://www.instagram.com/calexicochronicle" data-title="Instagram" class="tipi-i-instagram tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-yt"><a href="https://youtube.com/https://www.youtube.com/watch?v=6ReaUBW2Ygk&#038;list=UUJ4rDxLDu1Bk-pnEzWDoP-A" data-title="YouTube" class="tipi-i-youtube-play tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="YouTube" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-rss"><a href="https://calexicochronicle.com/feed/" data-title="RSS" class="tipi-i-rss tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="RSS" target="_blank"></a></li><li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li>
			
	
	</ul></div></div></div><header id="masthead" class="site-header-block site-header clearfix site-header-2 header-width-1 header-skin-3 site-img-1 mm-ani-3 mm-skin-4 main-menu-skin-3 main-menu-width-1 main-menu-bar-color-2 logo-only-when-stuck main-menu-c" data-pt-diff="0" data-pb-diff="0"><div class="bg-area">
	<div class="tipi-flex-lcr logo-main-wrap header-padding tipi-flex-eq-height logo-main-wrap-center tipi-row">
						<div class="logo-main-wrap header-padding tipi-all-c"><div class="logo logo-main"><a href="https://calexicochronicle.com" data-pin-nopin="true"><img src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1.png" alt="Calexico Chronicle Logo: Chronicling Our Community, Border Region, and Beyond Since 1904" srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1@2x.png 2x" data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-DarkArtboard-4.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-Artboard-1@2x.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CC-Logo-Header-DarkArtboard-4@2x.png 2x" width="595" height="94"></a></div></div>							</div>
	<div class="background"></div></div>
</header><!-- .site-header --><div id="header-line"></div><nav id="site-navigation" class="main-navigation main-navigation-1 tipi-xs-0 clearfix logo-only-when-stuck main-menu-skin-3 main-menu-width-1 main-menu-bar-color-2 mm-skin-4 mm-submenu-1 mm-ani-3 main-menu-c sticky-menu-dt sticky-menu sticky-menu-3">	<div class="main-navigation-border menu-bg-area">
		<div class="nav-grid clearfix tipi-row">
			<div class="tipi-flex sticky-part sticky-p1">
				<div class="logo-menu-wrap logo-menu-wrap-placeholder"></div>				<ul id="menu-main-menu" class="menu-main-menu horizontal-menu tipi-flex font-3">
					<li id="menu-item-157700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157700"><a href="https://calexicochronicle.com/">Home</a></li>
<li id="menu-item-157701" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157701"><a href="https://calexicochronicle.com/category/featured-stories/" data-ppp="3" data-tid="9"  data-term="category">Top Stories</a><div class="menu mm-11 tipi-row" data-mm="11"><div class="menu-wrap menu-wrap-more-10 tipi-flex"><div id="block-wrap-157701" class="block-wrap-native block-wrap block-wrap-61 block-css-157701 block-wrap-classic columns__m--1 elements-design-2 block-skin-0 filter-wrap-2 tipi-box tipi-row ppl-m-3 ppl-s-3 clearfix" data-id="157701" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block-title-wrap module-block-title clearfix  block-title-1 with-load-more" style="border-bottom-color:#630a1f;"><div class="block-title-area clearfix"><div class="block-title font-1">Top Stories</div><div class="block-subtitle font-1"><p>Covering stories that matter to the community.</p>
</div></div><div class="filters tipi-flex font-2"><div class="load-more-wrap load-more-size-2 load-more-wrap-2">		<a href="#" data-id="157701" class="tipi-arrow tipi-arrow-s tipi-arrow-l block-loader block-more block-more-1 no-more" data-dir="1"><i class="tipi-i-angle-left" aria-hidden="true"></i></a>
		<a href="#" data-id="157701" class="tipi-arrow tipi-arrow-s tipi-arrow-r block-loader block-more block-more-2" data-dir="2"><i class="tipi-i-angle-right" aria-hidden="true"></i></a>
		</div></div></div><div class="block block-61 tipi-flex preview-review-bot"><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-0 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157960 post type-post status-publish format-standard has-post-thumbnail hentry category-featured-stories category-sports tag-am-990 tag-brawley-union-high tag-brawley-wildcats tag-calexico-bullldogs tag-calexico-high tag-high-school-football tag-high-school-sports tag-imperial-valley-league tag-ivl"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/listen-live-brawley-calexico/" class="mask-img"><img width="370" height="247" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-370x247.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-370x247.jpg 370w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-300x200.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-1024x683.jpg 1024w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-770x513.jpg 770w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-1536x1024.jpg 1536w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-500x333.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-293x195.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27-1400x933.jpg 1400w, https://calexicochronicle.com/wp-content/uploads/2021/03/ClxvsSWFootballEXTRA-MAIN-3-27.jpg 2048w" data-lazy-sizes="(max-width: 370px) 100vw, 370px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/listen-live-brawley-calexico/">LISTEN LIVE: Brawley @ Calexico</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-1 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157916 post type-post status-publish format-standard has-post-thumbnail hentry category-covid19 category-featured-stories category-regional-news tag-african-americans tag-black-community tag-covid tag-covid-vaccine tag-covid-19 tag-imperial-county-news tag-imperial-valley-social-justice-committee tag-medical-racism tag-sweet-home-missionary-baptist-church"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/delivering-covid-vaccine-to-underserved-community/" class="mask-img"><img width="449" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-449x299.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-849x565.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-1234x822.jpg 1234w" data-lazy-sizes="(max-width: 449px) 100vw, 449px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/delivering-covid-vaccine-to-underserved-community/">REACHING PAST STIGMA</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-2 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157906 post type-post status-publish format-standard has-post-thumbnail hentry category-featured-stories category-local-news tag-farmworkers tag-imperial-county-news tag-rosario-pelayo tag-united-farm-workers"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/rosario-dona-chayo-pelayos-fire-still-burns-for-la-causa/" class="mask-img"><img width="449" height="299" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20370%20247&#039;%3E%3C/svg%3E" class="attachment-zeen-370-247 size-zeen-370-247 zeen-lazy-load-base zeen-lazy-load-mm wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/04/Dona-Chayo-GRAPHIC-4-1-449x299.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/Dona-Chayo-GRAPHIC-4-1-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/04/Dona-Chayo-GRAPHIC-4-1-360x240.jpg 360w" data-lazy-sizes="(max-width: 449px) 100vw, 449px" /></a></div><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/rosario-dona-chayo-pelayos-fire-still-burns-for-la-causa/">Rosario “Doña Chayo” Pelayo’s Fire Still Burns for ‘La Causa’</a></h3></div></div></div></article></div></div></div></div></div></div></li>
<li id="menu-item-157702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157702"><a href="#">Sections</a><div class="menu mm-2 tipi-row" data-mm="2"><div class="menu-wrap menu-wrap-minus-10">
<ul class="sub-menu">
	<li id="menu-item-157705" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157705"><a href="https://calexicochronicle.com/category/featured-stories/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Featured Stories" data-url="https://calexicochronicle.com/category/featured-stories/" data-subtitle="Covering stories that matter to the community." data-count="254" data-tid="9"  data-term="category">Featured Stories</a></li>
	<li id="menu-item-157703" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157703"><a href="https://calexicochronicle.com/category/local-news/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Local News" data-url="https://calexicochronicle.com/category/local-news/" data-subtitle="The Calexico Chronicle has you covered with all your local news. Stay informed about community, school, sports, and any other news that matters to you." data-count="554" data-tid="11"  data-term="category">Local News</a></li>
	<li id="menu-item-157704" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent dropper drop-it menu-item-157704"><a href="https://calexicochronicle.com/category/regional-news/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Regional News" data-url="https://calexicochronicle.com/category/regional-news/" data-subtitle="Get your Imperial Valley news here. We go beyond the &#039;instant news&#039;. We like to dig deeper and get to the root of the story. " data-count="399" data-tid="15"  data-term="category">Regional News</a></li>
	<li id="menu-item-157707" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157707"><a href="https://calexicochronicle.com/category/sports/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Sports" data-url="https://calexicochronicle.com/category/sports/" data-subtitle="" data-count="46" data-tid="16"  data-term="category">Sports</a></li>
	<li id="menu-item-157706" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent dropper drop-it menu-item-157706"><a href="https://calexicochronicle.com/category/public-safety/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Public Safety" data-url="https://calexicochronicle.com/category/public-safety/" data-subtitle="" data-count="64" data-tid="14"  data-term="category">Public Safety</a></li>
	<li id="menu-item-157708" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157708"><a href="https://calexicochronicle.com/category/opinion/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Opinion" data-url="https://calexicochronicle.com/category/opinion/" data-subtitle="" data-count="31" data-tid="13"  data-term="category">Opinion</a></li>
	<li id="menu-item-157712" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157712"><a href="https://calexicochronicle.com/category/education/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Education" data-url="https://calexicochronicle.com/category/education/" data-subtitle="" data-count="18" data-tid="7"  data-term="category">Education</a></li>
	<li id="menu-item-157710" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157710"><a href="https://calexicochronicle.com/category/business/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Business" data-url="https://calexicochronicle.com/category/business/" data-subtitle="" data-count="55" data-tid="4"  data-term="category">Business</a></li>
	<li id="menu-item-157709" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157709"><a href="https://calexicochronicle.com/category/agriculture/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Agriculture" data-url="https://calexicochronicle.com/category/agriculture/" data-subtitle="" data-count="12" data-tid="3"  data-term="category">Agriculture</a></li>
	<li id="menu-item-157711" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157711"><a href="https://calexicochronicle.com/category/community-briefs/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Community Briefs" data-url="https://calexicochronicle.com/category/community-briefs/" data-subtitle="" data-count="65" data-tid="5"  data-term="category">Community Briefs</a></li>
	<li id="menu-item-157713" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157713"><a href="https://calexicochronicle.com/category/obituaries/" class="block-more block-mm-changer block-mm-init block-changer" data-title="Obituaries" data-url="https://calexicochronicle.com/category/obituaries/" data-subtitle="" data-count="1" data-tid="12"  data-term="category">Obituaries</a></li>
	<li id="menu-item-157714" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it menu-item-157714"><a href="https://calexicochronicle.com/category/covid19/" class="block-more block-mm-changer block-mm-init block-changer" data-title="COVID-19" data-url="https://calexicochronicle.com/category/covid19/" data-subtitle="Stay up-to-date with the latest local developments on the COVID-19 Pandemic.
Follow us on Facebook &lt;a href=&quot;https://www.facebook.com/calexicochronicle.ivweekly/&quot;&gt;@calexicochronicle.ivweekly&lt;/a&gt; to receive immediate updates." data-count="229" data-tid="6"  data-term="category">COVID-19</a></li>
</ul></div></div>
</li>
<li id="menu-item-157715" class="menu-item menu-item-type-taxonomy menu-item-object-category dropper drop-it mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157715"><a href="https://calexicochronicle.com/category/legal-notices/" data-ppp="3" data-tid="10"  data-term="category">Legal Notices</a><div class="menu mm-11 tipi-row" data-mm="11"><div class="menu-wrap menu-wrap-more-10 tipi-flex"><div id="block-wrap-157715" class="block-wrap-native block-wrap block-wrap-61 block-css-157715 block-wrap-classic columns__m--1 elements-design-2 block-skin-0 filter-wrap-2 tipi-box tipi-row ppl-m-3 ppl-s-3 clearfix" data-id="157715" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block-title-wrap module-block-title clearfix  block-title-1 with-load-more" style="border-bottom-color:#630a1f;"><div class="block-title-area clearfix"><div class="block-title font-1">Legal Notices</div></div><div class="filters tipi-flex font-2"><div class="load-more-wrap load-more-size-2 load-more-wrap-2">		<a href="#" data-id="157715" class="tipi-arrow tipi-arrow-s tipi-arrow-l block-loader block-more block-more-1 no-more" data-dir="1"><i class="tipi-i-angle-left" aria-hidden="true"></i></a>
		<a href="#" data-id="157715" class="tipi-arrow tipi-arrow-s tipi-arrow-r block-loader block-more block-more-2" data-dir="2"><i class="tipi-i-angle-right" aria-hidden="true"></i></a>
		</div></div></div><div class="block block-61 tipi-flex preview-review-bot"><article class="tipi-xs-12 elements-location-3 clearfix no-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-0 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157533 post type-post status-publish format-standard hentry category-legal-notices"><div class="preview-mini-wrap clearfix"><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/03/25/legal-notices-march-25-2021/">LEGAL NOTICES: March 25, 2021</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix no-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-1 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157132 post type-post status-publish format-standard hentry category-legal-notices"><div class="preview-mini-wrap clearfix"><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/03/17/legal-notices-march-18-2021/">LEGAL NOTICES: March 18, 2021</a></h3></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix no-fi ani-base tipi-s-typo stack-1 stack-design-1 separation-border-style loop-2 preview-classic preview__img-shape-l preview-61 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-156932 post type-post status-publish format-standard hentry category-legal-notices"><div class="preview-mini-wrap clearfix"><div class="meta"><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/03/13/legal-notices-march-11-2021/">LEGAL NOTICES: March 11, 2021</a></h3></div></div></div></article></div></div></div></div></div></div></li>
<li id="menu-item-157716" class="menu-item menu-item-type-post_type menu-item-object-page dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157716"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li id="menu-item-157717" class="menu-item menu-item-type-post_type menu-item-object-page dropper drop-it mm-art mm-wrap-2 mm-wrap menu-item-157717"><a href="https://calexicochronicle.com/about/">About Us</a></li>
				</ul>
				<ul class="horizontal-menu font-3 menu-icons tipi-flex-eq-height">
										<li class="menu-icon drop-search-wrap menu-icon-search"><a href="#" class="tipi-i-search modal-tr" data-type="search-drop"></a>
				<div class="drop-search search-form-wrap widget_search clearfix"><form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
<div class="content-found-wrap"><div class="content-found"></div><div class="button-wrap"><a class="search-all-results button-arrow-r button-arrow tipi-button" href="#"><span class="button-title">See all results</span><i class="tipi-i-arrow-right"></i></a></div></div></div></li>
			
	
										</ul>
			</div>
			<div id="sticky-p2" class="sticky-part sticky-p2"><div class="sticky-p2-inner tipi-vertical-c"><div class="title-wrap"><span class="pre-title reading">Reading</span><div class="title" id="sticky-title">State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club</div></div><div id="sticky-p2-share" class="share-it tipi-vertical-c"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="https://twitter.com/intent/tweet?via=https://www.twitter.com/holtvilletribu1&#038;text=State%20Pays%20to%20House%20Asylum%20Seekers%20in%20Holtville%E2%80%99s%20Barbara%20Worth%20Country%20Club%20-%20https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i><span class="social-tip font-base font-1">Tweet</span></span></a></div></div></div>		</div>
		<span id="progress" class=" no-ipl"></span>	</div>
</nav><!-- .main-navigation -->
			<div id="content" class="site-content clearfix">
			<div id="primary" class="content-area">

	<div class="post-wrap clearfix article-layout-skin-1 title-beneath hero-m sidebar-on sidebar-right post-157978 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety category-regional-news tag-asylum-seekers tag-barbara-worth-country-club tag-border-crisis tag-galilee-center-in-mecca tag-holtville-news tag-imperial-county-news tag-migrants tag-public-safety tag-u-s-border-patrol tag-u-s-immigrations-and-customs-enforcement">
		<div class="hero-wrap clearfix hero-11 tipi-row content-bg medium-uncrop parallax"><div class="hero"><a href="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1.jpg" class="mask-img tipi-lightbox"><img width="976" height="593" src="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1.jpg" class="flipboard-image wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1.jpg 976w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-300x182.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-849x516.jpg 849w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-500x304.jpg 500w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-372x226.jpg 372w" sizes="(max-width: 976px) 100vw, 976px" /></a></div><div class="caption">An aerial overview of the Barbara Worth Country Club is shown in this image found on a real estate website. The California Department of Social Services has contracted with the owner of the hotel to house an undetermined amount of asylum seekers in its rooms, it was revealed on Thursday, April 1. | COURTESY PHOTO</div></div>		<div class="single-content contents-wrap tipi-row content-bg clearfix article-layout-1">
						<div class="tipi-cols clearfix sticky--wrap">
				<main class="site-main tipi-xs-12 main-block-wrap block-wrap tipi-l-8 tipi-col clearfix">
		<article>
				<div class="breadcrumbs-wrap breadcrumbs-sz-
	m	">
		<div class="breadcrumbs">
											<div class="crumb">
									<a href="https://calexicochronicle.com">
									<span>Home</span>
									</a>
								</div>
											<i class="tipi-i-chevron-right"></i>				<div class="crumb">
									<a href="https://calexicochronicle.com/category/public-safety/">
									<span>Public Safety</span>
									</a>
								</div>
									</div>
	</div>
	<div class="meta-wrap hero-meta tipi-m-typo elements-design-2 clearfix"><div class="meta meta-no-sub"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/public-safety/" class="cat">Public Safety</a><a href="https://calexicochronicle.com/category/regional-news/" class="cat">Regional News</a></div></div><div class="title-wrap"><h1 class="entry-title title flipboard-title">State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club</h1></div><div class="byline byline-3"><span class="byline-part author-avatar flipboard-author with-name"><a href="https://calexicochronicle.com/author/julio-morales/" class="author-avatar"></a></span><span class="byline-part author"><a href="https://calexicochronicle.com/author/julio-morales/" title="Posts by Julio Morales" class="author url fn" rel="author">Julio Morales</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-04-01T20:17:55-07:00">April 1, 2021</time></span><span class="byline-part view-count">591 views</span></div></div></div><!-- .meta-wrap -->			<div class="entry-content-wrap clearfix">
									<div class="share-it share-it-11 share-it-icons share-it-count-0 share-it-before"><div class="title">Share</div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class="tipi-tip tipi-tip-move share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i></span></a><a href="https://twitter.com/intent/tweet?via=https://www.twitter.com/holtvilletribu1&#038;text=State%20Pays%20to%20House%20Asylum%20Seekers%20in%20Holtville%E2%80%99s%20Barbara%20Worth%20Country%20Club%20-%20https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class="tipi-tip tipi-tip-move share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i></span></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F&media=https%3A%2F%2Fcalexicochronicle.com%2Fwp-content%2Fuploads%2F2021%2F04%2FBarbara-Worth-overview-4-1-849x516.jpg&description=State%20Pays%20to%20House%20Asylum%20Seekers%20in%20Holtville%26%238217%3Bs%20Barbara%20Worth%20Country%20Club" class="tipi-tip tipi-tip-move share-button share-button-pin" rel="noopener nofollow" aria-label="Pin" data-title="Pin" target="_blank" data-pin-custom="true"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-pinterest"></i></span></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class="tipi-tip tipi-tip-move share-button share-button-li" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-linkedin"></i></span></a><a href="https://reddit.com/submit?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class="tipi-tip tipi-tip-move share-button share-button-re" rel="noopener nofollow" aria-label="Submit" data-title="Submit" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-reddit-alien"></i></span></a><a href="mailto:?body=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class="tipi-tip tipi-tip-move share-button share-button-em" rel="noopener nofollow" aria-label="Email" data-title="Email" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-mail"></i></span></a><a href="whatsapp://send?text=State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club – https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class="tipi-tip tipi-tip-move tipi-xl-0 share-button share-button-wa" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-whatsapp"></i></span></a><a href="fb-messenger://share/?link=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class="tipi-tip tipi-tip-move tipi-xl-0 share-button share-button-msg" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-messenger"></i></span></a></div>												<div class="entry-content body-color clearfix link-color-wrap">
																										
<p>HOLTVILLE — An undetermined number of asylum seekers that have been released from the custody of federal immigration officials are being temporarily housed at the Barbara Worth Country Club.</p>



<p>The individuals being housed at the resort’s hotel are members of family units. They are being housed at the location through a contract between the resort and the California Department of Social Services, a county official said.</p>



<div class="wp-block-image"><figure class="alignleft size-large is-resized"><a href="https://holtvilletribune.com/wp-content/uploads/2021/04/Barbara-Worth-Hotels.jpg"><img src="https://holtvilletribune.com/wp-content/uploads/2021/04/Barbara-Worth-Hotels.jpg" alt="" class="wp-image-150608" width="419" height="249"/></a><figcaption>A wing of hotel rooms at the Barbara Worth Country Club is shown in this image found on a real estate website. The California Department of Social Services has contracted with the owner of the hotel to house an undetermined amount of asylum seekers in its rooms, it was revealed on Thursday, April 1. | COURTESY PHOTO</figcaption></figure></div>



<p>The local housing of asylum seekers has resulted from an increase in the number of migrants being apprehended at the border by U.S. Border Patrol, as well as the inability of the Immigration and Customs Enforcement to detain subjects, a local Border Patrol official said.</p>



<p>Resort owner Eddie Mejorado said the arrangement with the state happened quickly without any advance notice and was facilitated by similar arrangements between state officials and Wyndham Hotels &amp; Resorts, which operates the Ramada hotel at the resort.</p>



<p>Though he said he was not at liberty to discuss details of the arrangement, he did state that about 30 rooms are being occupied by individuals from Syria, Brazil, and Russia, to name just a few.</p>



<p>“It’s a mixture of teenagers and little kids going through the courts,” Mejorado said. “They’re a bunch of good kids.”</p>



<p>He could not say for certain whether more asylum seekers will continue to arrive or whether the resort will need to establish additional temporary housing, such as tents, to accommodate them.</p>



<p>Security has been hired to monitor the grounds around the clock, as has an additional crew to perform cleaning duties.</p>



<p>County Supervisor Ray Castillo, whose district includes Holtville, said he was unaware of the housing of asylum seekers at Barbara Worth until the Wednesday morning, March 31, when a resident of the resort contacted him to express concerns about the situation.</p>



<p>“I was kind of caught by surprise,” Castillo said on Thursday, April 1.</p>



<p>The revelation prompted him to visit the country club, where he spoke with Mejorado.</p>



<p>Castillo said Mejorado reportedly told him that the resort was contacted by state officials who requested the use of the facility’s hotel to temporarily house asylum seekers who are in the process of reuniting with family or sponsors elsewhere in the country.</p>



<p>“The folks that are coming here are strictly in transit and are going to have a high turnover,” Castillo said.</p>



<p>Castillo said he was unaware of how long the overall initiative may be in place but was in the process of seeking answers.</p>



<p>“Are we talking about weeks, months?” Castillo said. “Those are the questions I have, and I’d like to get an answer to.”</p>



<p>When contacted on Thursday evening, Mejorado, too, said he was not certain how long the initiative might be in operation. &nbsp;&nbsp;</p>



<p>One resident of the resort, who asked to remain anonymous, said they were caught off guard by the situation, and felt disappointed that nearby residents were not notified.</p>



<p>The resident said that unverified reports have suggested that up to 500 individuals may be housed at the hotel. Trying to get answers from public officials has also proven fruitless, the resident said.</p>



<p>“I feel like this isn’t an issue to ignore,” the resident, who has lived at the resort for the past two years, said. “We don’t know who these people are.”</p>



<p>Mejorado brushed aside such concerns.</p>



<p>“They are not here to harm anybody,” he said. “Instead of being worried about who’s there and where they’re from, we should take toys to the kids.”</p>



<p>The local housing of migrants appears to stem from a recent change in policy that prohibits federal immigration officials from transporting subjects beyond a five-mile radius, said Gilbert Rebollar, who is a member of the County Executive Office’s Joint Information Center.</p>



<p>“Whether this change in policy was due to COVID-19 or the federal government’s administration, the county is committed in providing humanitarian support for our local agencies and (non-governmental organizations) aiding those unable to shelter or quarantine during this time,” according to Rebollar in a written statement Thursday.</p>



<p>Aside from the asylum seekers that are being housed at the resort’s hotel, an increasing number of them are being transported outside of the county to the Galilee Center in Mecca, which provides services for the less fortunate.</p><p><div class="inline-post clearfix"><div class="see-also byline">See also</div><div id="block-wrap-40975" class="block-wrap-native block-wrap block-wrap-23 block-css-40975 block-wrap-classic columns__m--1 elements-design-2 block-ani block-skin-0 tipi-box block-wrap-thumbnail ppl-m-1 clearfix" data-id="40975" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block block-23 clearfix"><article class="tipi-xs-12 clearfix with-fi ani-base tipi-xs-typo split-1 split-design-1 loop-0 preview-thumbnail preview-23 elements-design-2 post-156764 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety category-regional-news tag-fatal-collision tag-highway-115 tag-holtville-news tag-imperial-county-coroner tag-jairo-duenas tag-norrish-road tag-yesenia-cardona"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/03/08/names-ages-of-deceased-in-holtville-crash-released/" class="mask-img"><img width="100" height="100" src="https://calexicochronicle.com/wp-content/uploads/2021/03/CBS-8-aerial-2-3-2-e1615251414674-100x100.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/CBS-8-aerial-2-3-2-e1615251414674-100x100.png 100w, https://calexicochronicle.com/wp-content/uploads/2021/03/CBS-8-aerial-2-3-2-e1615251414674-293x293.png 293w, https://calexicochronicle.com/wp-content/uploads/2021/03/CBS-8-aerial-2-3-2-e1615251414674-390x390.png 390w, https://calexicochronicle.com/wp-content/uploads/2021/03/CBS-8-aerial-2-3-2-e1615251414674-585x585.png 585w, https://calexicochronicle.com/wp-content/uploads/2021/03/CBS-8-aerial-2-3-2-e1615251414674-900x900.png 900w" sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/public-safety/" class="cat">Public Safety</a><a href="https://calexicochronicle.com/category/regional-news/" class="cat">Regional News</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/03/08/names-ages-of-deceased-in-holtville-crash-released/">Names, Ages of Deceased in Holtville Crash Released by Imperial County Coroner&#8217;s Office</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/richardmontenegro/" title="Posts by Richard Montenegro Brown" class="author url fn" rel="author">Richard Montenegro Brown</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-03-08T17:00:14-08:00">March 8, 2021</time></span></div></div></div></article></div></div></div></div></div></p>



<p>In the past, the Border Patrol would often transport asylum seekers directly to the Galilee Center for temporary housing, said Claudia Castorena, the center’s co-founder and chief financial officer.</p>



<p>Since the federal government’s March 1 change in immigrant transportation policy, shelter personnel have been traveling to the county Mondays through Fridays to pick up individuals released from Border Patrol custody, Castorena said.</p>



<p>The shelter has a capacity of about 70 people. Lately, migrants released in the Imperial County and transported to the shelter have accounted for about 50 to 70 percent of those housed there, she said.</p>



<p>Typically, the Border Patrol will provide the shelter advance notice of the number of asylum seekers it is processing.</p>



<p>“They’re doing what they can and they’re pretty good about communicating with us,” Castorena said. “They send us basic information ahead of time.”</p>



<p>The shelter is only accepting individuals who have tested negative for COVID-19. Those who test positive are referred by the shelter to county Public Health, which then will place the migrants at the Quarantine and Isolation Shelter (QIS) that has been established at Imperial Valley College.</p>



<p>On Thursday, there was 32 individuals sheltering at the QIS, with none being minors, Rebollar said.</p>



<p>“At this time, the county continues in our effort to maintain daily communications with federal authorities on information and notification of individuals and family units released within Imperial County,” Rebollar stated.</p>



<p>This comes as the El Centro Sector of the Border Patrol reported on its Facebook page on Wednesday evening that the Calexico station had set a single-day record for the largest group apprehension in the history of the sector at 64 undocumented immigrants.</p>



<p>Over the past 24 hours at the time of the post, the sector reported 208 immigrants detained, “a new 10-year high for our Sector,” according to the Border Patrol.</p>



<p>When contacted about the apprehensions on Thursday morning, an El Centro Sector spokesperson stated no further information would be released at that time.</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><a href="https://holtvilletribune.com/wp-content/uploads/2021/04/BP-thermal-image.jpg"><img src="https://holtvilletribune.com/wp-content/uploads/2021/04/BP-thermal-image.jpg" alt="" class="wp-image-150606"/></a><figcaption>An image from El Centro Sector Border Patrol shows the apprehension of 64 undocumented immigrants in a single group near the border. | IMAGE FROM EL CENTRO SECTOR BORDER PATROL’S PUBLIC FACEBOOK PAGE</figcaption></figure></div>
									</div><!-- .entry-content -->
							</div><!-- .entry-content -->

			<footer class="entry-footer">
				<div class="mobile--limiter--wrap tipi-m-0"><a href="#" class="mobile--limiter tipi-button"><span class="mobile--limiter--on">Show More <i class="tipi-i-angle-down"></i></span></a></div><div class="post-tags footer-block-links clearfix"><div class="title">Tags</div><div class="block-elements"><a href="https://calexicochronicle.com/tag/asylum-seekers/" rel="tag">asylum seekers</a><a href="https://calexicochronicle.com/tag/barbara-worth-country-club/" rel="tag">Barbara Worth Country Club</a><a href="https://calexicochronicle.com/tag/border-crisis/" rel="tag">border crisis</a><a href="https://calexicochronicle.com/tag/galilee-center-in-mecca/" rel="tag">Galilee Center in Mecca</a><a href="https://calexicochronicle.com/tag/holtville-news/" rel="tag">Holtville News</a><a href="https://calexicochronicle.com/tag/imperial-county-news/" rel="tag">Imperial County news</a><a href="https://calexicochronicle.com/tag/migrants/" rel="tag">migrants</a><a href="https://calexicochronicle.com/tag/public-safety/" rel="tag">Public Safety</a><a href="https://calexicochronicle.com/tag/u-s-border-patrol/" rel="tag">U.S. Border Patrol</a><a href="https://calexicochronicle.com/tag/u-s-immigrations-and-customs-enforcement/" rel="tag">u.s. immigrations and customs enforcement</a></div></div><div class="share-it share-it-2 share-it-bold share-it-count-0 share-it-after tipi-flex"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" share-button share-button-fb" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-facebook"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="https://twitter.com/intent/tweet?via=https://www.twitter.com/holtvilletribu1&#038;text=State%20Pays%20to%20House%20Asylum%20Seekers%20in%20Holtville%E2%80%99s%20Barbara%20Worth%20Country%20Club%20-%20https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" share-button share-button-tw" rel="noopener nofollow" aria-label="Tweet" data-title="Tweet" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-twitter"></i><span class="social-tip font-base font-1">Tweet</span></span></a><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F&media=https%3A%2F%2Fcalexicochronicle.com%2Fwp-content%2Fuploads%2F2021%2F04%2FBarbara-Worth-overview-4-1-849x516.jpg&description=State%20Pays%20to%20House%20Asylum%20Seekers%20in%20Holtville%26%238217%3Bs%20Barbara%20Worth%20Country%20Club" class=" share-button share-button-pin" rel="noopener nofollow" aria-label="Pin" data-title="Pin" target="_blank" data-pin-custom="true"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-pinterest"></i><span class="social-tip font-base font-1">Pin</span></span></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" share-button share-button-li" rel="noopener nofollow" aria-label="Share" data-title="Share" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-linkedin"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="https://reddit.com/submit?url=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" share-button share-button-re" rel="noopener nofollow" aria-label="Submit" data-title="Submit" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-reddit-alien"></i><span class="social-tip font-base font-1">Submit</span></span></a><a href="mailto:?body=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" share-button share-button-em" rel="noopener nofollow" aria-label="Email" data-title="Email" target="_blank"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-mail"></i><span class="social-tip font-base font-1">Email</span></span></a><a href="whatsapp://send?text=State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club – https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" tipi-xl-0 share-button share-button-wa" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-whatsapp"></i><span class="social-tip font-base font-1">Share</span></span></a><a href="fb-messenger://share/?link=https%3A%2F%2Fcalexicochronicle.com%2F2021%2F04%2F01%2Fstate-houses-migrants-in-holtville-hotel%2F" class=" tipi-xl-0 share-button share-button-msg" rel="noopener nofollow" aria-label="Share" data-title="Share"><span class="share-button-content tipi-vertical-c"><i class="tipi-i-messenger"></i><span class="social-tip font-base font-1">Share</span></span></a></div><div class="user-page-box-1 user-box-skin-1 user-box-type-1 tipi-xs-12 user-page-box clearfix">		<div class="mask">
			<a href="https://calexicochronicle.com/author/julio-morales/">
								<span class="overlay-arrow-r overlay-arrow"><i class="tipi-i-long-right"></i></span>
			</a>
		</div>
		<div class="meta">
			<div class="author-info-wrap">
				<div class="author-name font-1"><a href="https://calexicochronicle.com/author/julio-morales/">Julio Morales</a></div>
							</div>
			<div class="author-right-meta">
												<div class="icons">
														</div>
			</div>
		</div>
	</div>
	<div class="related-posts-wrap clearfix"><div id="block-wrap-36132" class="block-wrap-native block-wrap block-wrap-27 block-css-36132 block-wrap-classic columns__m--1 elements-design-2 block-skin-0 filter-wrap-2 tipi-box ppl-m-3 ppl-s-3 clearfix" data-id="36132" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="block-title-wrap module-block-title clearfix  block-title-wrap-style block-title-1 with-load-more" style="border-bottom-color:#630a1f;"><div class="block-title-area clearfix"><div class="block-title font-1">Related</div></div><div class="filters tipi-flex font-2"><div class="load-more-wrap load-more-size-2 load-more-wrap-2">		<a href="#" data-id="36132" class="tipi-arrow tipi-arrow-s tipi-arrow-l block-loader block-more block-more-1 no-more" data-dir="1"><i class="tipi-i-angle-left" aria-hidden="true"></i></a>
		<a href="#" data-id="36132" class="tipi-arrow tipi-arrow-s tipi-arrow-r block-loader block-more block-more-2" data-dir="2"><i class="tipi-i-angle-right" aria-hidden="true"></i></a>
		</div></div></div><div class="block block-27 tipi-flex"><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base article-ani article-ani-1 tipi-s-typo stack-1 stack-design-1 separation-border loop-0 preview-classic preview__img-shape-s preview-27 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157982 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety tag-crime tag-imperial-county-news tag-imperial-county-sheriff-office tag-police-briefs tag-public-safety"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/imperial-county-sheriffs-office-briefs-march-23-29/" class="mask-img"><img width="390" height="390" src="https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-390x390.jpg" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-390x390.jpg 390w, https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-585x585.jpg 585w" sizes="(max-width: 390px) 100vw, 390px" /></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/public-safety/" class="cat">Public Safety</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/imperial-county-sheriffs-office-briefs-march-23-29/">Imperial County Sheriff’s Office Briefs: March 23-29</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/calexicochronicle/" title="Posts by Calexico Chronicle" class="author url fn" rel="author">Calexico Chronicle</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-04-01T20:25:02-07:00">April 1, 2021</time></span></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base article-ani article-ani-1 tipi-s-typo stack-1 stack-design-1 separation-border loop-1 preview-classic preview__img-shape-s preview-27 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157957 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety tag-calexico-police-department tag-city-of-calexico tag-imperial-county-news tag-police-briefs tag-public-safety"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/calexico-police-briefs-march-21-27/" class="mask-img"><img width="390" height="390" src="https://calexicochronicle.com/wp-content/uploads/2021/02/Calexico-Police-Stock-Patch-390x390.jpg" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/Calexico-Police-Stock-Patch-390x390.jpg 390w, https://calexicochronicle.com/wp-content/uploads/2021/02/Calexico-Police-Stock-Patch-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/02/Calexico-Police-Stock-Patch-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/02/Calexico-Police-Stock-Patch-585x585.jpg 585w, https://calexicochronicle.com/wp-content/uploads/2021/02/Calexico-Police-Stock-Patch-900x900.jpg 900w" sizes="(max-width: 390px) 100vw, 390px" /></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/public-safety/" class="cat">Public Safety</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/calexico-police-briefs-march-21-27/">Calexico Police Briefs: March 21-27</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/staff-report/" title="Posts by STAFF REPORT" class="author url fn" rel="author">STAFF REPORT</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-04-01T18:33:08-07:00">April 1, 2021</time></span></div></div></div></article><article class="tipi-xs-12 elements-location-3 clearfix with-fi ani-base article-ani article-ani-1 tipi-s-typo stack-1 stack-design-1 separation-border loop-2 preview-classic preview__img-shape-s preview-27 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 elements-design-2 post-157916 post type-post status-publish format-standard has-post-thumbnail hentry category-covid19 category-featured-stories category-regional-news tag-african-americans tag-black-community tag-covid tag-covid-vaccine tag-covid-19 tag-imperial-county-news tag-imperial-valley-social-justice-committee tag-medical-racism tag-sweet-home-missionary-baptist-church"><div class="preview-mini-wrap clearfix"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/delivering-covid-vaccine-to-underserved-community/" class="mask-img"><img width="469" height="469" src="https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-469x469.jpg" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-664x664.jpg 664w, https://calexicochronicle.com/wp-content/uploads/2021/04/African-American-vaccine-graphic-979x979.jpg 979w" sizes="(max-width: 469px) 100vw, 469px" /></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-1"><div class="byline-part cats"><span class="byline-in byline-blog-detail">In </span><a href="https://calexicochronicle.com/category/covid19/" class="cat">COVID-19</a><a href="https://calexicochronicle.com/category/featured-stories/" class="cat">Featured Stories</a><a href="https://calexicochronicle.com/category/regional-news/" class="cat">Regional News</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/delivering-covid-vaccine-to-underserved-community/">REACHING PAST STIGMA</a></h3></div><div class="byline byline-3"><span class="byline-part author"><a href="https://calexicochronicle.com/author/briannaluskrangel/" title="Posts by Brianna Lusk Rangel" class="author url fn" rel="author">Brianna Lusk Rangel</a></span><span class="byline-part date"><span class="byline-on byline-blog-detail">on </span><time class="entry-date published dateCreated flipboard-date" datetime="2021-04-01T15:37:49-07:00">April 1, 2021</time></span></div></div></div></article></div></div></div></div></div>			</footer><!-- .entry-footer -->
		</article><!-- #post-x -->
	</main><!-- .site-main -->
	
<div class="block clearfix sidebar-wrap sb-wrap-skin-1 tipi-xs-12 tipi-l-4 tipi-col">
		<aside class="sidebar widget-area bg-area site-img-1 sb-skin-1 widgets-title-skin-4 widgets-skin-4">
		<div class="background"></div>
		<div id="adrotate_widgets-2" class="sidebar-widget zeen-widget clearfix adrotate_widgets"><div class="g g-8"><div class="g-dyn a-34 c-1"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MzQsOCwxLDYw" href="https://cetweb.edu/" target="_blank" rel="nofollow"><img src="https://calexicochronicle.com/wp-content/banners/CenterForEmployment-Ad-2021Spring-Square.jpg" /></a></div></div><div class="g-dyn a-25 c-2"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MjUsOCwxLDYw" href="http://www.sunvalleyb.com/contact-us.php"><img src="https://calexicochronicle.com/wp-content/banners/Sun-Valley-SquareSize-300px.jpg" /></a></div></div><div class="g-dyn a-9 c-3"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="OSw4LDEsNjA=" href="https://www.co.imperial.ca.us/behavioralhealth/"><img src="https://calexicochronicle.com/wp-content/banners/bh_substance_abuse_ad_300x250_08-20.jpg" /></a><h4 style="padding-top:19px;">It's Ok, Seek Help! Get More Information <a class="gofollow" data-track="OSw4LDEsNjA=" href="https://www.co.imperial.ca.us/behavioralhealth/">Here</a></h4></div></div><div class="g-dyn a-30 c-4"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MzAsOCwxLDYw" href="https://bhs.imperialcounty.org/" target="_blank" rel="nofollow"><img src="https://calexicochronicle.com/wp-content/banners/IC-BEH-Health-Ad-2021Spring-FullSquare1.jpg" /></a></div></div><div class="g-dyn a-26 c-5"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MjYsOCwxLDYw" href="https://www.imperialgold.org/" target="_blank" rel="nofollow"><img src="https://calexicochronicle.com/wp-content/banners/Imperial-Gold-Ad-2021Spring-Square2.jpg" /></a></div></div></div></div><div id="search-3" class="sidebar-widget zeen-widget clearfix widget_search"><h3 class="widget-title title">Search Our Site:</h3><form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
</div><div id="zeen_facebook_like_box-2" class="sidebar-widget zeen-widget clearfix zeen_facebook_like_box">		<div class="fb-page"
			  data-href="https://www.facebook.com/calexicochronicle.ivweekly"
			  data-width="600"
			  data-hide-cover="false"
			  data-show-facepile="true"
			  data-small-header="false"
			  data-tabs="timeline"
			  data-show-posts="false"></div>

	<div id="fb-root"></div>
	<script>(function(d, s, id) {
		var js, fjs = d.getElementsByTagName(s)[0];
		if (d.getElementById(id)) return;
		js = d.createElement(s); js.id = id;
		js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2';
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script>

		</div><div id="lets_social_count-2" class="sidebar-widget zeen-widget clearfix lets_social_count"><h3 class="widget-title title">We&#8217;re Social! Let&#8217;s Connect:</h3>		<ul class="lets-social-count-wrap lets-social-count-3 clearfix">
											<li class="network-option network-fb">
								<a href="https://facebook.com/calexicochronicle.ivweekly" target="_blank" rel="noopener nofollow"><span class="icon-wrap"><i class="tipi-i-facebook lsc-facebook"></i></span><span class="icon-content"><span class="icon-action">Like</span><span class="icon-count">6,960</span><span class="icon-title">Fans</span>				</span>
			</a>
			</li>
											<li class="network-option network-in">
								<a href="https://www.instagram.com/calexicochronicle" target="_blank" rel="noopener nofollow"><span class="icon-wrap"><i class="tipi-i-instagram lsc-instagram"></i></span><span class="icon-content"><span class="icon-action">Follow</span><span class="icon-count">550</span><span class="icon-title">Followers</span>				</span>
			</a>
			</li>
											<li class="network-option network-yt">
								<a href="https://www.youtube.com/channel/UCJ4rDxLDu1Bk-pnEzWDoP-A/featured" target="_blank" rel="noopener nofollow"><span class="icon-wrap"><i class="tipi-i-youtube-play lsc-youtube-play"></i></span><span class="icon-content"><span class="icon-action">Subscribe</span><span class="icon-count">13</span><span class="icon-title">Subscribers</span>				</span>
			</a>
			</li>
				</ul>

		</div><div id="adrotate_widgets-3" class="sidebar-widget zeen-widget clearfix adrotate_widgets"><div class="g g-9"><div class="g-single a-9"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="OSw5LDEsNjA=" href="https://www.co.imperial.ca.us/behavioralhealth/"><img src="https://calexicochronicle.com/wp-content/banners/bh_substance_abuse_ad_300x250_08-20.jpg" /></a><h4 style="padding-top:19px;">It's Ok, Seek Help! Get More Information <a class="gofollow" data-track="OSw5LDEsNjA=" href="https://www.co.imperial.ca.us/behavioralhealth/">Here</a></h4></div></div></div></div><div id="media_video-2" class="sidebar-widget zeen-widget clearfix widget_media_video"><h3 class="widget-title title">Recent News Videos</h3><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-157978-1" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=lc86LBS4G4s&#038;list=UL&#038;_=1" /><a href="https://www.youtube.com/watch?v=lc86LBS4G4s&#038;list=UL">https://www.youtube.com/watch?v=lc86LBS4G4s&#038;list=UL</a></video></div></div><div id="adrotate_widgets-4" class="sidebar-widget zeen-widget clearfix adrotate_widgets"><div class="g g-10"><div class="g-dyn a-9 c-1"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="OSwxMCwxLDYw" href="https://www.co.imperial.ca.us/behavioralhealth/"><img src="https://calexicochronicle.com/wp-content/banners/bh_substance_abuse_ad_300x250_08-20.jpg" /></a><h4 style="padding-top:19px;">It's Ok, Seek Help! Get More Information <a class="gofollow" data-track="OSwxMCwxLDYw" href="https://www.co.imperial.ca.us/behavioralhealth/">Here</a></h4></div></div><div class="g-dyn a-32 c-2"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MzIsMTAsMSw2MA==" href="https://pmhd.org/" target="_blank" rel="nofollow"><img src="https://calexicochronicle.com/wp-content/banners/Pioneers-Ad-2021Spring-Banner-300x250.jpg" /></a></div></div><div class="g-dyn a-34 c-3"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MzQsMTAsMSw2MA==" href="https://cetweb.edu/" target="_blank" rel="nofollow"><img src="https://calexicochronicle.com/wp-content/banners/CenterForEmployment-Ad-2021Spring-Square.jpg" /></a></div></div><div class="g-dyn a-31 c-4"><div class="ad-small-text" style="font-size:12px;clear:right;color:#999;">- ADVERTISEMENT -<br /><a class="gofollow" data-track="MzEsMTAsMSw2MA==" href="https://bhs.imperialcounty.org/" target="_blank" rel="nofollow"><img src="https://calexicochronicle.com/wp-content/banners/IC-BEH-Health-Ad-2021Spring-FullSquare2.jpg" /></a></div></div></div></div><div id="zeen_stylish_posts-2" class="sidebar-widget zeen-widget clearfix zeen_stylish_posts"><h3 class="widget-title title">Trending News</h3><div class="zeen-stylish-posts-wrap"><div id="block-wrap-93501" class="block-wrap-native block-wrap block-wrap-55 block-css-93501 block-wrap-slider block-wrap-tiles columns__m--1 elements-design-3 block-skin-0 tipi-box tile-design-wrap-1 rounded-corners clearfix" data-id="93501" data-base="0"><div class="tipi-row-inner-style clearfix"><div class="tipi-row-inner-box contents sticky--wrap"><div class="slider slider-art tipi-spin clearfix" data-ppp="1" data-dir="0" data-s="55" data-effect="0"><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-1 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-157828 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety category-regional-news tag-deadly-crash tag-fatal-collision tag-highway-115 tag-holtville-news tag-imperial-county-news tag-norrish-road"><div class="mask"><a href="https://calexicochronicle.com/2021/03/30/arrest-made-in-deadly-holtville-crash/" class="mask-img"><img width="370" height="247" src="https://calexicochronicle.com/wp-content/uploads/2021/03/Holt-Memorial-0220-scaled-1-370x247.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/03/Holt-Memorial-0220-scaled-1-370x247.jpg 370w, https://calexicochronicle.com/wp-content/uploads/2021/03/Holt-Memorial-0220-scaled-1-300x199.jpg 300w, https://calexicochronicle.com/wp-content/uploads/2021/03/Holt-Memorial-0220-scaled-1-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/03/Holt-Memorial-0220-scaled-1-1155x770.jpg 1155w, https://calexicochronicle.com/wp-content/uploads/2021/03/Holt-Memorial-0220-scaled-1-770x513.jpg 770w" sizes="(max-width: 370px) 100vw, 370px" /></a><a href="https://calexicochronicle.com/2021/03/30/arrest-made-in-deadly-holtville-crash/" class="mask-overlay" aria-label="Arrest Made in Deadly Holtville Crash That Killed 13; Charges Filed"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/richardmontenegro/" title="Posts by Richard Montenegro Brown" class="author url fn" rel="author">Richard Montenegro Brown</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/public-safety/" style="background-color:#630a1f" class="cat cat-with-bg">Public Safety</a><a href="https://calexicochronicle.com/category/regional-news/" style="background-color:#630a1f" class="cat cat-with-bg">Regional News</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/03/30/arrest-made-in-deadly-holtville-crash/">Arrest Made in Deadly Holtville Crash That Killed 13; Charges Filed</a></h3></div></div></article><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-2 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-157919 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety tag-crime tag-el-centro-sector tag-public-safety tag-stash-house tag-u-s-border-patrol tag-undocumented-immigrants"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/border-patrol-takes-down-stash-house-in-imperial/" class="mask-img"><img width="449" height="299" src="https://calexicochronicle.com/wp-content/uploads/2021/04/IID-clone-stash-house-449x299.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/IID-clone-stash-house-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/04/IID-clone-stash-house-360x240.jpg 360w" sizes="(max-width: 449px) 100vw, 449px" /></a><a href="https://calexicochronicle.com/2021/04/01/border-patrol-takes-down-stash-house-in-imperial/" class="mask-overlay" aria-label="Border Patrol Takes Down Stash House in Imperial"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/calexicochronicle/" title="Posts by Calexico Chronicle" class="author url fn" rel="author">Calexico Chronicle</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/public-safety/" style="background-color:#630a1f" class="cat cat-with-bg">Public Safety</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/border-patrol-takes-down-stash-house-in-imperial/">Border Patrol Takes Down Stash House in Imperial</a></h3></div></div></article><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-3 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-157978 post type-post status-publish format-standard has-post-thumbnail hentry category-public-safety category-regional-news tag-asylum-seekers tag-barbara-worth-country-club tag-border-crisis tag-galilee-center-in-mecca tag-holtville-news tag-imperial-county-news tag-migrants tag-public-safety tag-u-s-border-patrol tag-u-s-immigrations-and-customs-enforcement"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/" class="mask-img"><img width="449" height="299" src="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-449x299.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-449x299.jpg 449w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-360x240.jpg 360w, https://calexicochronicle.com/wp-content/uploads/2021/04/Barbara-Worth-overview-4-1-849x565.jpg 849w" sizes="(max-width: 449px) 100vw, 449px" /></a><a href="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/" class="mask-overlay" aria-label="State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/julio-morales/" title="Posts by Julio Morales" class="author url fn" rel="author">Julio Morales</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/public-safety/" style="background-color:#630a1f" class="cat cat-with-bg">Public Safety</a><a href="https://calexicochronicle.com/category/regional-news/" style="background-color:#630a1f" class="cat cat-with-bg">Regional News</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/state-houses-migrants-in-holtville-hotel/">State Pays to House Asylum Seekers in Holtville&#8217;s Barbara Worth Country Club</a></h3></div></div></article><article class="slide tipi-xs-12 clearfix with-fi ani-base tipi-s-typo loop-4 preview-55 preview-slider slider-overlay-1 slider-meta-bg meta-bg-1 meta-edge-1 slider-image-1 img-ani-base img-ani-1 img-color-hover-base img-color-hover-1 tile-design tile-design-1 elements-design-3 post-157895 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion tag-calexico-city-council tag-calexico-mayor tag-city-of-calexico tag-imperial-county-news tag-raul-urena tag-rosie-arreola-fernandez"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/letter-calexico-mayor-takes-on-attacks/" class="mask-img"><img width="238" height="299" src="https://calexicochronicle.com/wp-content/uploads/2021/04/New-Rosie-Fernandez-mug-238x299.jpg" class="attachment-zeen-370-247 size-zeen-370-247 wp-post-image" alt="" /></a><a href="https://calexicochronicle.com/2021/04/01/letter-calexico-mayor-takes-on-attacks/" class="mask-overlay" aria-label="LETTER: Calexico Mayor Takes On Personal Attacks"></a></div><div class="meta"><div class="byline byline-2 byline-cats-design-2"><span class="byline-part author"><a href="https://calexicochronicle.com/author/rosie-arreola-fernandez/" title="Posts by Rosie Arreola Fernandez" class="author url fn" rel="author">Rosie Arreola Fernandez</a></span><div class="byline-part cats"><a href="https://calexicochronicle.com/category/opinion/" style="background-color:#630a1f" class="cat cat-with-bg">Opinion</a></div></div><div class="title-wrap"><h3 class="title"><a href="https://calexicochronicle.com/2021/04/01/letter-calexico-mayor-takes-on-attacks/">LETTER: Calexico Mayor Takes On Personal Attacks</a></h3></div></div></article><span class="slider-arrow slider-arrow-prev slider-arrow-2"><i class="tipi-i-angle-left"></i></span><span class="slider-arrow slider-arrow-next slider-arrow-2"><i class="tipi-i-angle-right"></i></span></div></div></div></div></div></div>	</aside><!-- .sidebar -->
</div>
			</div><!-- .tipi-cols -->
					</div><!-- .tipi-row -->
			</div><!-- .post-wrap -->
		
</div><!-- .content-area -->
		</div><!-- .site-content -->
				<footer id="colophon" class="site-footer site-footer-2 site-img-1 widget-area-borders-1 footer-fs  widget-title-default footer__mob__cols-2 clearfix">
			<div class="bg-area">
								<div class="bg-area-inner">
										<div class="footer-widget-area footer-widget-bg-area footer-widgets tipi-xs-12 clearfix footer-widget-area-5 footer-widgets-skin-3 site-img-1">
	<div class="footer-widget-bg-area-inner tipi-flex tipi-row footer-widget-mob-area tipi-xs-12 tipi-m-0 clearfix">
	<div class="tipi-xs-12 footer-widget-wrap footer-widget-wrap-1 clearfix">
		<aside class="sidebar widget-area">
			<div id="search-4" class="footer-widget footer-widget-mob zeen-widget clearfix widget_search"><h3 class="widget-title title">Search</h3><form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
</div><div id="categories-3" class="footer-widget footer-widget-mob zeen-widget clearfix widget_categories"><h3 class="widget-title title">Sections</h3>
			<ul>
					<li class="cat-item cat-item-3"><a href="https://calexicochronicle.com/category/agriculture/">Agriculture</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://calexicochronicle.com/category/business/">Business</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://calexicochronicle.com/category/community-briefs/">Community Briefs</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://calexicochronicle.com/category/covid19/" title="Stay up-to-date with the latest local developments on the COVID-19 Pandemic.
Follow us on Facebook @calexicochronicle.ivweekly to receive immediate updates.">COVID-19</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://calexicochronicle.com/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://calexicochronicle.com/category/election-coverage/">Election Coverage</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://calexicochronicle.com/category/featured-stories/" title="Covering stories that matter to the community.">Featured Stories</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a>
</li>
	<li class="cat-item cat-item-11"><a href="https://calexicochronicle.com/category/local-news/" title="The Calexico Chronicle has you covered with all your local news. Stay informed about community, school, sports, and any other news that matters to you.">Local News</a>
</li>
	<li class="cat-item cat-item-12"><a href="https://calexicochronicle.com/category/obituaries/">Obituaries</a>
</li>
	<li class="cat-item cat-item-13"><a href="https://calexicochronicle.com/category/opinion/">Opinion</a>
</li>
	<li class="cat-item cat-item-14"><a href="https://calexicochronicle.com/category/public-safety/">Public Safety</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://calexicochronicle.com/category/regional-news/" title="Get your Imperial Valley news here. We go beyond the &#039;instant news&#039;. We like to dig deeper and get to the root of the story. ">Regional News</a>
</li>
	<li class="cat-item cat-item-16"><a href="https://calexicochronicle.com/category/sports/">Sports</a>
</li>
			</ul>

			</div><div id="pages-3" class="footer-widget footer-widget-mob zeen-widget clearfix widget_pages"><h3 class="widget-title title">Services</h3>
			<ul>
				<li class="page_item page-item-144531"><a href="https://calexicochronicle.com/about/">About Us</a></li>
<li class="page_item page-item-155865"><a href="https://calexicochronicle.com/advertising/">Advertising</a></li>
<li class="page_item page-item-144857"><a href="https://calexicochronicle.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-155882"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li class="page_item page-item-155880"><a href="https://calexicochronicle.com/archived-eeditions/">Older E-Editions</a></li>
<li class="page_item page-item-144866"><a href="https://calexicochronicle.com/subscribe/">Subscribe</a></li>
			</ul>

			</div>		</aside><!-- .sidebar .widget-area -->
	</div>
</div><!-- .footer-widget-area -->
	<div class="footer-widget-bg-area-inner tipi-flex tipi-row tipi-xs-0">
					<div class="tipi-xs-6 footer-widget-wrap footer-widget-wrap-1 clearfix">
				<aside class="sidebar widget-area">
					<div id="categories-2" class="footer-widget zeen-widget clearfix widget_categories"><h3 class="widget-title title">Sections</h3>
			<ul>
					<li class="cat-item cat-item-3"><a href="https://calexicochronicle.com/category/agriculture/">Agriculture</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://calexicochronicle.com/category/business/">Business</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://calexicochronicle.com/category/community-briefs/">Community Briefs</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://calexicochronicle.com/category/covid19/" title="Stay up-to-date with the latest local developments on the COVID-19 Pandemic.
Follow us on Facebook @calexicochronicle.ivweekly to receive immediate updates.">COVID-19</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://calexicochronicle.com/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://calexicochronicle.com/category/election-coverage/">Election Coverage</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://calexicochronicle.com/category/featured-stories/" title="Covering stories that matter to the community.">Featured Stories</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a>
</li>
	<li class="cat-item cat-item-11"><a href="https://calexicochronicle.com/category/local-news/" title="The Calexico Chronicle has you covered with all your local news. Stay informed about community, school, sports, and any other news that matters to you.">Local News</a>
</li>
	<li class="cat-item cat-item-12"><a href="https://calexicochronicle.com/category/obituaries/">Obituaries</a>
</li>
	<li class="cat-item cat-item-13"><a href="https://calexicochronicle.com/category/opinion/">Opinion</a>
</li>
	<li class="cat-item cat-item-14"><a href="https://calexicochronicle.com/category/public-safety/">Public Safety</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://calexicochronicle.com/category/regional-news/" title="Get your Imperial Valley news here. We go beyond the &#039;instant news&#039;. We like to dig deeper and get to the root of the story. ">Regional News</a>
</li>
	<li class="cat-item cat-item-16"><a href="https://calexicochronicle.com/category/sports/">Sports</a>
</li>
			</ul>

			</div>				</aside><!-- .sidebar .widget-area -->
			</div>
							<div class="tipi-xs-6 footer-widget-wrap footer-widget-wrap-2 clearfix">
				<aside class="sidebar widget-area">
					<div id="pages-2" class="footer-widget zeen-widget clearfix widget_pages"><h3 class="widget-title title">Services</h3>
			<ul>
				<li class="page_item page-item-144531"><a href="https://calexicochronicle.com/about/">About Us</a></li>
<li class="page_item page-item-155865"><a href="https://calexicochronicle.com/advertising/">Advertising</a></li>
<li class="page_item page-item-144857"><a href="https://calexicochronicle.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-155882"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li class="page_item page-item-155880"><a href="https://calexicochronicle.com/archived-eeditions/">Older E-Editions</a></li>
<li class="page_item page-item-144866"><a href="https://calexicochronicle.com/subscribe/">Subscribe</a></li>
			</ul>

			</div>				</aside><!-- .sidebar .widget-area -->
			</div>
							<div class="tipi-xs-6 footer-widget-wrap footer-widget-wrap-3 clearfix footer-widget-wrap-last">
				<aside class="sidebar widget-area">
					<div id="custom_html-2" class="widget_text footer-widget zeen-widget clearfix widget_custom_html"><h3 class="widget-title title">Contact Information</h3><div class="textwidget custom-html-widget"><a href="https://calexicochronicle.com"><img class="alignnone size-medium wp-image-148863" src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleBlack400x52.png" alt="" width="300" style="padding-bottom: 5px;" /></a>

<div>
<strong>Address:</strong> 1239 W. Main Street, El Centro CA 92243<br />
<strong>Phone:</strong> (760) 339-4899, (760) 356-2995<br />
	<strong>Email:</strong> <a href="mailto:info@calexicochronicle.com">info@calexicochronicle.com</a><br /></div></div></div>				</aside><!-- .sidebar .widget-area -->
			</div>
					</div><!-- .footer-widget-area -->
	<div class="background"></div></div><!-- .footer-widget-area -->
<div class="footer-lower-area footer-area clearfix site-skin-3">
	<div class="tipi-row tipi-flex tipi-xs-flex-full">
		<div class="logo-copyright-block">
			<div class="logo logo-footer"><a href="https://calexicochronicle.com" data-pin-nopin="true"><img src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-416x55-1.png" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-832x110-1.png 2x" data-base-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-416x55-1.png" data-alt-src="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-White-Footer-416x55-1.png" data-base-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-SimpleGarnet-Footer-832x110-1.png 2x" data-alt-srcset="https://calexicochronicle.com/wp-content/uploads/2021/02/CalexicoChronicle-Logo-White-Footer-832x110-1.png 2x" width="416" height="55"><span class="logo-subtitle font-3">Chronicling Our Community, Border Region, and Beyond Since 1904</span></a></div>				<div class="copyright font-2 copyright-l">© 2021 Calexico Chronicle, 1239 W. Main Street, El Centro CA 92243</div>
			</div>
		<div class="tipi-flex-right">
				<ul class="horizontal-menu font-3 menu-icons">
		<li  class="menu-icon menu-icon-style-1 menu-icon-fb"><a href="https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly" data-title="Facebook" class="tipi-i-facebook tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-tw"><a href="https://twitter.com/https://www.twitter.com/holtvilletribu1" data-title="Twitter" class="tipi-i-twitter tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-insta"><a href="https://instagram.com/https://www.instagram.com/calexicochronicle" data-title="Instagram" class="tipi-i-instagram tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-yt"><a href="https://youtube.com/https://www.youtube.com/watch?v=6ReaUBW2Ygk&#038;list=UUJ4rDxLDu1Bk-pnEzWDoP-A" data-title="YouTube" class="tipi-i-youtube-play tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="YouTube" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-rss"><a href="https://calexicochronicle.com/feed/" data-title="RSS" class="tipi-i-rss tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="RSS" target="_blank"></a></li><li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li><li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-move" data-title="Search" data-type="search"></a></li>
			
	
		</ul>
						<nav id="footer-navigation" class="footer-navigation clearfix font-3">
		<ul id="menu-footer-menu" class="footer-menu horizontal-menu"><li id="menu-item-157695" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157695"><a href="https://calexicochronicle.com/subscribe/">Subscribe</a></li>
<li id="menu-item-157696" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157696"><a href="https://calexicochronicle.com/contact-us/">Contact</a></li>
<li id="menu-item-157697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157697"><a href="https://calexicochronicle.com/privacy-policy-2/">Privacy Policy</a></li>
<li id="menu-item-157698" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157698"><a href="https://calexicochronicle.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-157699" class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157699"><a href="https://calexicochronicle.com/credits/">Site Credits</a></li>
</ul>	</nav><!-- .footer-navigation -->
					</div>
	</div>
</div>
					<div class="background"></div>				</div>
			</div>
		</footer><!-- .site-footer -->
		<div id="prev-block__wrap" class="next-prev__design-2 tipi-vertical-c next-prev__prev"><div class="next-prev__trigger tipi-all-c"><i class="tipi-i-arrow-left"></i></div><div class="next-prev__contents"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/imperial-county-sheriffs-office-briefs-march-23-29/" class="mask-img"><img width="100" height="100" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20100%20100&#039;%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail zeen-lazy-load-base zeen-lazy-load  wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-100x100.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-390x390.jpg 390w, https://calexicochronicle.com/wp-content/uploads/2020/11/Imperial-County-Sheriffs-New-Stock-Image-585x585.jpg 585w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="meta"><div class="pre-title">Previous</div><a href="https://calexicochronicle.com/2021/04/01/imperial-county-sheriffs-office-briefs-march-23-29/" class="title">Imperial County Sheriff’s Office Briefs: March 23-29</a></div></div></div><div id="next-block__wrap" class="next-prev__design-2 tipi-vertical-c next-prev__next"><div class="next-prev__trigger tipi-all-c"><i class="tipi-i-arrow-right"></i></div><div class="next-prev__contents"><div class="mask"><a href="https://calexicochronicle.com/2021/04/01/watch-live-central-imperial/" class="mask-img"><img width="100" height="100" src="data:image/svg+xml,%3Csvg%20xmlns=&#039;http://www.w3.org/2000/svg&#039;%20viewBox=&#039;0%200%20100%20100&#039;%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail zeen-lazy-load-base zeen-lazy-load  wp-post-image" alt="" data-lazy-src="https://calexicochronicle.com/wp-content/uploads/2021/04/VSN-Central-@-Imperial-4-1-100x100.jpg" data-lazy-srcset="https://calexicochronicle.com/wp-content/uploads/2021/04/VSN-Central-@-Imperial-4-1-100x100.jpg 100w, https://calexicochronicle.com/wp-content/uploads/2021/04/VSN-Central-@-Imperial-4-1-293x293.jpg 293w, https://calexicochronicle.com/wp-content/uploads/2021/04/VSN-Central-@-Imperial-4-1-372x372.jpg 372w, https://calexicochronicle.com/wp-content/uploads/2021/04/VSN-Central-@-Imperial-4-1-469x469.jpg 469w, https://calexicochronicle.com/wp-content/uploads/2021/04/VSN-Central-@-Imperial-4-1-664x664.jpg 664w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" /></a></div><div class="meta"><div class="pre-title">Next</div><a href="https://calexicochronicle.com/2021/04/01/watch-live-central-imperial/" class="title">WATCH LIVE: Central @ Imperial</a></div></div></div>		
	</div><!-- .site-inner -->

</div><!-- .site -->
<div id="mob-menu-wrap" class="mob-menu-wrap mobile-navigation-dd tipi-m-0 site-skin-3 site-img-1">
	<div class="bg-area">
		<a href="#" class="mob-tr-close tipi-close-icon"><i class="tipi-i-close" aria-hidden="true"></i></a>
		<div class="content-wrap">
			<div class="content">
												<nav class="mobile-navigation mobile-navigation-1"><ul id="menu-mobile" class="menu-mobile vertical-menu font-2"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157700"><a href="https://calexicochronicle.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157701"><a href="https://calexicochronicle.com/category/featured-stories/">Top Stories</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157702"><a href="#">Sections</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157705"><a href="https://calexicochronicle.com/category/featured-stories/">Featured Stories</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157703"><a href="https://calexicochronicle.com/category/local-news/">Local News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent dropper standard-drop menu-item-157704"><a href="https://calexicochronicle.com/category/regional-news/">Regional News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157707"><a href="https://calexicochronicle.com/category/sports/">Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent dropper standard-drop menu-item-157706"><a href="https://calexicochronicle.com/category/public-safety/">Public Safety</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157708"><a href="https://calexicochronicle.com/category/opinion/">Opinion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157712"><a href="https://calexicochronicle.com/category/education/">Education</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157710"><a href="https://calexicochronicle.com/category/business/">Business</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157709"><a href="https://calexicochronicle.com/category/agriculture/">Agriculture</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157711"><a href="https://calexicochronicle.com/category/community-briefs/">Community Briefs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157713"><a href="https://calexicochronicle.com/category/obituaries/">Obituaries</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop menu-item-157714"><a href="https://calexicochronicle.com/category/covid19/">COVID-19</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category dropper standard-drop mm-art mm-wrap-11 mm-wrap mm-color mm-sb-left menu-item-157715"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157716"><a href="https://calexicochronicle.com/e-editions/">E-Editions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page dropper standard-drop mm-art mm-wrap-2 mm-wrap menu-item-157717"><a href="https://calexicochronicle.com/about/">About Us</a></li>
</ul></nav><!-- .mobile-navigation -->				<ul class="menu-icons horizontal-menu">
							<li class="menu-icon menu-icon-subscribe"><a href="#" class="modal-tr" data-type="subscribe"><i class="tipi-i-mail"></i><span class="font-3">Subscribe</span></a></li>
	<li  class="menu-icon menu-icon-style-1 menu-icon-fb"><a href="https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly" data-title="Facebook" class="tipi-i-facebook tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Facebook" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-tw"><a href="https://twitter.com/https://www.twitter.com/holtvilletribu1" data-title="Twitter" class="tipi-i-twitter tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Twitter" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-insta"><a href="https://instagram.com/https://www.instagram.com/calexicochronicle" data-title="Instagram" class="tipi-i-instagram tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="Instagram" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-yt"><a href="https://youtube.com/https://www.youtube.com/watch?v=6ReaUBW2Ygk&#038;list=UUJ4rDxLDu1Bk-pnEzWDoP-A" data-title="YouTube" class="tipi-i-youtube-play tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="YouTube" target="_blank"></a></li><li  class="menu-icon menu-icon-style-1 menu-icon-rss"><a href="https://calexicochronicle.com/feed/" data-title="RSS" class="tipi-i-rss tipi-tip tipi-tip-move" rel="noopener nofollow" aria-label="RSS" target="_blank"></a></li><li class="menu-icon menu-icon-style-1 menu-icon-mode">	<a href="#" class="mode__wrap">
		<span class="mode__inner__wrap tipi-vertical-c tipi-tip tipi-tip-move" data-title="Reading Mode">
			<i class="tipi-i-sun tipi-all-c"></i>
			<i class="tipi-i-moon tipi-all-c"></i>
		</span>
	</a>
	</li><li class="menu-icon menu-icon-style-1 menu-icon-search"><a href="#" class="tipi-i-search modal-tr tipi-tip tipi-tip-move" data-title="Search" data-type="search"></a></li>
			
	
					</ul>
			</div>
		</div>
		<div class="background"></div>	</div>
</div>
<div id="modal" class="modal-wrap inactive" data-fid="">
	<span class="tipi-overlay tipi-overlay-modal"></span>
	<div class="content tipi-vertical-c tipi-row">
		<div class="content-search search-form-wrap content-block">
			<form method="get" class="search tipi-flex" action="https://calexicochronicle.com/">
	<input type="search" class="search-field font-b" placeholder="Search" value="" name="s" autocomplete="off" aria-label="search form">
	<button class="tipi-i-search-thin search-submit" type="submit" value="" aria-label="search"></button>
</form>
			<div class="search-hints">
				<span class="search-hint">
					Start typing to see results or hit ESC to close				</span>
				<div class="suggestions-wrap font-2"><a href="https://calexicochronicle.com/tag/calexico-chronicle/" class="tag-cloud-link tag-link-177 tag-link-position-1" style="font-size: 12px;">Calexico Chronicle</a>
<a href="https://calexicochronicle.com/tag/imperial-county-news/" class="tag-cloud-link tag-link-758 tag-link-position-2" style="font-size: 12px;">Imperial County news</a>
<a href="https://calexicochronicle.com/tag/calexico-news/" class="tag-cloud-link tag-link-195 tag-link-position-3" style="font-size: 12px;">Calexico News</a>
<a href="https://calexicochronicle.com/tag/covid-19/" class="tag-cloud-link tag-link-359 tag-link-position-4" style="font-size: 12px;">Covid-19</a>
<a href="https://calexicochronicle.com/tag/calexico/" class="tag-cloud-link tag-link-166 tag-link-position-5" style="font-size: 12px;">Calexico</a></div>			</div>
			<div class="content-found-wrap"><div class="content-found"></div><div class="button-wrap"><a class="search-all-results button-arrow-r button-arrow tipi-button" href="#"><span class="button-title">See all results</span><i class="tipi-i-arrow-right"></i></a></div></div>		</div>

				<div class="content-lwa content-block site-img-1 site-skin-2">
					<div class="tipi-modal-bg bg-area">
							</div>
				</div>

		<div class="content-custom content-block">
		</div>
	</div>
	<a href="#" class="close tipi-x-wrap tipi-x-outer"><i class="tipi-i-close"></i></a>

</div>
<span id="tipi-overlay" class="tipi-overlay tipi-overlay-base tipi-overlay-dark"><a href="#" class="close tipi-x-wrap"><i class="tipi-i-close"></i></a></span>
<div id="slide-in-box" class="slide-in-box tipi-tile tipi-xs-0 slide-in-2"><i class="tipi-i-close tipi-closer"></i><div class="content"><div class="title">More Stories</div>			<div class="mask"><a href="https://calexicochronicle.com/2020/07/01/state-approves-imperials-amended-roadmap-to-recovery-county-officials-announce/" class="mask-img"><img width="390" height="390" src="https://calexicochronicle.com/wp-content/uploads/2020/07/Munday-and-Plancarte-screen-grab-390x390.png" class="attachment-zeen-390-390 size-zeen-390-390 wp-post-image" alt="" srcset="https://calexicochronicle.com/wp-content/uploads/2020/07/Munday-and-Plancarte-screen-grab-390x390.png 390w, https://calexicochronicle.com/wp-content/uploads/2020/07/Munday-and-Plancarte-screen-grab-100x100.png 100w, https://calexicochronicle.com/wp-content/uploads/2020/07/Munday-and-Plancarte-screen-grab-293x293.png 293w, https://calexicochronicle.com/wp-content/uploads/2020/07/Munday-and-Plancarte-screen-grab-585x585.png 585w, https://calexicochronicle.com/wp-content/uploads/2020/07/Munday-and-Plancarte-screen-grab-770x768.png 770w" sizes="(max-width: 390px) 100vw, 390px" /></a><div class="go-next"><a href="https://calexicochronicle.com/2020/07/01/state-approves-imperials-amended-roadmap-to-recovery-county-officials-announce/"><i class="tipi-i-long-right"></i></a></div></div>

			<div class="entry font-1"><a href="https://calexicochronicle.com/2020/07/01/state-approves-imperials-amended-roadmap-to-recovery-county-officials-announce/">State Approves Imperial’s Amended Roadmap to Recovery, County Officials Announce</a></div>
			</div></div>		<div id="to-top-wrap" class="to-top to-top-2 font-2"><a href="#" id="to-top-a" class="
								tipi-arrow tipi-arrow-m tipi-arrow-t
								">
		<i class="tipi-i-angle-up"></i>					</a></div>
		<span id="lr-check"></span><script type="application/ld+json">{"@context": "http://schema.org",
	"@type": "WebPage",
	"name": "Calexico Chronicle",
	"description": "Chronicling our community, border region, and beyond since 1904","url": "https://calexicochronicle.com/","datePublished": "2021-04-01T20:17:55-07:00","dateCreated": "2021-04-01T20:17:55-07:00","dateModified": "2021-04-01T20:17:57-07:00","sameAs": ["https://facebook.com/https://www.facebook.com/calexicochronicle.ivweekly","https://twitter.com/https://www.twitter.com/holtvilletribu1"],"potentialAction": {
	"@type": "SearchAction",
	"target": "https://calexicochronicle.com/?s=&#123;search_term&#125;",
	"query-input": "required name=search_term"},"breadcrumb":{ "@type": "BreadcrumbList","itemListElement": [{"@type": "ListItem",	"position": 1, "item": {
				"@id": "https://calexicochronicle.com",
				"name": "Home"
				}
				},{"@type": "ListItem",	"position": 2, "item": {
				"@id": "https://calexicochronicle.com/category/public-safety/",
				"name": "Public Safety"
				}
				}]}}</script><style id='zeen-mm-style-inline-css' type='text/css'>
.main-menu-bar-color-2 .menu-main-menu .menu-item-157700.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157700 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157701.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157701 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157702.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157702 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157715.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157715 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157716.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157716 .sub-menu { background: #111;}
.main-menu-bar-color-2 .menu-main-menu .menu-item-157717.drop-it > a:before { border-bottom-color: #111;}.main-navigation .mm-color.menu-item-157717 .sub-menu { background: #111;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://calexicochronicle.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://calexicochronicle.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.7' type='text/css' media='all' />
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/zeen-engine/admin/js/flickity.pkgd.min.js?ver=2.2.0' id='flickity-js'></script>
<script type='text/javascript' id='jshowoff-adrotate-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js' id='jshowoff-adrotate-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1' id='awesome_weather-js'></script>
<script type='text/javascript' id='lets-live-blog-js-js-extra'>
/* <![CDATA[ */
var letsLiveBlogJs = {"root":"https:\/\/calexicochronicle.com\/wp-json\/","nonce":"80db49d8fe","root_point":"codetipi-lets-live-blog\/v1","root_full":"https:\/\/calexicochronicle.com\/wp-json\/codetipi-lets-live-blog\/v1\/","pagiRoot":"\/2021\/04\/01\/state-houses-migrants-in-holtville-hotel\/","data":{"pid":157978,"timeInterval":10000,"i18n":{"ok":"OK","warning":"Warning","delete":"Delete","jumphl":"Jump to highlight","edit":"Edit","live":"Live","ended":"Finished","starting":"Not started","disabled":"Broadcasting Off","publish":"Publish","cancel":"Cancel","success":"Success","successD":"Entry was deleted.","confirmD":"This will permanently delete this entry. Continue?","update":"Update","start":"Start broadcast","stop":"Stop broadcast","highlight":"Highlight","highlightinput":"Summary of highlight"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/lets-live-blog/frontend/js/functions.min.js?ver=1.1.1' id='lets-live-blog-js-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/gsap/gsap.min.js?ver=3.4' id='gsap-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/gsap/ScrollTrigger.min.js?ver=3.4' id='scroll-trigger-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/js.cookie.min.js?ver=2.2.1' id='js-cookie-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/imagesloaded.pkgd.min.js?ver=4.1.4' id='images-loaded-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/menu-aim.min.js?ver=1.9.0' id='menu-aim-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/intersection-observer.min.js?ver=1.0.0' id='intersection-observer-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/swipebox.min.js?ver=1.4.4.1' id='swipebox-js'></script>
<script type='text/javascript' id='zeen-functions-js-extra'>
/* <![CDATA[ */
var zeenJS = {"root":"https:\/\/calexicochronicle.com\/wp-json\/codetipi-zeen\/v1\/","nonce":"80db49d8fe","qry":{"page":0,"year":2021,"monthnum":4,"day":1,"name":"state-houses-migrants-in-holtville-hotel","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":true,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":10,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"},"args":{"siteUrl":"https:\/\/calexicochronicle.com","sDelay":7000,"subL":false,"lazy":true,"lazyNative":false,"iconSorter":"<i class=\"tipi-i-chevron-down\"><\/i>","iplComs":false,"heroFade":0.07499999999999999722444243843710864894092082977294921875,"iplMob":true,"infUrlChange":true,"fbComs":false,"lightbox":true,"lightboxChoice":1,"archiveUrlChange":false,"stickyHeaderCustomize":false,"cookieDuration":90,"searchPpp":3,"iplCached":true,"path":"\/","disqus":false,"subCookie":true,"pluginsUrl":"https:\/\/calexicochronicle.com\/wp-content\/plugins","frontpage":false,"ipl":["lets-review\/assets\/js\/functions.min.js"]},"i18n":{"embedError":"There was a problem with your embed code. Please refer to the documentation for help.","loadMore":"Load More","noMore":"No More Content"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/zeen/assets/js/functions.min.js?ver=3.9.8.4' id='zeen-functions-js'></script>
<script type='text/javascript' id='zeen-functions-js-after'>
	var zeen_65221 = {
		id: 65221,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 61,
		is110: 0,
		counter: 1,
		counter_class: "border",
		post_subtitle: "",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 1,
		fi_off: 0,
		ppp: 3,
		args: {"posts_per_page":3,"trending":{"name":"zeen-trending-now","num":2},"post_type":{"post":"post","e_editions":"e_editions","bookshelf_v1":"bookshelf_v1"}}	};
	
	var zeen_157701 = {
		id: 157701,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 61,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "off",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 1,
		fi_off: 0,
		ppp: 3,
		args: {"cat":"9","post_type":{"post":"post","e_editions":"e_editions","bookshelf_v1":"bookshelf_v1"},"posts_per_page":"3","ignore_sticky_posts":1}	};
	
	var zeen_157715 = {
		id: 157715,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 61,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "off",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 1,
		fi_off: 0,
		ppp: 3,
		args: {"cat":"10","post_type":{"post":"post","e_editions":"e_editions","bookshelf_v1":"bookshelf_v1"},"posts_per_page":"3","ignore_sticky_posts":1}	};
	
	var zeen_40975 = {
		id: 40975,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 23,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 0,
		fi_off: 0,
		ppp: 1,
		args: {"cat":"14,15,","post__not_in":[157978],"posts_per_page":1,"orderby":"rand","date_query":[{"inclusive":true,"after":"3 months ago"}]}	};
	
	var zeen_36132 = {
		id: 36132,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 27,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 0,
		fi_off: 0,
		ppp: 3,
		args: {"post__not_in":[157978],"posts_per_page":3,"post_type":"post","tag":"","cat":"14,15,"}	};
	
	var zeen_93501 = {
		id: 93501,
		next: 2,
		prev: 0,
		target: 0,
		mnp: 0,
		preview: 55,
		is110: 0,
		counter: 0,
		counter_class: "",
		post_subtitle: "",
		excerpt_off: 1,
		excerpt_length: 12,
		excerpt_full: 0,
		img_shape: 0,
		byline_off: 0,
		fi_off: 0,
		ppp: 4,
		args: {"posts_per_page":4,"tag__in":[],"cat":"","orderby":"trending","trending":{"name":"styling-posts-month493501","max":4,"num":30}}	};
	
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5' id='page-links-to-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.7' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.7' id='wp-mediaelement-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-includes/js/mediaelement/renderers/vimeo.min.js?ver=4.2.16' id='mediaelement-vimeo-js'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-2').gslider({ groupid: 2, speed: 12000 });
	jQuery('.g-4').gslider({ groupid: 4, speed: 10000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 12000 });
	jQuery('.g-8').gslider({ groupid: 8, speed: 35000 });
	jQuery('.g-10').gslider({ groupid: 10, speed: 10000 });
}
});
</script>
<!-- /AdRotate JS -->

<script src='https://stats.wp.com/e-202113.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.5',blog:'191296439',post:'157978',tz:'-7',srv:'calexicochronicle.com'} ]);
	_stq.push([ 'clickTrackerInit', '191296439', '157978' ]);
</script>
</body>
</html>