<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	
	<!-- This site is optimized with the Yoast SEO plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>ELECTION UPDATE: 28K Ballots Remain; No Change in Tight IID Div. 4 Race; McCabe School Board Sees Shift - Calexico Chronicle</title>
	<meta name="description" content="Imperial County has until Dec. 3 to certify the Nov. 3 General Election results with around 28,000 mail-in and provisional ballots left to be counted, according to the latest update from the election department." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="ELECTION UPDATE: 28K Ballots Remain; No Change in Tight IID Div. 4 Race; McCabe School Board Sees Shift - Calexico Chronicle" />
	<meta property="og:description" content="Imperial County has until Dec. 3 to certify the Nov. 3 General Election results with around 28,000 mail-in and provisional ballots left to be counted, according to the latest update from the election department." />
	<meta property="og:url" content="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/" />
	<meta property="og:site_name" content="Calexico Chronicle" />
	<meta property="article:publisher" content="https://www.facebook.com//calexicochronicle.ivweekly/" />
	<meta property="article:published_time" content="2020-11-06T08:00:58+00:00" />
	<meta property="article:modified_time" content="2020-11-06T08:59:39+00:00" />
	<meta property="og:image" content="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?fit=768%2C576&#038;ssl=1" />
	<meta property="og:image:width" content="768" />
	<meta property="og:image:height" content="576" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://calexicochronicle.com/#website","url":"https://calexicochronicle.com/","name":"Calexico Chronicle","description":"Serving your community since 1904","potentialAction":[{"@type":"SearchAction","target":"https://calexicochronicle.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?fit=768%2C576&ssl=1","width":768,"height":576,"caption":"A sign outside the County Administration Center in El Centro on Tuesday, Oct. 27, points to an early polling site for the Nov. 3, 2020, General Election. | CORISSA IBARRA PHOTO"},{"@type":"WebPage","@id":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/#webpage","url":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/","name":"ELECTION UPDATE: 28K Ballots Remain; No Change in Tight IID Div. 4 Race; McCabe School Board Sees Shift - Calexico Chronicle","isPartOf":{"@id":"https://calexicochronicle.com/#website"},"primaryImageOfPage":{"@id":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/#primaryimage"},"datePublished":"2020-11-06T08:00:58+00:00","dateModified":"2020-11-06T08:59:39+00:00","author":{"@id":"https://calexicochronicle.com/#/schema/person/ea3f46d24b5d82d53b084563d2ab67c3"},"description":"Imperial County has until Dec. 3 to certify the Nov. 3 General Election results with around 28,000 mail-in and provisional ballots left to be counted, according to the latest update from the election department.","breadcrumb":{"@id":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/"]}]},{"@type":"BreadcrumbList","@id":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://calexicochronicle.com/","url":"https://calexicochronicle.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://calexicochronicle.com/category/election-coverage/","url":"https://calexicochronicle.com/category/election-coverage/","name":"Election Coverage"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/","url":"https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/","name":"ELECTION UPDATE: 28K Ballots Remain; No Change in Tight IID Div. 4 Race; McCabe School Board Sees Shift"}}]},{"@type":"Person","@id":"https://calexicochronicle.com/#/schema/person/ea3f46d24b5d82d53b084563d2ab67c3","name":"Richard Montenegro Brown","sameAs":["walter@ivdesigner.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; Feed" href="https://calexicochronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; Comments Feed" href="https://calexicochronicle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Calexico Chronicle &raquo; ELECTION UPDATE: 28K Ballots Remain; No Change in Tight IID Div. 4 Race; McCabe School Board Sees Shift Comments Feed" href="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/feed/" />
<!-- This site uses the Google Analytics by ExactMetrics plugin v6.2.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.2.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-149073942-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-149073942-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/calexicochronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-show-posts-css'  href='https://calexicochronicle.com/wp-content/plugins/wp-show-posts/css/wp-show-posts-min.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-show-posts-pro-css'  href='https://calexicochronicle.com/wp-content/plugins/wp-show-posts-pro/css/wp-show-posts-min.css?ver=0.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='https://calexicochronicle.com/wp-content/themes/generatepress/css/all.min.css?ver=2.4.2' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-child-css'  href='https://calexicochronicle.com/wp-content/themes/generatepress_child/style.css?ver=1579202050' type='text/css' media='all' />
<link rel='stylesheet' id='wp-featherlight-css'  href='https://calexicochronicle.com/wp-content/plugins/wp-featherlight/css/wp-featherlight.min.css?ver=1.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='generate-blog-images-css'  href='https://calexicochronicle.com/wp-content/plugins/gp-premium/blog/functions/css/featured-images.min.css?ver=1.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='lgc-unsemantic-grid-responsive-tablet-css'  href='https://calexicochronicle.com/wp-content/plugins/lightweight-grid-columns/css/unsemantic-grid-responsive-tablet.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='generate-sticky-css'  href='https://calexicochronicle.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sticky.min.css?ver=1.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-navigation-branding-css'  href='https://calexicochronicle.com/wp-content/plugins/gp-premium/menu-plus/functions/css/navigation-branding.min.css?ver=1.12.1' type='text/css' media='all' />
<style id='generate-navigation-branding-inline-css' type='text/css'>
@media (max-width: 768px){.site-header, #site-navigation, #sticky-navigation{display:none !important;opacity:0.0;}#mobile-header{display:block !important;width:100% !important;}#mobile-header .main-nav > ul{display:none;}#mobile-header.toggled .main-nav > ul, #mobile-header .menu-toggle, #mobile-header .mobile-bar-items{display:block;}#mobile-header .main-nav{-ms-flex:0 0 100%;flex:0 0 100%;-webkit-box-ordinal-group:5;-ms-flex-order:4;order:4;}}.main-navigation .sticky-navigation-logo, .main-navigation.navigation-stick .site-logo:not(.mobile-header-logo){display:none;}.main-navigation.navigation-stick .sticky-navigation-logo{display:block;}.navigation-branding img, .site-logo.mobile-header-logo img{height:60px;width:auto;}.navigation-branding .main-title{line-height:60px;}@media (max-width: 1150px){#site-navigation .navigation-branding, #sticky-navigation .navigation-branding{margin-left:10px;}}@media (max-width: 768px){.main-navigation:not(.slideout-navigation) .main-nav{-ms-flex:0 0 100%;flex:0 0 100%;}.main-navigation:not(.slideout-navigation) .inside-navigation{-ms-flex-wrap:wrap;flex-wrap:wrap;display:-webkit-box;display:-ms-flexbox;display:flex;}.nav-aligned-center .navigation-branding, .nav-aligned-left .navigation-branding{margin-right:auto;}.nav-aligned-center  .main-navigation.has-branding:not(.slideout-navigation) .inside-navigation .main-nav,.nav-aligned-center  .main-navigation.has-sticky-branding.navigation-stick .inside-navigation .main-nav,.nav-aligned-left  .main-navigation.has-branding:not(.slideout-navigation) .inside-navigation .main-nav,.nav-aligned-left  .main-navigation.has-sticky-branding.navigation-stick .inside-navigation .main-nav{margin-right:0px;}}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.9.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.9.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/calexicochronicle.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.2.2' id='exactmetrics-frontend-script-js'></script>
<link rel="https://api.w.org/" href="https://calexicochronicle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://calexicochronicle.com/wp-json/wp/v2/posts/152411" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://calexicochronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://calexicochronicle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://calexicochronicle.com/?p=152411' />
<link rel="alternate" type="application/json+oembed" href="https://calexicochronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcalexicochronicle.com%2F2020%2F11%2Felection-coverage%2Felection-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://calexicochronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcalexicochronicle.com%2F2020%2F11%2Felection-coverage%2Felection-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.9.1 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 {  margin: 0 auto; }
	.g-2 { margin:0px;  float:left; clear:left; }
	.g-3 { margin:0px;  float:right; clear:right; }
	.g-4 {  margin: 0 auto; }
	.g-5 {  margin: 0 auto; }
	.g-6 {  margin: 0 auto; }
	.g-10 { margin:0px;  float:left; clear:left; }
	.g-11 {  margin: 0 auto; }
	.g-14 { min-width:0px; max-width:900px; }
	.b-14 { margin:0px; }
	.g-16 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

		<!--[if lt IE 9]>
			<link rel="stylesheet" href="https://calexicochronicle.com/wp-content/plugins/lightweight-grid-columns/css/ie.min.css" />
		<![endif]-->
	<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://calexicochronicle.com/xmlrpc.php">
<meta name="viewport" content="width=device-width, initial-scale=1"><link rel="icon" href="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2019/09/cropped-Site_Icon_1024x1024.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2019/09/cropped-Site_Icon_1024x1024.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2019/09/cropped-Site_Icon_1024x1024.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2019/09/cropped-Site_Icon_1024x1024.jpg?fit=270%2C270&#038;ssl=1" />
		<style type="text/css" id="wp-custom-css">
			.top-bar .inside-top-bar .textwidget p:last-child {
	padding:8px;
}
.top-bar a:visited{
	color:#1e1e1e;
}
.top-bar a:hover{
	color:#e30000;
}
.category-94 div.top-bar-align-center .inside-top-bar .widget:first-child:last-child{
	display:none;
}

/*Hero Slider styles*/
.uagb-post__title{
	position:relative;
	top:100px;
	right:95px;
	background:#000;
	padding:10px;
}

@media only screen and (max-width: 600px){
	.uagb-post-grid .uagb-post__text{
		box-sizing:content-box!important;
	
	}

	
}

/*AdRotate Queries*/
@media only screen and (max-width: 768px) {
	.mobile-hide{display:none;}
}

@media screen and (min-width: 601px) {
	.desktop-hide{display:none;}
}
		</style>
		</head>

<body class="post-template-default single single-post postid-152411 single-format-standard wp-custom-logo wp-embed-responsive post-image-below-header post-image-aligned-left sticky-menu-fade sticky-enabled both-sticky-menu mobile-header mobile-header-logo mobile-header-sticky wp-featherlight-captions right-sidebar nav-below-header fluid-header one-container active-footer-widgets-0 nav-search-enabled nav-aligned-right header-aligned-left dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<div class="top-bar grid-container grid-parent top-bar-align-center">
			<div class="inside-top-bar grid-container grid-parent">
				<aside id="custom_html-2" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><p>
	<a href="/category/COVID-19"><span style="color:#e30000;">COVID-19:</span> See the latest local updates →</a>
</p></div></aside>			</div>
		</div>
				<nav id="mobile-header" class="main-navigation mobile-header-navigation has-branding has-sticky-branding" itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation grid-container grid-parent">
				<form method="get" class="search-form navigation-search" action="https://calexicochronicle.com/">
				<input type="search" class="search-field" value="" name="s" title="Search" />
			</form><div class="site-logo mobile-header-logo">
						<a href="https://calexicochronicle.com/" title="Calexico Chronicle" rel="home">
							<img src="https://calexicochronicle.com/wp-content/uploads/2019/09/Site_Icon_512x512.jpg" alt="Calexico Chronicle" class="is-logo-image" />
						</a>
					</div>		<div class="mobile-bar-items">
						<span class="search-item">
				<a aria-label="Open Search Bar" href="#">
									</a>
			</span>
		</div><!-- .mobile-bar-items -->
							<button class="menu-toggle" aria-controls="mobile-menu" aria-expanded="false">
						<span class="mobile-menu">Menu</span>					</button>
					<div id="mobile-menu" class="main-nav"><ul id="menu-main-menu" class=" menu sf-menu"><li id="menu-item-13703" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-13703"><a href="https://calexicochronicle.com/">Home</a></li>
<li id="menu-item-144852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144852"><a href="https://calexicochronicle.com/category/featured-stories/">Top Stories</a></li>
<li id="menu-item-144863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-144863"><a href="https://calexicochronicle.com/category/calexico-local-news/">Local News<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li id="menu-item-151639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151639"><a href="https://calexicochronicle.com/category/press-release/">Press Release</a></li>
	<li id="menu-item-145008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145008"><a href="https://calexicochronicle.com/category/business-buzz/">Business Buzz</a></li>
	<li id="menu-item-144856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144856"><a href="https://calexicochronicle.com/category/calexico-local-news/local-sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-151507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151507"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a></li>
<li id="menu-item-144952" class="menu-item menu-item-type-post_type_archive menu-item-object-e_editions menu-item-144952"><a href="https://calexicochronicle.com/e_editions/">E-Editions</a></li>
<li id="menu-item-144533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144533"><a href="https://calexicochronicle.com/about-calexico-chronicle/">About Us</a></li>
<li class="search-item"><a aria-label="Open Search Bar" href="#"></a></li></ul></div>			</div><!-- .inside-navigation -->
		</nav><!-- #site-navigation -->
				<nav id="site-navigation" class="has-branding has-sticky-branding main-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation grid-container grid-parent">
				<div class="navigation-branding"><div class="site-logo">
						<a href="https://calexicochronicle.com/" title="Calexico Chronicle" rel="home">
							<img  class="header-image is-logo-image" alt="Calexico Chronicle" src="https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2019/11/clxchronicle_logo_White_701px.png?fit=695%2C98&#038;ssl=1" title="Calexico Chronicle" srcset="https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2019/11/clxchronicle_logo_White_701px.png?fit=695%2C98&#038;ssl=1 1x, https://calexicochronicle.com/wp-content/uploads/2019/11/clxchronicle_logo_White_701px.png 2x" width="695" height="98" />
						</a>
					</div><div class="sticky-navigation-logo">
					<a href="https://calexicochronicle.com/" title="Calexico Chronicle" rel="home">
						<img src="https://calexicochronicle.com/wp-content/uploads/2019/09/Site_Icon_512x512.jpg" class="is-logo-image" alt="Calexico Chronicle" />
					</a>
				</div></div><form method="get" class="search-form navigation-search" action="https://calexicochronicle.com/">
				<input type="search" class="search-field" value="" name="s" title="Search" />
			</form>		<div class="mobile-bar-items">
						<span class="search-item">
				<a aria-label="Open Search Bar" href="#">
									</a>
			</span>
		</div><!-- .mobile-bar-items -->
						<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
					<span class="mobile-menu">Menu</span>				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-main-menu-1" class=" menu sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-13703"><a href="https://calexicochronicle.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144852"><a href="https://calexicochronicle.com/category/featured-stories/">Top Stories</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-144863"><a href="https://calexicochronicle.com/category/calexico-local-news/">Local News<span role="presentation" class="dropdown-menu-toggle"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151639"><a href="https://calexicochronicle.com/category/press-release/">Press Release</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145008"><a href="https://calexicochronicle.com/category/business-buzz/">Business Buzz</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144856"><a href="https://calexicochronicle.com/category/calexico-local-news/local-sports/">Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151507"><a href="https://calexicochronicle.com/category/legal-notices/">Legal Notices</a></li>
<li class="menu-item menu-item-type-post_type_archive menu-item-object-e_editions menu-item-144952"><a href="https://calexicochronicle.com/e_editions/">E-Editions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144533"><a href="https://calexicochronicle.com/about-calexico-chronicle/">About Us</a></li>
<li class="search-item"><a aria-label="Open Search Bar" href="#"></a></li></ul></div>			</div><!-- .inside-navigation -->
		</nav><!-- #site-navigation -->
		
	<div id="page" class="hfeed site grid-container container grid-parent">
				<div id="content" class="site-content">
			
	<div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75">
		<main id="main" class="site-main">
			
<article id="post-152411" class="post-152411 post type-post status-publish format-standard has-post-thumbnail hentry category-election-coverage tag-election-news tag-election-update tag-imperial-county-news tag-imperial-irrigation-district tag-mccabe-school-board tag-nov-3-general-election" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
		
		<header class="entry-header">
			<div style="font-size:12px;">
	<span><span><a href="https://calexicochronicle.com/">Home</a> » <span><a href="https://calexicochronicle.com/category/election-coverage/">Election Coverage</a> » <span class="breadcrumb_last" aria-current="page">ELECTION UPDATE: 28K Ballots Remain; No Change in Tight IID Div. 4 Race; McCabe School Board Sees Shift</span></span></span></span>
</div><h1 class="entry-title" itemprop="headline">ELECTION UPDATE: 28K Ballots Remain; No Change in Tight IID Div. 4 Race; McCabe School Board Sees Shift</h1>			<div class="entry-meta">
				<span class="posted-on"><a href="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/" title="12:00 am" rel="bookmark"><time class="updated" datetime="2020-11-06T00:59:39-08:00" itemprop="dateModified">November 6, 2020</time><time class="entry-date published" datetime="2020-11-06T00:00:58-08:00" itemprop="datePublished">November 6, 2020</time></a></span>  <span class="byline"><a href="https://calexicochronicle.com/author/richardmontenegro/" title="Posts by Richard Montenegro Brown" class="author url fn" rel="author">Richard Montenegro Brown</a></span>			</div><!-- .entry-meta -->
					
		</header><!-- .entry-header -->

		<div class="featured-image  page-header-image-single ">
				<img width="768" height="576" src="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?fit=768%2C576&amp;ssl=1" class="attachment-900x9999x size-900x9999x" alt="Election Day Looms for Dozens of Local Races" loading="lazy" itemprop="image" srcset="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?w=768&amp;ssl=1 768w, https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?resize=300%2C225&amp;ssl=1 300w" sizes="(max-width: 768px) 100vw, 768px" data-attachment-id="152189" data-permalink="https://calexicochronicle.com/2020/10/calexico-local-news/election-day-looms-for-dozens-of-local-races/attachment/election-preview-10-29-6742/#main" data-orig-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?fit=768%2C576&amp;ssl=1" data-orig-size="768,576" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone XR&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1603800248&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.25&quot;,&quot;iso&quot;:&quot;25&quot;,&quot;shutter_speed&quot;:&quot;0.00013513513513514&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Election Day Looms for Dozens of Local Races" data-image-description="" data-medium-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/10/Election-preview-10-29-6742.jpg?fit=768%2C576&amp;ssl=1" />
			</div><div class="featured_caption">A sign outside the County Administration Center in El Centro on Tuesday, Oct. 27, points to an early polling site for the Nov. 3, 2020, General Election. | CORISSA IBARRA PHOTO</div>		
		<div class="entry-content" itemprop="text">
			<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-152411" class="share-twitter sd-button share-icon no-text" href="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-152411" class="share-facebook sd-button share-icon no-text" href="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-152411" class="share-pinterest sd-button share-icon no-text" href="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<p>Imperial County has until Dec. 3 to certify the Nov. 3 General Election results with around 28,000 mail-in and provisional ballots left to be counted, according to the latest update from the election department.</p>



<p>With just 793 additional ballots tallied across the county in the past 24 hours, there were few significant changes in the daily summary report issued at 5:26 p.m. Thursday, Nov. 5.</p>



<p>That already-large number of unprocessed ballots does have the potential to grow; California counties can accept mail-in ballots through Nov. 20 if they are postmarked by Election Day, Nov. 3.</p>



<p>“Due to the unprecedented amount of vote-by-mail and provisional ballots received by the Registrar’s Office, final tallying of ballots could take longer than previous elections,” according to the press release that accompanied the most recent report.</p>



<p>Voter turnout as of the Nov. 5 report is 26.44 percent, with some 22,238 ballots counted from the 84,123 eligible registered voters in the county.</p>



<p>Projected total turnout would be 59.72 percent for Imperial County if no other ballots are received beyond the estimated 28,000 in possession of the Registrar’s Office.</p>



<p><strong>IID Div. 4 Race Tight</strong> </p>



<p>Meanwhile, possibly the most significant race hanging in the balance is the Division 4 run-off for the Imperial Irrigation District Board of Directors between incumbent Erik Ortega and challenger Javier Gonzalez, who led by just 20 votes, according to the Nov. 5 report.</p>



<p>Following the three most recent ballot reports, Gonzalez’s lead has gone from more than 40 votes on Election Night, to just 14 votes after the 5 p.m. Wednesday, Nov. 4, report.</p>



<p>A first-time political candidate and community organizer, Gonzalez had 2,107 votes, or 50.24 percent of the ballots cast in the 27-precinct division in the Calexico area. Ortega, who is seeking his second term on the IID board, has 2,087 votes, or 49.76 percent.</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img data-attachment-id="151268" data-permalink="https://calexicochronicle.com/2020/09/calexico-local-news/calexico-council-candidate-forum-sees-poor-participation/attachment/zoom-iid-div-4-9-19/#main" data-orig-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/09/Zoom-IID-Div.-4-9-19.png?fit=696%2C203&amp;ssl=1" data-orig-size="696,203" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Zoom IID Div. 4 9-19" data-image-description="" data-medium-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/09/Zoom-IID-Div.-4-9-19.png?fit=300%2C88&amp;ssl=1" data-large-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/09/Zoom-IID-Div.-4-9-19.png?fit=696%2C203&amp;ssl=1" loading="lazy" width="696" height="203" src="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/09/Zoom-IID-Div.-4-9-19.png?resize=696%2C203&#038;ssl=1" alt="" class="wp-image-151268" srcset="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/09/Zoom-IID-Div.-4-9-19.png?w=696&amp;ssl=1 696w, https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/09/Zoom-IID-Div.-4-9-19.png?resize=300%2C88&amp;ssl=1 300w" sizes="(max-width: 696px) 100vw, 696px" data-recalc-dims="1" /><figcaption>Imperial Irrigation District Board of Directors Division 4 runoff candidates, incumbent Erik Ortega (from left) and Javier G. Gonzalez, participate in the Sept. 19 candidate forum put on by the Imperial Valley Social Justice Committee and Imperial Valley College Students for Political Awareness and Action. | VIDEO SCREEN CAPTURE</figcaption></figure></div>



<p>Only 74 new ballots were counted in that race the past 24 hours. Some 17,670 registered voters are in the division.</p>



<p>The race is significant in that it will decide one of five members of the county’s water and power district, a hugely influential political body that oversees a larger annual operating budget ($560 million on the power side; $290 million on the water side) than the county of Imperial ($540 million).</p>



<p>Incumbent Ortega thinks he will win, saying the historical turnout in the division is in his favor. <a href="https://calexicochronicle.com/2020/11/election-coverage/iid-board-gonzalezs-lead-over-div-4-incumbent-ortega-narrows-to-14-votes/" target="_blank" rel="noreferrer noopener">To read what Ortega and Gonzalez had to say, check out our coverage of the race here</a>. &nbsp;</p>



<p><strong>McCabe School Board Shift</strong></p>



<p>The only race to register a change in the past 24 hours is the race for the third and final seat on the McCabe Union Elementary School District Board of Trustee in El Centro.</p>



<div class="wp-block-image"><figure class="alignleft size-large is-resized"><img data-attachment-id="152417" data-permalink="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/attachment/mccabe-michael-mcfadden-mug/#main" data-orig-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Michael-McFadden-mug.png?fit=484%2C604&amp;ssl=1" data-orig-size="484,604" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MCCABE Michael McFadden mug" data-image-description="" data-medium-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Michael-McFadden-mug.png?fit=240%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Michael-McFadden-mug.png?fit=484%2C604&amp;ssl=1" loading="lazy" src="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Michael-McFadden-mug.png?resize=180%2C225&#038;ssl=1" alt="" class="wp-image-152417" width="180" height="225" srcset="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Michael-McFadden-mug.png?w=484&amp;ssl=1 484w, https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Michael-McFadden-mug.png?resize=240%2C300&amp;ssl=1 240w" sizes="(max-width: 180px) 100vw, 180px" data-recalc-dims="1" /><figcaption>Michael T. McFadden | COURTESY PHOTO</figcaption></figure></div>



<div class="wp-block-image"><figure class="alignright size-large is-resized"><img data-attachment-id="152418" data-permalink="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/attachment/mccabe-alec-hendry-mug/#main" data-orig-file="https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Alec-Hendry-mug.png?fit=287%2C371&amp;ssl=1" data-orig-size="287,371" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MCCABE Alec Hendry mug" data-image-description="" data-medium-file="https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Alec-Hendry-mug.png?fit=232%2C300&amp;ssl=1" data-large-file="https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Alec-Hendry-mug.png?fit=287%2C371&amp;ssl=1" loading="lazy" src="https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Alec-Hendry-mug.png?resize=159%2C205&#038;ssl=1" alt="" class="wp-image-152418" width="159" height="205" srcset="https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Alec-Hendry-mug.png?w=287&amp;ssl=1 287w, https://i1.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Alec-Hendry-mug.png?resize=232%2C300&amp;ssl=1 232w" sizes="(max-width: 159px) 100vw, 159px" data-recalc-dims="1" /><figcaption>Alec Austin Hendry | COURTESY PHOTO</figcaption></figure></div>



<p>Incumbent Michael T. McFadden and challenger Alec Austin Hendry traded position in the last day, with Hendry falling to fourth place behind McFadden.</p>



<p>Just four votes separate McFadden and Hendry, as of Nov. 5.</p>



<p>McFadden had 504 votes, or 18.79 percent of the ballots cast in the 20-precinct district, with some 3,920 registered voters. Hendry had 500 votes, or 18.64 percent.</p>



<div class="wp-block-image"><figure class="alignleft size-large is-resized"><img data-attachment-id="152415" data-permalink="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/attachment/mccabe-karina-alvarez-mug/#main" data-orig-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Karina-Alvarez-mug.jpg?fit=391%2C411&amp;ssl=1" data-orig-size="391,411" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1604618533&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MCCABE Karina Alvarez mug" data-image-description="" data-medium-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Karina-Alvarez-mug.jpg?fit=285%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Karina-Alvarez-mug.jpg?fit=391%2C411&amp;ssl=1" loading="lazy" src="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Karina-Alvarez-mug.jpg?resize=183%2C192&#038;ssl=1" alt="" class="wp-image-152415" width="183" height="192" srcset="https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Karina-Alvarez-mug.jpg?w=391&amp;ssl=1 391w, https://i0.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Karina-Alvarez-mug.jpg?resize=285%2C300&amp;ssl=1 285w" sizes="(max-width: 183px) 100vw, 183px" data-recalc-dims="1" /><figcaption>Karina B. Alvarez | COURTESY PHOTO</figcaption></figure></div>



<div class="wp-block-image"><figure class="alignright size-large is-resized"><img data-attachment-id="152416" data-permalink="https://calexicochronicle.com/2020/11/election-coverage/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift/attachment/mccabe-edgar-aguilar-mug/#main" data-orig-file="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Edgar-Aguilar-mug.jpg?fit=235%2C292&amp;ssl=1" data-orig-size="235,292" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1604618478&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MCCABE Edgar Aguilar mug" data-image-description="" data-medium-file="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Edgar-Aguilar-mug.jpg?fit=235%2C292&amp;ssl=1" data-large-file="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Edgar-Aguilar-mug.jpg?fit=235%2C292&amp;ssl=1" loading="lazy" src="https://i2.wp.com/calexicochronicle.com/wp-content/uploads/2020/11/MCCABE-Edgar-Aguilar-mug.jpg?resize=172%2C214&#038;ssl=1" alt="" class="wp-image-152416" width="172" height="214" data-recalc-dims="1" /><figcaption>Dr. Edgar Aguilar | COURTESY PHOTO</figcaption></figure></div>



<p>The first and second seats on the board look to be firmly at hand, with 32.4 percent of the district ballots having been counted.</p>



<p>Leading the race is incumbent Karina B. Alvarez, with 717 votes, or 26.73 percent, followed by challenger, Dr. Edgar Aguilar, with 539 votes, or 20.1 percent.</p>



<p>Incumbent Charles “Chip” Corfman is bringing up the rear with 422 votes, or 15.73 percent.</p>



<p>The Registrar’s Office is expected to release daily summary reports at 5 p.m. Mondays through Fridays until the count is complete or until certification.</p>
		</div><!-- .entry-content -->

					<footer class="entry-meta">
				<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://calexicochronicle.com/category/election-coverage/" rel="category tag">Election Coverage</a></span> 		<nav id="nav-below" class="post-navigation">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://calexicochronicle.com/2020/11/featured-stories/election-turnout-could-be-epic-in-imperial-county/" rel="prev">Imperial County Could Be Looking at Epic Election Turnout</a></span></div>		</nav><!-- #nav-below -->
					</footer><!-- .entry-meta -->
			</div><!-- .inside-article -->
</article><!-- #post-## -->
		</main><!-- #main -->
	</div><!-- #primary -->

	<div id="right-sidebar" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="calendar-1" class="widget inner-padding widget_calendar"><h2 class="widget-title">Stories by Date</h2><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>November 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="6" class="pad">&nbsp;</td><td>1</td>
	</tr>
	<tr>
		<td><a href="https://calexicochronicle.com/2020/11/02/" aria-label="Posts published on November 2, 2020">2</a></td><td><a href="https://calexicochronicle.com/2020/11/03/" aria-label="Posts published on November 3, 2020">3</a></td><td><a href="https://calexicochronicle.com/2020/11/04/" aria-label="Posts published on November 4, 2020">4</a></td><td><a href="https://calexicochronicle.com/2020/11/05/" aria-label="Posts published on November 5, 2020">5</a></td><td id="today"><a href="https://calexicochronicle.com/2020/11/06/" aria-label="Posts published on November 6, 2020">6</a></td><td>7</td><td>8</td>
	</tr>
	<tr>
		<td>9</td><td>10</td><td>11</td><td>12</td><td>13</td><td>14</td><td>15</td>
	</tr>
	<tr>
		<td>16</td><td>17</td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td>
	</tr>
	<tr>
		<td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
	</tr>
	<tr>
		<td>30</td>
		<td class="pad" colspan="6">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://calexicochronicle.com/2020/10/">&laquo; Oct</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></aside><aside id="adrotate_widgets-2" class="widget inner-padding adrotate_widgets"><div class="g g-10"><div class="g-single a-10"><div class="loop-ads"><p style="font-size:xx-small;padding-bottom:0px;">-Advertisement-</p>
<div class="wp-show-posts-image zoom wpsp-image-center"><a class="gofollow" data-track="MTAsMTAsMSw2MA==" href="https://www.co.imperial.ca.us/behavioralhealth/"><img src="https://i1.wp.com/calexicochronicle.com/wp-content/banners/bh_substance_abuse_ad_300x250_08-20.jpg?ssl=1" /></a><h4 style="padding-top:19px;">It's Ok, Seek Help! Get More Information <a class="gofollow" data-track="MTAsMTAsMSw2MA==" href="https://www.co.imperial.ca.us/behavioralhealth/">Here</a></h4></div>
</div></div></div></aside>	</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->

	</div><!-- #content -->
</div><!-- #page -->


<div class="site-footer footer-bar-active footer-bar-align-right">
			<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
			<div class="inside-site-info grid-container grid-parent">
						<div class="footer-bar">
			<aside id="nav_menu-2" class="widget inner-padding widget_nav_menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-145381" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-145381"><a href="https://calexicochronicle.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-144920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144920"><a href="https://calexicochronicle.com/contact-us/">Contact Us</a></li>
</ul></div></aside>		</div>
						<div class="copyright-bar">
					&copy; 2020 <span style="color:#FFF;font-weight:500">Calexico Chronicle</span>				</div>
			</div>
		</footer><!-- .site-info -->
		</div><!-- .site-footer -->

<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
				<span class="screen-reader-text">Scroll back to top</span>
				
			</a>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/calexicochronicle.com\/2020\/11\/election-coverage\/election-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift\/":152411};
	</script>
						<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=1.12.1' id='generate-sticky-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' id='generate-smooth-scroll-js-extra'>
/* <![CDATA[ */
var smooth = {"elements":[".smooth-scroll","li.smooth-scroll a"],"duration":"800"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/gp-premium/general/js/smooth-scroll.min.js?ver=1.12.1' id='generate-smooth-scroll-js'></script>
<!--[if lte IE 11]>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/generatepress/js/classList.min.js?ver=2.4.2' id='generate-classlist-js'></script>
<![endif]-->
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/generatepress/js/menu.min.js?ver=2.4.2' id='generate-menu-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/generatepress/js/a11y.min.js?ver=2.4.2' id='generate-a11y-js'></script>
<script type='text/javascript' id='generate-navigation-search-js-extra'>
/* <![CDATA[ */
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
/* ]]> */
</script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/generatepress/js/navigation-search.min.js?ver=2.4.2' id='generate-navigation-search-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/themes/generatepress/js/back-to-top.min.js?ver=2.4.2' id='generate-back-to-top-js'></script>
<script type='text/javascript' src='https://calexicochronicle.com/wp-content/plugins/wp-featherlight/js/wpFeatherlight.pkgd.min.js?ver=1.3.4' id='wp-featherlight-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/calexicochronicle.com\/wp-admin\/admin-ajax.php","nonce":"e9ca1ecdb4","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/calexicochronicle.com\/clxlogin\/?redirect_to=https%3A%2F%2Fcalexicochronicle.com%2F2020%2F11%2Felection-coverage%2Felection-update-28k-ballots-remain-no-change-in-tight-iid-div-4-race-mccabe-school-board-sees-shift%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202045.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'167098462',post:'152411',tz:'-8',srv:'calexicochronicle.com'} ]);
	_stq.push([ 'clickTrackerInit', '167098462', '152411' ]);
</script>

</body>
</html>
